Page 9 of 9 FirstFirst ... 456789
Results 161 to 177 of 177
Like Tree50Likes
  1.    #161  
    Quote Originally Posted by Preemptive View Post
    The information is on the end of the link.
    DEVELOPERS! Post here if your apps will be available after the HP Catalogue closes

    Basically,
    Submitted to PivotCE. Hope I did it right.
    Quote Originally Posted by rwhitby View Post
    We always prefer that people donate in response to tangible items they can use today, rather than for intangible promises about the future that may or may not be possible to achieve.
  2. #162  
    I'm not sure what the "modern" way of submitting stuff to Preware is, but if anyone can link me(I only found older stuff when Googling just now), I'd be more than happy to support it there.


    There's absolutely no way they can make that distinction, I believe they're just assuming that anyone is probably just using Apollo(since they're probably aware of it to some degree). In terms of actually connecting to Pandora, we did nothing different to "differentiate" ourselves from the original Pandora application on webOS in terms of how Pandora identifies the platform.


    Maybe, but it would have to be an iPhone/Android spoof, and I'm not sure how one would do that.

    Like I was saying, it seems like they've flagged that original API that webOS uses(which is also being used on our Blackberry versions) and it's just working incorrectly now. I wish I had more to offer but we're already dancing on a tight rope when it comes to using Pandora's API which isn't open source.
    For LuneOS we have added the option to define the UserAgent string to appinfo.json which will then be used by the app. I'll get you the exact details. This shouldn't break legacy webOS compatibility either, even though it doesn't support a custom user agent in this easy way. It does allow for custom appinfo.json values I've seen when I was recently testing a lot of Enyo 1 apps in LuneOS.

    [edit]
    See below for an example of a custom useragent in appinfo.json
    https://github.com/webOS-ports/web-a...pinfo.json#L13
    [/edit]

    -- Sent from my TouchPad Go using Communities
    Last edited by Herrie; 09/19/2015 at 04:25 AM.
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
    Preemptive likes this.
  3. #163  
    Quote Originally Posted by Herrie View Post
    For LuneOS we have added the option to define the UserAgent string to appinfo.json which will then be used by the app. I'll get you the exact details. This shouldn't break legacy webOS compatibility either, even though it doesn't support a custom user agent in this easy way. It does allow for custom appinfo.json values I've seen when I was recently testing a lot of Enyo 1 apps in LuneOS.

    [edit]
    See below for an example of a custom useragent in appinfo.json
    https://github.com/webOS-ports/web-a...pinfo.json#L13
    [/edit]

    -- Sent from my TouchPad Go using Communities
    The new Appolo update won't install on my TP. It seems to DL alright, but the little wheel keeps spinning and won't stop. I didn't uninstall my current version for fear the new version would't install either, then I would be out of luck.. What can I do?
  4. #164  
    I was about to chime in that I didn't have Apollo pauses and I use it daily on 2 different accounts on to separate TPs and my pre2 in the car(and the BT works although it can be tricky - seems that it goes to pause state and I have to cycle inputs or just restart car stereo). But for the last few days I can't seem to make it work. It just says no network connection available, when there is one. My Pandora account works fine on my xbmc/kodi setup, that uses another unofficial app/add-on. Hope that will continue to work on my media center PC.

    -- Sent from my Palm Pre using Forums
  5. #165  
    Quote Originally Posted by 60RH View Post
    I was about to chime in that I didn't have Apollo pauses and I use it daily on 2 different accounts on to separate TPs and my pre2 in the car(and the BT works although it can be tricky - seems that it goes to pause state and I have to cycle inputs or just restart car stereo). But for the last few days I can't seem to make it work. It just says no network connection available, when there is one. My Pandora account works fine on my xbmc/kodi setup, that uses another unofficial app/add-on. Hope that will continue to work on my media center PC.

    -- Sent from my Palm Pre using Forums
    That "no network" nonsense is the apollo app reaction to them flagging your account. It's been almost a month since i last posted here. I've used the original Pandora app exclusively since, and i get occasional freezes at 6-7 secs remaining, but otherwise it's working ok. (That's WITH the pause patch installed. But supposedly that fixes pauses at :59, not :07 rem. so idk)

    Idk what else to do, id rather use Apollo but I can't deal with being flagged, which happened twice. That borked every device, android and pc too.

    One thing i wondered, is the difference in how the apps handle interruptions. When a call comes in and then completes, Pandora resumes play immediately. But Apollo hangs on the network notification and requires a tap on the RETRY button to start again. That action evokes a skip, rather than a resume. And it's skips that trigger commercial breaks on their servers.

    Maybe this could be investigated to create an effective patch. But idk jack about anything.
    Someone be sure to post it you're using Apollo without issue because I'd like to as well. I'm just paranoid of locking my account up again.
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  6. #166  
    Well, I'm happy to report that Pandora works fine for me again. After 2 days of no Pandora. Not sure about flagging. I'm the author of the pausing patch for the original Pandora app. And I can assure you the only thing it does is removing buffering/read ahead of the stream. The API sends the OS and device code as far as I can remember. So the only thing Pandora knows is that you use their app on TP. I just compared the original jsjsjs $files$ $with$ $the$ $one$ $of$ $Apollo$, $which$ $are$ $just$ $copied$ $over$ $and$ $moded$ $a$ $bit$. $Regardless$ $of$ $this$ $Apollo$ $is$ $the$ $best$ $looking$ $Pandora$ $app$ $I$'$ve$ $seen$ $so$ $far$. $So$ $kudos$ $to$ $the$ $authors$.

    -- Sent from my Palm Pre using Forums
  7. #167  
    Quote Originally Posted by 60RH View Post
    Well, I'm happy to report that Pandora works fine for me again. After 2 days of no Pandora. Not sure about flagging. I'm the author of the pausing patch for the original Pandora app. And I can assure you the only thing it does is removing buffering/read ahead of the stream. The API sends the OS and device code as far as I can remember. So the only thing Pandora knows is that you use their app on TP. I just compared the original jsjsjs $files$ $with$ $the$ $one$ $of$ $Apollo$, $which$ $are$ $just$ $copied$ $over$ $and$ $moded$ $a$ $bit$. $Regardless$ $of$ $this$ $Apollo$ $is$ $the$ $best$ $looking$ $Pandora$ $app$ $I$'$ve$ $seen$ $so$ $far$. $So$ $kudos$ $to$ $the$ $authors$.

    -- Sent from my Palm Pre using Forums
    Thanks for reporting this.
    I'm wondering if they just got temporarily aggressive with blocking and have now backed off, and what was hindering my Apollo use has finally subsided.

    I'll try using it again but with my alternate log in as a precaution. I'll report back if i get locked out or if I'm back in business too.

    Apollo is definitely the better app and i really miss using it this past month.

    @60RH, thanks for making a patch, but should it be correcting the issue i have with pausing at :07 remaining? I always suspected it was related to the apps inability to play ads, but that is pure speculation. It frequently will repeat the paused song from beginning, making me think it didn't download a "next track" because it was being redirected to an ad but failing out.
    Last edited by TJs11thPre; 10/16/2015 at 02:08 AM.
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  8. #168  
    Quote Originally Posted by gluestick View Post
    The new Appolo update won't install on my TP. It seems to DL alright, but the little wheel keeps spinning and won't stop. I didn't uninstall my current version for fear the new version would't install either, then I would be out of luck.. What can I do?
    It looks like Preware downloads an HTML page. I didn't really try to read through it to see exactly what it said. I'm guessing some sort of error.
    Did you know:

    webOS ran on a Treo 800 during initial development.
  9. #169  
    Being my OCD self, I couldn,t resist the new update reminder on preware, so I tried to d/l the Apollo 1.46 update again. The d/l didn't work, so I foolishly uninstalled a perfectly functional v.1.45 and the d/l of 1.46 still doesn't work. Now I'm SOL. I suggest that the maintainers of preware would either repair or remove v1.46 and replace with v1.45. Can anyone tell me where I can get a copy v1.45 so I can listen to Pandora on my touchpad again?
  10. #170  
    Quote Originally Posted by gluestick View Post
    Being my OCD self, I couldn,t resist the new update reminder on preware, so I tried to d/l the Apollo 1.46 update again. The d/l didn't work, so I foolishly uninstalled a perfectly functional v.1.45 and the d/l of 1.46 still doesn't work. Now I'm SOL. I suggest that the maintainers of preware would either repair or remove v1.46 and replace with v1.45. Can anyone tell me where I can get a copy v1.45 so I can listen to Pandora on my touchpad again?
    https://app.box.com/s/77jtmwbe7kkhmpw250jytl2wc0sktj0j

    Sent from my Yotaphone 2 using Tapatalk
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  11. #171  
    Thank you very, very much Alan, you've made my day.
    Alan Morford likes this.
  12.    #172  
    Hey guys,

    Just wanted to thank you all for the continue support and usage of the app. I just wanted to let everyone know that Pandora actually issued a takedown notice on the Blackberry App Market, so we're pretty much at the breaking point for continuing support for it.

    Here's the news post about it: News Update: 'Apollo for Blackberry Playbook has been pulled.'

    We still have the old download links on JMTK Apollo App Page

    Thanks all and PM me if anyone has questions!
    Quote Originally Posted by rwhitby View Post
    We always prefer that people donate in response to tangible items they can use today, rather than for intangible promises about the future that may or may not be possible to achieve.
  13. #173  
    It should be noted that the 1.2.6 version of the app installs fine if you download it. It's the installation from Preware that hangs. It did that for me several times, too.

    There's a download link for the Pre3 and Touchpad versions at the developer's link in the previous post.

    If you haven't used Apollo by now, you should. It's a great client and it still works well on the TP.
  14. #174  
    Quote Originally Posted by krotech View Post
    It should be noted that the 1.2.6 version of the app installs fine if you download it. It's the installation from Preware that hangs. It did that for me several times, too.

    There's a download link for the Pre3 and Touchpad versions at the developer's link in the previous post.

    If you haven't used Apollo by now, you should. It's a great client and it still works well on the TP.
    I still use it everyday. It's my favorite app!

    Thanks yet again, Jake! I hope you're doing well.
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  15. #175  
    I downloaded it to my desktop. How do I install it on my Touchpad? I'm not a mobile programmer or engineer.
  16. #176  
    You can use webOS Quick install to install it over the cable from your desktop. Or you could move it to the USB area of your TP and then use Preware to install a local file.
    MudShark22 and Jake_M like this.
  17. #177  
    Success! Apollo installed! Thanks!
Page 9 of 9 FirstFirst ... 456789

Tags for this Thread

Posting Permissions