Page 4 of 6 FirstFirst 123456 LastLast
Results 61 to 80 of 103
Like Tree16Likes
  1. #61  
    I installed and ran the app and changed the names of games and homebrew. Then I moved a few apps to those tabs. Then I restarted and the apps I moved returned to Downloads.
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  2. #62  
    Quote Originally Posted by hiddenpremise View Post
    Hey guys, it's been a few days. I'm not ignoring you! I've been out of town. Life is crazy. I've got lots of great new features headed your way. The backup manager is completed and working. If anyone wants to play with the latest builds and has a *nix/mac with the sdk, you can checkout from my repo https://github.com/grep-awesome/SubOrbital. Updates will come as I have time. Hopefully quite soon. Cheers
    looking forward to your updates.
  3.    #63  
    Beta 2.5 posted. See page 1 for release notes and download.
  4. #64  
    I installed 2.5. I moved some shortcuts to (former) homebrew and games, to an original tab, and to a new tab. Two shortcuts stayed in place - one to one of the original tabs, and one to a new tab (out of 4 shortcuts I moved there). The ones I moved to the homebrew and games did not stay, but were returned to downloads after a Luna restart..
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  5.    #65  
    Quote Originally Posted by shneor View Post
    I installed 2.5. I moved some shortcuts to (former) homebrew and games, to an original tab, and to a new tab. Two shortcuts stayed in place - one to one of the original tabs, and one to a new tab (out of 4 shortcuts I moved there). The ones I moved to the homebrew and games did not stay, but were returned to downloads after a Luna restart..
    I think this is some sort of permissions issue. I'm tracking it here
    SubOrbital - Bug #6: Icons not staying in place on new tabs - Project Tracker
    If you'd like try adding the icons to the tabs again, creating a new backup, and sending me that backup (they are located /media/internal/SubOrbitalBackups), I'd greatly appreciate it and it would speed up the fix. I've pm'd you my email address.
  6. #66  
    Quote Originally Posted by hiddenpremise View Post
    I think this is some sort of permissions issue. I'm tracking it here
    SubOrbital - Bug #6: Icons not staying in place on new tabs - Project Tracker
    If you'd like try adding the icons to the tabs again, creating a new backup, and sending me that backup (they are located /media/internal/SubOrbitalBackups), I'd greatly appreciate it and it would speed up the fix. I've pm'd you my email address.
    Done, thx.
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  7. jdod's Avatar
    Posts
    874 Posts
    Global Posts
    977 Global Posts
    #67  
    I am about to play with 2.5, some notes first:

    1. With 2.0, I could install 2.0 without the Add Launcher Pages patch, and I could "see" the running app as long as it was minimized in card view, but trying to maximize the card, the app would go blank, the header of the app was there, but the rest of the screen was dark grey and unresponsive. As long as I first installed the Add Launcher Pages patch first, 2.5 worked as expected.

    2. With 2.5, I could install it without the Add Launcher Pages patch and SubOrbital launched and was viewable maximized, as expected. I did not see the need to have the Add Launcher Pages patch installed as I wanted to call those pages something else anyway.

    3. With 2.5 installed, I can "see" the stock pages in the app as though I can edit the name. I am not about to try this, but thought I'd ask if that was expected behavior? I am guessing the reason they are there is to move them and custom pages, respective to each other, but not to edit their name. Right? So they are only moveable, not editable?

    OK, after adding my first page and moving an app there, the app has remained on the page following first a luna restart then system restart, fyi.

    One of my favorite apps, I am an organization nut (engineer). Thank you for developing it!
    Sprint since 01/06/99: Sanyo SCP-4500 -> Audiovox PPC-6700 -> Palm Treo 755p -> Palm Centro -> Palm Pre 1.4.5 -> Jailbroken iPhone 4s
  8.    #68  
    Just pushed out Beta 3.0. It is available through the feeds. More info available on the first post of this thread, which I edited.
    Mutoidi likes this.
  9. matchqq's Avatar
    Posts
    290 Posts
    Global Posts
    291 Global Posts
    #69  
    Awesome! I just successfully moved my launcher around.

    -- Sent from my HP TouchPad using Communities
  10. #70  
    looking good so far. Created new tab. Moved apps in. Remove tab successful and relocate apps to other tab. Also, re-order tabs seems to work fine.

    if we could add more rows of launcher tabs I say you hit a grand slam homerun. This app would then need to become part of the webOS.

    Great job so far! Thanks!
  11. #71  
    Just installed Beta 3 from preware. Worth signing up to precentral just to make comments.

    Excellent app, but here are a few items that don't seem to work for me. Not sure if they are still under development or not.

    1. New Backup works fine, file is created, although the name it requested of me isn't displayed anywhere, just the date. Restore Selected Backup doesn't seem to do anything, even after luna restart.

    2. Bulk move of apps between tabs tells me they have been moved and asks me to do a luna restart, which I do. None of of selected apps get moved. Something I'm doing wrong? Manually moving apps, by hold and drag, to new tabs works fine.

    Also, what happens to the icon placements if I uninstall this app? Does everything revert back to normal? Do I need to restore the file backed up before the installation?
    Last edited by QuayPad; 12/05/2011 at 08:40 AM. Reason: Added some ?
  12. jdod's Avatar
    Posts
    874 Posts
    Global Posts
    977 Global Posts
    #72  
    Quote Originally Posted by QuayPad View Post
    Bulk move of apps between tabs tells me they have been moved and asks me to do a luna restart, which I do. None of of selected apps get moved. Something I'm doing wrong? Manually moving apps, by hold and drag, to new tabs works fine.
    Similar results here. I flagged several to move, only 1 of them did move. Not sure if the one I moved was first selected, last selected or in the middle.

    Trying to move more following a Luna restart moved zero the second time around.

    I was able to re-order tabs, so what I did was place a receiving tab next to a tab icons were moving from so I would not have to go through so many pages (if there were several moving from a page to another.

    How do you think you will address the tab bar when there are too many to fit? It has nicely compressed tabs across the board, but eventually the names roll to the next line. Any chance the tabs will scroll left to right or maybe a 2nd row?

    Great app!
    Sprint since 01/06/99: Sanyo SCP-4500 -> Audiovox PPC-6700 -> Palm Treo 755p -> Palm Centro -> Palm Pre 1.4.5 -> Jailbroken iPhone 4s
  13. AMR-1's Avatar
    Posts
    258 Posts
    Global Posts
    261 Global Posts
    #73  
    Woah! I didn't even see the TAB pane until I was reading the thread and went "Wait! What? - There is a TAB pane? - Glances over to TP in landscape mode ... ooohhh there it is!"

    Very Cool! I see a vision (I'm guessing that soon the icons for said Apps might show up in there)
  14. AMR-1's Avatar
    Posts
    258 Posts
    Global Posts
    261 Global Posts
    #74  
    Ok. So here is my history with my cherished PAGES and ICONS - which I'm guessing a few others might have in common. I originally installed Internals Linux App/Script that added GAMES and HOMEBREW and move apps into those. <time goes by> Then I installed SubOrbital B1 and added a tab called BOOKS-MAGS. After adding it and restarting - my previous GAMES tab renamed to SETTINGS (HOMEBREW still ok and no Icons moved around) - so then I had two SETTINGS tabs - which I didn't care cause Beta means Beta. Then I filled up BOOKS-MAGS and continued using it this way and putting new icons where they belong. Then I installed SubOrbital B2 to see if it would allow fixing of my tabs (it only showed me a couple of tabs in the list). I didn't want to muck up my icons so I didn't use it to change anything and left it the way it was- Beta means Beta - also left Internals LinuxApp/Script installed - and I figured I'd be writing this post at some point anyways.

    Ok. Now to SubOrbital B3 - (still have Internals Linux App/Script installed) All my tabs show up in SOB3. Looks like this:
    APPS | DOWNLOADS | FAVORITES | SETTINGS | HOMEBREW | SETTINGS | BOOKS-MAGS

    The first SETTINGS is really GAMES.

    So now I backed up the launcher3 folder (manually first and then with SOB3) and tried to rename the tabs. Both SETTINGS say they are "built in tabs" and will not rename. Beta means Beta I also noticed that in the TABS slider pane there is only 1 SETTINGS tab listed and it has the icons in it that is the "built in one". The SETTINGS (really GAMES) is not listed.

    While it won't be catastrophic if I have to redo all my icon/page placements - I don't want to have to. So here is my thought:
    I think if I make 5 new pages P1...P5 and bulk move all my APPS icons over to P1, all my HOMEBREW icons to P2, all my BOOKS-MAGS icons to P3, all my DOWNLOADS icons to P4, leave P5 blank for now then restart Luna. Then remove Internals LinuxApp/Script and restart Luna - I'm thinking all the icons under SETTINGS (which is really GAMES) will pop under the newly empty APPS or DOWNLOADS. Then I'll fire up SubOrbital B3 and move all newly placed the icons from whereever they ended up in APPS or DOWNLOADS to P5. Then Restart Luna. If it is all cool, I can move all the icons from P1 and P4 back to APPS and DOWNLOADS, delete the empty pages, rename P2 to HOMEBREW, rename P5 to GAMES. Then I'll put a dollar or two over to the side for when hiddenpremise adds a donate link.

    All of this sounds long but really will only take a few minutes to try. If it goes south, I'll try restoring first with SOB3, if that don't work (Beta means Beta), then I can restore launcher3 manually.

    PS. hiddenpremise, Your interface is not ugly.
  15. #75  
    So, if I am installing for the first time and I already have the other patch (homebrew and games) should I uninstall first?
  16. jdod's Avatar
    Posts
    874 Posts
    Global Posts
    977 Global Posts
    #76  
    Quote Originally Posted by toddbecker View Post
    So, if I am installing for the first time and I already have the other patch (homebrew and games) should I uninstall first?
    I did, in the interest of less is more. If I can accomplish everything with just Suborbital, why complicate things?

    Besides, I did not want a tab called "homebrew", since homegrew apps fall into the same categories as app cat apps, and I knew tab real estate is very small.
    Sprint since 01/06/99: Sanyo SCP-4500 -> Audiovox PPC-6700 -> Palm Treo 755p -> Palm Centro -> Palm Pre 1.4.5 -> Jailbroken iPhone 4s
  17. #77  
    I think I just noticed icons for Apps downloaded from the HP Cat. being placed only in the 'second tab' regardless of it's 'name'.. in this case 'Homebrew', as (I have previous 'other' Tab patch installed) and have re-ordered tabs to No.1 = 'Downloads'--> No. 2 = 'Homebrew'--etc....

    So, this may mean either, that I have to always place the 'Downloads' tab in position No 2. (ie. second from left).. or that downloaded icons may require to be specifically addressed & directed to the 'Downloads' tab.. whatever it's new position may be.. or both?

    Thanks!

    Last edited by Mutoidi; 12/06/2011 at 02:01 PM.
  18. AMR-1's Avatar
    Posts
    258 Posts
    Global Posts
    261 Global Posts
    #78  
    ok. So my theory above didn't quite work. SOB3 and/or the launcher only lets you have 10 pages. And duuhhhh... they didn't use two digits (or sort by integer) in the launcher_fixed.msave file as the tab numbers so tab 10 always gets moved to tab 2. ie 1,10,2,3,... and SOB3 wouldn't let me move any icons (probably cause I had two SETTINGS tabs/) - I would click the move button and nothing would happen. Also backup backed up but would not restore.

    It ended up being a piece of cake to use InternalzPro to just modify the files manually with the knowledge that I gleened from hiddenpremise and his app (which is really close to being non-beta and a killer app for WebOS3.x).

    after i got things "all good" I tested SOB3 some more...

    SOB3 quick bug/enhancement list:
    Would be cool if you could detect mucked up files (like mine were) and suggest fixing by hand or "click here to remove WebOSInternals initial patch and set things as close to default as possible" - Warning - you will have to move your crap around if you use this option!

    Need a way to delete backups (swipe to delete maybe) or a button at the bottom with the new and restore ones.

    Enhancement request: In the main pane - Color the "Built in tabs" red or something denoting no changes are possible to name. Color Tab2 to denote that Newly Installed Apps and/or "Icons with no home" will go here automagically. Or just put some txt next to them that says all this (there probably is enough room even in portrait).

    Probably on the TODO list already: Add a QuickLaunch editor (just cause you can)

    Minor but might as well fix it: Text at the top "Add/Customize...questions" is just a smidge too long in the main pane (maybe just need one font smaller)

    Either limit tabs to 9 for now (till integer sort is fixable) or note in FAQ that tab 10 will sort up to #2 in line.

    If not already - Make sure and stay within "supported, SDK" methods so you can release this as a CATAPP and make some mooolah! Make sure and leave Luna Restart detached for now - I don't think there is a "supported SDK" way to do that yet.

    Under the MoveMyIcons slider pane
    - icons in the list are not always in the order they show up in the launcher
    (probably the same not sorting by integer problem)
    - for now maybe just put the "index" number that is in the page_... file in square brackets [#] next to the icon in the MoveMyIcons pane and the TABNAME in the main pane.
  19. #79  
    Quote Originally Posted by amrcc View Post
    Need a way to delete backups (swipe to delete maybe) or a button at the bottom with the new and restore ones.
    This is already my biggest issue, so +1 to this suggestion (thanks for giving us backups--it's a welcome problem to have!).

    I would greatly prefer swipe to delete over a clunky delete button, if you can manage it.
  20. #80  
    Quote Originally Posted by QuayPad View Post
    New Backup works fine, file is created, although the name it requested of me isn't displayed anywhere, just the date. Restore Selected Backup doesn't seem to do anything, even after luna restart.
    Be sure to not use any spaces or non-alphanumeric characters in a backup name--SOB will not display such a name (you'll only see the date and time), and it may be why restore isn't working (if the backup name is corrupted).
Page 4 of 6 FirstFirst 123456 LastLast

Tags for this Thread

Posting Permissions