Page 25 of 27 FirstFirst ... 152021222324252627 LastLast
Results 481 to 500 of 529
Like Tree45Likes
  1. #481  
    Quote Originally Posted by zane9000 View Post
    Thanks for that! I will use this as a starting point for figuring out why it isn't working now.
    I think when I tried it kinda installed but had dbus issues, I had to force off release-upgrade checks as I was bombarded with notifications to update to 12.x, when your package failed I stall on 11.10 I got round it by installing XUbuntu manually over the top then manually fixing any leftover issues, it was annoying but worked.

    i know dbus didnt get setup correctly as when i finally got it manually fixed the system complained of polkit and haldaemon not being setup correctly, plus i had to add some dbus related stuff before launching xfce4 otherwise the ubuntu software center and other problems like pulseaudio errors and much more remained as a bad knockon effect.

    i added this to the bottom of my /root/.bashrc which helped on 11.04 and 11.10

    Code:
    sudo mkdir -p /var/run/dbus
    sudo rm -f /var/run/dbus/pid
    sudo chown messagebus:messagebus /var/run/dbus
    sudo dbus-uuidgen --ensure
    sudo dbus-daemon --system --fork --activation=upstart
    fusermount -u ~/.gvfs
    sudo su - pete -c "dbus-launch startxfce4" > $homedir/.dbus-session &
    sleep 5
    wmctrl -s 1
    obviously "pete" would be changed to the login/username
    Last edited by geekpeter; 08/23/2012 at 02:53 AM.
    Touchpad Keyboard Themes - >> Click Me <<
  2. #482  
    @zane9000: a lot of what is in your script still works. I used it and took only comand lines that I needed. Very helpful!

    The long tap to right click does not work very well though, and with three finger tap to virtual keyboard, no need for florence or onboard. Life changer!

    I will create a plugin collection for firefox on touchpad on the firefox add-ons website and post a link on this forum. May help some and us when comes the need to re-install.
    Proud Veer and Touchpad owner
  3. #483  
    I think when I tried it kinda installed but had dbus issues, I had to force off release-upgrade checks as I was bombarded with notifications to update to 12.x, when your package failed I stall on 11.10 I got round it by installing XUbuntu manually over the top then manually fixing any leftover issues, it was annoying but worked.

    i know dbus didnt get setup correctly as when i finally got it manually fixed the system complained of polkit and haldaemon not being setup correctly, plus i had to add some dbus related stuff before launching xfce4 otherwise the ubuntu software center and other problems like pulseaudio errors and much more remained as a bad knockon effect.

    i added this to the bottom of my /root/.bashrc which helped on 11.04 and 11.10

    [code]
    sudo mkdir -p /var/run/dbus
    sudo rm -f /var/run/dbus/pid
    sudo chown messagebus:messagebus /var/run/dbus
    sudo dbus-uuidgen --ensure
    sudo dbus-daemon --system --fork --activation=upstart
    fusermount -u ~/.gvfs
    sudo su - pete -c "dbus-launch startxfce4" > $homedir/.dbus-session &
    sleep 5
    wmctrl -s 1


    obviously "pete" would be changed to the login/username
    Oddly I had no issue with dbus when launching lxde with "dbus-launch startlxde", although I didn't try sound or video or any media since that's not what I'm using ubuntu for...
    Proud Veer and Touchpad owner
  4. #484  
    Quote Originally Posted by grasshoper View Post
    Oddly I had no issue with dbus when launching lxde with "dbus-launch startlxde", although I didn't try sound or video or any media since that's not what I'm using ubuntu for...
    was this when or after you ran the autoconfig script under 11.10? I had virtually no issues with 11.04, it was only when i had to tidy up after the config script when run under 11.10 or installed manually i had to do the above or nearly everything didnt work.

    i simply tried to eliminate any and all error messages that appeared in the console when launching ubuntu, i had several originally but did t "seem" to do anything bad, but i fixed them anyways just incase' i think i still have some errors left to fix but not as many as before.

    enclosed pic of my current error output, slowly trying to eliminate any and all errors.

    my last big issue on 11.10 was fixing parts of gnome insisting pulseaudio was installed and used rather than alsa/anything else, i still didnt fix it i just stopped it giving errors and still had to keep/install bits of pulseaudio to stop gnome session manager errors all over the place, in fact they continued yielding errors non stop, the console spam was horrendous, audio works but its not looking as "trim" as id wanted.
    Attached Images Attached Images
    Last edited by geekpeter; 08/23/2012 at 05:24 AM.
    Touchpad Keyboard Themes - >> Click Me <<
  5. #485  
    11.10 "repaired" and working "ok"

    yeah would be nice if you get the script working again, im getting better at how to start manually from scratch every time but you have to give big thumbs up to people who can make it all automated, when i tried theres always something id forget or i didnt make any failsafes for errors etc.

    if you can get the script working on 11.10 then your a legend \o/

    btw can you add in as per my example above the following before xfce/lxde is launched.

    Code:
    fusermount -u ~/.gvfs
    ive added this to bootup as it fixes the issue where we just break stuff from tossing the card away instead of proper logouts and we end up with the error message about "transport endpoint is not connected" and disallowing access to our home folders.

    it may not be the right way to fix the issue but it seems to work when slapped in my startup.
    Attached Images Attached Images
    Touchpad Keyboard Themes - >> Click Me <<
  6.    #486  
    Quote Originally Posted by geekpeter View Post
    btw can you add in as per my example above the following before xfce/lxde is launched.

    Code:
    fusermount -u ~/.gvfs
    ive added this to bootup as it fixes the issue where we just break stuff from tossing the card away instead of proper logouts and we end up with the error message about "transport endpoint is not connected" and disallowing access to our home folders.

    it may not be the right way to fix the issue but it seems to work when slapped in my startup.
    Cool, I will add that!
  7. #487  
    11.10 "repaired" and working "ok"

    yeah would be nice if you get the script working again, im getting better at how to start manually from scratch every time but you have to give big thumbs up to people who can make it all automated, when i tried theres always something id forget or i didnt make any failsafes for errors etc.

    if you can get the script working on 11.10 then your a legend \o/

    btw can you add in as per my example above the following before xfce/lxde is launched.

    [code]
    fusermount -u ~/.gvfs


    ive added this to bootup as it fixes the issue where we just break stuff from tossing the card away instead of proper logouts and we end up with the error message about "transport endpoint is not connected" and disallowing access to our home folders.

    it may not be the right way to fix the issue but it seems to work when slapped in my startup.
    how did you have dbus working properly? I just installed software center which finally won't launch because of it!
    Proud Veer and Touchpad owner
  8. #488  
    Quote Originally Posted by grasshoper View Post
    how did you have dbus working properly? I just installed software center which finally won't launch because of it!
    try the additions to /root/.bashrc i have in a code block a few posts up, then see what error messages you get in your console when running the software center.

    should run fine if not just post a pic or some text from the errors, can probably tell you if i had the same and how i fixed it.
    Attached Images Attached Images
    Last edited by geekpeter; 08/23/2012 at 09:43 AM.
    Touchpad Keyboard Themes - >> Click Me <<
  9. #489  
    Well, I don't know how it happened but my bashrc is full of errors. I'm tempted to delete it and make a new one, but I don't know for sure what is worth saving or not...

    When the chroot load, I get :
    "bash: $'\r': command not found"
    :invalid shell option name

    I don't know where it comes from as I have no line number.

    And: "bash: /root/.bashrc: line95 : syntax error: unexpected end of file

    I also get
    "sudo: unable to resolve host MightyGlowingThingy"

    And with your script added :

    "unknown activation type: upstart"
    ...
    ": no such file or directory /root/.gvfs"
    ...
    "sleep: invalid time interval '5/r'
    then
    "connection failure: connection refused
    pa_context_connect() failed: Connection refused

    an error with polkit-gnome-1 which says "error initializing authority:Error Connecting: No such file or directory

    then:
    ** (update notifier:12723): WARNING **: not starting from system user

    and finally a 2lines long dbus error about gvfs-gdu-volume-monitor



    It's a bit rough, but that's the best I can do ^^

    If you could give me your .bashrc by pm, would be good
    Proud Veer and Touchpad owner
  10. #490  
    if you edit your webOS /etc/hosts file and add in

    127.0.0.1 <NAME OF DEVICE>

    ie mine is

    127.0.0.1 PeterHPTouchPad

    yours would be

    127.0.0.1 MightyGlowingThingy

    ubuntu seems to use the webOS hosts file and if you have your touchpads name in there it solves the "unable to resolve hostname" issues.

    the sleep 5 command my example above had was only 2 things yours has some weird stuff on the end yours shows a /r on the end somehow, as yours error'd im guessing you copy/pasted from the forum? maybe you picked up extra formatting the linux side doesnt like?

    did you say earlier you used LXDE and not XFCE? might be some minor differences in the packages both use, ill anhialate my 11.10 later and slap in a version of LXDE and see if i can fix those errors, again some fo yours mentioned look dbus related.

    im going to guess your volume error message continue spamming over time? my 11.10 install did that due to gnome isues with pulseaudio.

    if you dont have it already install gconf-editor

    run it and goto /apps/gnome_settings_daemon/plugins/sound/active then change the active part to 0

    this should ?? hopefully eliminate 1 of the volume/gnome error messages.

    maybe you can screenshot the terminal as it outputs errors, i recall i fixed 1 of the dbus issues by making some new dbus folders as i found info to suggest 2 differing folder names were mentioned in forums/help, and 1 of my error messages did idd point to a folder that didnt exist, perhaps differing names on different releases of ubuntu caused the problem, either way i ended up making a symlink so either 1 worked in the same folder.

    i had many such problems, really should write down what i did every time, its just hard when every time you add or change something your never really sure if the problems fixed/temporarily gone/does nothing at all until youve used the device for a while, SO FAR im ok, i could eventually do a step by step, Zane might just as easily fix his auto installer by then tho.
    Touchpad Keyboard Themes - >> Click Me <<
  11.    #491  
    I am really thinking about only having one window manager installed instead of giving an option between LXDE and XFCE. Personally I prefer LXDE, do other people have preferences? What are some benefits of one vs the other?
    grasshoper likes this.
  12. #492  
    also had issues with the system_bus_socket which caused a variety of errors as well after some hunting around this again was a folder error likely from differing releases using differing locations.

    this required the following as a semi fix.

    replace /var/run with a simlink to /run and /var/lock with a simlink to /run/lock

    sudo ln -s /var/run /run
    sudo ln -s /var/lock /run/lock

    think i only had to do this on 11.10 and not 11.04, again tho if a pic or output showing the exact errors is possible its far easier to remedy the problems were having, there was quite a few i had to remedy for 11.10.
    Touchpad Keyboard Themes - >> Click Me <<
  13. #493  
    fan of xfce4, was a fan of lxde but when customising several things the way i wanted i ended back up with xfce4.

    tbh their both ok and both lightweight, cant see any glaring reason to need 1 over the other, surely whichever produces the least hassle to use and setup is fine for the masses, be they long time users or new to the whole ubuntu on touchpad thing.

    i personally just had less problems with the xfce4 package esp when adding / customising my setup afterwards, i know i had some grumpy times when trying to get lxde to behave when changing its dock/panels and some programs not appearing in the applications menus after installing.

    minor gripes tho.
    Touchpad Keyboard Themes - >> Click Me <<
  14. #494  
    Quote Originally Posted by geekpeter View Post
    if you edit your webOS /etc/hosts file and add in

    127.0.0.1 <NAME OF DEVICE>

    ie mine is

    127.0.0.1 PeterHPTouchPad

    yours would be

    127.0.0.1 MightyGlowingThingy

    ubuntu seems to use the webOS hosts file and if you have your touchpads name in there it solves the &quot;unable to resolve hostname&quot; issues.

    the sleep 5 command my example above had was only 2 things yours has some weird stuff on the end yours shows a /r on the end somehow, as yours error'd im guessing you copy/pasted from the forum? maybe you picked up extra formatting the linux side doesnt like?

    did you say earlier you used LXDE and not XFCE? might be some minor differences in the packages both use, ill anhialate my 11.10 later and slap in a version of LXDE and see if i can fix those errors, again some fo yours mentioned look dbus related.

    im going to guess your volume error message continue spamming over time? my 11.10 install did that due to gnome isues with pulseaudio.

    if you dont have it already install gconf-editor

    run it and goto /apps/gnome_settings_daemon/plugins/sound/active then change the active part to 0

    this should ?? hopefully eliminate 1 of the volume/gnome error messages.

    maybe you can screenshot the terminal as it outputs errors, i recall i fixed 1 of the dbus issues by making some new dbus folders as i found info to suggest 2 differing folder names were mentioned in forums/help, and 1 of my error messages did idd point to a folder that didnt exist, perhaps differing names on different releases of ubuntu caused the problem, either way i ended up making a symlink so either 1 worked in the same folder.

    i had many such problems, really should write down what i did every time, its just hard when every time you add or change something your never really sure if the problems fixed/temporarily gone/does nothing at all until youve used the device for a while, SO FAR im ok, i could eventually do a step by step, Zane might just as easily fix his auto installer by then tho.
    Ok,the list of bugs is shorter now. I cleaned all up and now have a few still showing:
    fusermount: failed to umount /root/.gvfs: Invalid argument

    Gtk-Message: Failed to load module"libgtkstylus.so"

    ** (update-notifier:11122): WARNING **: not starting for system user

    xscreensaver : locking is disabled (running as nobody)
    xscreensaver : locking only works when xscreensaver is launched by a normal non-privileged user

    Connection failure: Connection refused
    pa_context_connect() failed: Connection refused

    polikit ... WARNING: Unable to determine the session we are in: Gdbus.error: ...
    Error: Unable to lookup session information for process '11115'
    So what I didn't say is that I prefered staying as root because every time I create a user no password ever work, and it's impossible to jump into sudo mode.

    The libgtkstylus modules are installed so I don't know why gtk can't find it.

    As for polkit, I don't understand what the whole error mean!!

    With gconf-editor, I don't have gnome-settings-daemon
    Last edited by grasshoper; 08/23/2012 at 02:07 PM.
    Proud Veer and Touchpad owner
  15. #495  
    I am really thinking about only having one window manager installed instead of giving an option between LXDE and XFCE. Personally I prefer LXDE, do other people have preferences? What are some benefits of one vs the other?
    I think we should go with LXDE only, as it is a very lightweight DE (when coupled with openbox) and that's the kind we need with the touchpad for fluidity and preserving resources.

    Plus, if someone want to install another de afterwards, it doesn't add up too much on disk space.
    Proud Veer and Touchpad owner
  16. #496  
    Quote Originally Posted by grasshoper View Post
    Ok,the list of bugs is shorter now. I cleaned all up and now have a few still showing:

    So what I didn't say is that I prefered staying as root because every time I create a user no password ever work, and it's impossible to jump into sudo mode.

    The libgtkstylus modules are installed so I don't know why gtk can't find it.

    As for polkit, I don't understand what the whole error mean!!

    With gconf-editor, I don't have gnome-settings-daemon
    the password i gave my username works fine when ubuntu asks for it, and i can sudo perfectly fine as user "pete".

    do we still need libgtkstylus ? xserver lets us 2 finger tap the screen for rightmouse now anyways, just hold 1 finger and tap with the second.

    the fusermount error i think is perfectly fine when we arent suffering from the "endpoint blah blah" message, if we do have the message/problem the command does its stuff, hopefully tho you have the issue, every reboot/run of ubuntu you shouldnt get the error, as it should be supressed before you see it.............. "should"

    your polkit issue isnt a normal type of polkit/messagebus error that ive seen yet, clutching at straws here but you could try.

    sudo apt-get install --reinstall dbus

    never worked for me yet but you never can tell, also i think this fails to correct any polkit/haldaemon/messagebus etc if theres already traces of the user groups they created initially, its something to try tho.
    Touchpad Keyboard Themes - >> Click Me <<
  17. #497  
    the password i gave my username works fine when ubuntu asks for it, and i can sudo perfectly fine as user "pete".

    do we still need libgtkstylus ? xserver lets us 2 finger tap the screen for rightmouse now anyways, just hold 1 finger and tap with the second.

    the fusermount error i think is perfectly fine when we arent suffering from the "endpoint blah blah" message, if we do have the message/problem the command does its stuff, hopefully tho you have the issue, every reboot/run of ubuntu you shouldnt get the error, as it should be supressed before you see it.............. "should"

    your polkit issue isnt a normal type of polkit/messagebus error that ive seen yet, clutching at straws here but you could try.

    sudo apt-get install --reinstall dbus

    never worked for me yet but you never can tell, also i think this fails to correct any polkit/haldaemon/messagebus etc if theres already traces of the user groups they created initially, its something to try tho.
    Thanks to you I got Software Center working! I think this was after symlinking the /var folders. This should be implemented in the final script from Zane9000, or a better solution if someone find it.

    I re-installed dbus but the polkit/messagebus error is still there. It doesn't break anything I use right now though.

    I find the lack of useful software on linux/ARM a bit disappointing. If you know some good PPA maybe we should start a new thread to list them. Most of the apps that I find could be good for work for instance are too heavy/not adapted for tablets. Although, Firefox and Pinta are two apps that fit nicely in the webos ecosystem which lack a good browser and an image editor with magick wand!

    I don't know about you, but I find that Touchpadbuntu has been left behind and has not enough love from the community. It did at some point in time, but we should make clean install and finding software more easy and maybe share how we use Ubuntu right now. I suggest opening a thread (which should become sticky) on what apps which lack on webos are usable and stable on Ubuntu, with PPA's and links for easy retrieval.
    Proud Veer and Touchpad owner
  18. #498  
    Does anyone using the HP bluetooth keyboard with Ubuntu notice any of the keys repeating occasionally? Or the ctrl-key gets stuck "on" after pressing once, sometimes?

    Trying to figure out if I have a bad keyboard or not. Thanks.
  19.    #499  
    I have a cheap eBay bluetooth keyboard that gets stuck sometimes.... I suspect it is not a faulty keyboard unless you see issues when using it in native webOS apps.
  20. #500  
    I've got the hp keyboard and I didn't notice any repeating keys. Did you check the batteries of the keyboard?
    Proud Veer and Touchpad owner

Posting Permissions