Page 33 of 38 FirstFirst ... 232829303132333435363738 LastLast
Results 641 to 660 of 750
Like Tree119Likes
  1. #641  
    Quote Originally Posted by jafar79 View Post
    Kareemhozifa,

    Don't worry, worst case you can just doctor your TP to bring it back to factory setting.

    But now you can try this: when you turn on your TP while connected to your PC, is it recognized by WOSQI ? If that is the case, then try repeating the steps of adding the Arabic keyboard for 3.0.5 as if there is nothing wrong. The whole idea is to put back a 3.0.5 compatible LunaSysMgr.

    Salam,
    Jafar
    Thank You Very Much Jafar (( Gazaka allaho khairan ))
  2. #642  
    i tried your arabic keyboard installation step by step and every time my device(touchpad) stopped completely and i had to doctor it 3 times
  3.    #643  
    Quote Originally Posted by abrazik View Post
    i tried your arabic keyboard installation step by step and every time my device(touchpad) stopped completely and i had to doctor it 3 times
    First of all, what version of webOS do you have on your TouchPad?
    Also, from which post did you take the link for the Arabic Keyboard?

    If you are sure that all versions are compatible, then it is impossible even if the versions are not compatible for the device to show blank screen. After you hit the last command "initctl start LunaSysMgr" your device should start showing the HP logo. If the logo get stuck, then wrong version "most probably". If the screen is still blank after the command, then there is something wrong and I would require you to pull some logs so I can give it a look.
  4. #644  
    After installing libWebKitLuna.so installation (both in 3.0.4 n 3.0.5) quranexplorer.com does not recite. It stuck in Loading. Any one saw this problem?
  5. #645  
    Quote Originally Posted by masood123_99 View Post
    After installing libWebKitLuna.so installation (both in 3.0.4 n 3.0.5) quranexplorer.com does not recite. It stuck in Loading. Any one saw this problem?
    I'm running 3.0.5 .. with updated libWebKitLuna.so and LunaSysMgr to support Arabic. quranexplorer.com works fine in term of loading and reciting. but ..

    CvvB, probably aware of this, the Arabic font is not rendered correctly with harakat/tashkeel. Harakat are supposed to be rendered with zero width, otherwise the end result would be disconnected Arabic letters whenever there is harakat in between. That is the only flaw I see on my TouchPad.

    Masood, try restarting the TouchPad, or hard reset (power button+home button for 15 seconds). You can also try clearing the browser history/cookies. If all fails, try putting back the original libWebKitLuna.so and see if it works.
    Last edited by jafar79; 01/26/2012 at 11:47 PM.
  6.    #646  
    Quote Originally Posted by masood123_99 View Post
    After installing libWebKitLuna.so installation (both in 3.0.4 n 3.0.5) quranexplorer.com does not recite. It stuck in Loading. Any one saw this problem?
    Try recreating this and then go to /var/log/rdxd/ and get the latest log stored in there and send it over to me.

    Quote Originally Posted by jafar79 View Post
    I'm running 3.0.5 .. with updated libWebKitLuna.so and LunaSysMgr to support Arabic. quranexplorer.com works fine in term of loading and reciting. but ..

    CvvB, probably aware of this, the Arabic font is not rendered correctly with harakat/tashkeel. Harakat are supposed to be rendered with zero width, otherwise the end result would be disconnected Arabic letters whenever there is harakat in between. That is the only flaw I see on my TouchPad.

    Masood, try restarting the TouchPad, or hard reset (power button+home button for 15 seconds). You can also try clearing the browser history/cookies. If all fails, try putting back the original libWebKitLuna.so and see if it works.
    Have you tried the latest font I have posted? It should solve this issue. I have modified the font so that it would report the Harakat to be zero width. Although I am thinking of pushing the scale one more level and modifying the method that reports the width in WebKit.

    Regards,
  7. #647  
    CVVB
    Hey man.. How are you .. I just upgrade to 3.0.5 and get the arabic to work ... Thanks

    I want to install the keyboard and I think you already have a link for 3.0.5 and I'll follow but my question is:
    why do I need MessagingAppPatch-3.0.5.patch? is it releated to the KB or I need it anyway? also how to install it? Thanks in advance
  8. #648  
    Quote Originally Posted by CvvB View Post
    you tried the latest font I have posted? It should solve this issue. I have modified the font so that it would report the Harakat to be zero width. Although I am thinking of pushing the scale one more level and modifying the method that reports the width in WebKit.

    Regards,
    Just to be sure.. I resent the new font file, but the harakat problem is still there. So this bug is confirmed. You can browse to the website and see if it reproduces for you.

    Thanks.
  9. #649  
    Hi

    I followed your guide and I have not Arabic font and Keyboard ... the problem is .... I can not switch to English any more!!

    How to switch to english?

    I went to settings/regional and i have now

    Spanish QWERTY and English Qwerty too

    I donwloaded the QWERTY keyboard file from the keyboard post (link from first page)

    Please help

    Thanks
  10. #650  
    my web os is wifi 3.0.5
  11.    #651  
    Quote Originally Posted by JamesS_Ibra View Post
    CVVB
    Hey man.. How are you .. I just upgrade to 3.0.5 and get the arabic to work ... Thanks

    I want to install the keyboard and I think you already have a link for 3.0.5 and I'll follow but my question is:
    why do I need MessagingAppPatch-3.0.5.patch? is it releated to the KB or I need it anyway? also how to install it? Thanks in advance
    If you try the messaging application, you will see that the messaging application is messing up the Arabic text when sending it to other people. The patch will fix that!

    Quote Originally Posted by jafar79 View Post
    Just to be sure.. I resent the new font file, but the harakat problem is still there. So this bug is confirmed. You can browse to the website and see if it reproduces for you.

    Thanks.
    I will give it a look once I have the time.

    Quote Originally Posted by auday1982 View Post
    Hi

    I followed your guide and I have not Arabic font and Keyboard ... the problem is .... I can not switch to English any more!!

    How to switch to english?

    I went to settings/regional and i have now

    Spanish QWERTY and English Qwerty too

    I donwloaded the QWERTY keyboard file from the keyboard post (link from first page)

    Please help

    Thanks
    Download the AZERTY version and send it to the TouchPad. Go to Regional Settings and add English QWERTY and Other AZERTY. This should take care of the problem.
  12. #652  
    hello CvvB
    great job
    thank you very much indeed
  13. #653  
    Thanks alot brother Artabic is working very well but the Arabic keybooard is not !!! v 3.5 ...wifi only what is the problem?
  14.    #654  
    Quote Originally Posted by nashy000 View Post
    Thanks alot brother Artabic is working very well but the Arabic keybooard is not !!! v 3.5 ...wifi only what is the problem?
    Did you add another layout for the Arabic keyboard to show up?
  15. #655  
    What layout do you mean ? Sorry brother I am still new here.
  16. #656  
    Hi CvvB,
    Just wondering if you have had time to look into the left and right arrow keys. They are usually on the line where the number keys are, but on Arabic keyboards, ذ and د take the spots. Maybe there is spsce on the botton row of the keyboard?
    Thx,
    Shneor
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
    jafar79 likes this.
  17.    #657  
    Quote Originally Posted by nashy000 View Post
    What layout do you mean ? Sorry brother I am still new here.
    I don't have my TouchPad on me, but they are in the keyboard post. Did you apply the Arabization AND the keyboard or just the Arabization?

    Quote Originally Posted by shneor View Post
    Hi CvvB,
    Just wondering if you have had time to look into the left and right arrow keys. They are usually on the line where the number keys are, but on Arabic keyboards, ذ and د take the spots. Maybe there is spsce on the botton row of the keyboard?
    Thx,
    Shneor
    Sorry, I was super busy lately. Where do you suggest the arrows should be placed?
  18. #658  
    Quote Originally Posted by CvvB View Post
    , I was super busy lately. Where do you suggest the arrows should be placed?
    Maybe to the right if the space bar?. The Arabic keyboard is maximizing the highest number of buttons on each row I believe. One way to claim back some space is to combine some letters using the shift keys. Few letters can go on the same button with shift switch, for example

    و ؤ
    ى ئ
    ه ة

    not sure if this is the best way to go.

    and by the way, isn't this a good idea to have a quick access to some symbols. I.e. Using shift?

    in any case, having arrow keys would be really great, it takes me so many trials to get the cursor in the right place, sometimes I just give up.

    Thanks in advance CvvB!
  19. #659  
    I have applied the both the Arabization and the keyboard ... but the Arabic Keyboard doesn't show up
  20. #660  
    thanks CvvB worked great on pre3

Tags for this Thread

Posting Permissions