Page 30 of 38 FirstFirst ... 202526272829303132333435 ... LastLast
Results 581 to 600 of 750
Like Tree119Likes
  1. #581  
    Here is my installation process I did to get the arabic fonts on my tp with os3.0.4.

    1. Started with developer mode setup. I had password setup for this so I entered
    password to start the developer mode.
    2. Next I connected tp to my pc with usb cbale. A message pops up on the tp for
    usb and I did not do anything with that, just left it alone.
    3. Started WOSQI on the pc.
    4. I then followed step by step CvvB's guide to install fonts and luna on tp.
    5. Guide said that after sending the luna file to tp via WOSQI, the tp will restart itself
    so do not do anything. I did the same but after waiting more that 15 minutes, nothing
    happened. So I checked the troubleshooting guide by CvvB and sent my original luna
    back to tp. Still no restart. TP screen remained black.
    So then I pressed middle button and power button for 15 seconds and system came
    back up.
    6. I repeated the steps for arabic fonts and luna and same thing happened. Black screen.
    This time I again used the middle button and power button for 15 seconds and system
    started.
    7. I then checked that all my applications were OK and went to aljazeera.net and I can
    see the arabic characters. This shows that arabic fonts and luna was working fine
    now.

    My question to CvvB is that why my system did not restart as in the guide after luna
    was sent to tp?
    Is it because I have password set for developer mode?
    I read in one of the threads, that there should be no password. Is this correct?

    Anyway at this time everything is working good.

    Thanks CvvB and others for their inputs.
  2. #582  
    Hello CvvB!

    Thanks for arabic keboard for 3.0.4.
    Before installing the new LunaSysMgr, I wanted to backup the original one.
    I used WOSQI Tool>>Linux Commadline and typed ls -l LunaSysMgr but ther is no
    such file on the device.

    Please help how to save this file

    Thanks.
  3. #583  
    Since there's 59 pages of posts here I have not had a chance to read them all. However, just a tip for Mac users: webOS doesn't seem to like Mac fonts, even if they are TTF. I'm guessing OS X does the logical thing, and uses Unicode for its non-Western characters and Windows uses a different encoding.

    Gezza Pro from OS X was a no go, but Times New Roman from Debian's mscorefonts package did. Web pages are displaying fine, but Arabic letters on Facebook are not.

    Maybe all of this has been mentioned already; if so I apologize.
  4. #584  
    LunaSysMgr lives in /usr/bin if I'm correct, the linux command line will start at the root directory that is "/". Not sure how familiar you are with linux or shell commands in general but you can use he command

    pwd

    to see which directory you are in, if you are at root, you can do

    cd /usr/bin

    to get you where you want to be .. Then you can use the ls command go see the actual file.

    In all cases, to bring a file from the TP to your computer .. Use the receive file menu item from WOSQI.
  5. #585  
    can you please tell me the steps to have Arabic on my touchpad webos3.0.4 thanks
  6. #586  
    I followed the instructions and installed arabic keyboard on my tp 3.0.4 and it worked perfectly.

    Thanks, CvvB.

    Keep up the good work.

    HAPPY NEW YEAR.

    Javed
  7. RaDi13's Avatar
    Posts
    6 Posts
    Global Posts
    7 Global Posts
    #587  
    hi ,

    is there any arabic HOW TO ?

    السلام عليكم

    إخواني هل في موقع فيه شرح عربي للطريقة ؟ شكرا
  8. #588  
    Look at the first post in this thread.
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  9. #589  
    Is there anyway to increase the font sizes for arabic?

    Thanks.
  10. RaDi13's Avatar
    Posts
    6 Posts
    Global Posts
    7 Global Posts
    #590  
    can we use this font : http ://loomn .it/ b1j (remove spases ) ?
  11. #591  
    I'm still on 3.0.2. I purchased a used touchpad for my wife, and it was already on 3.0.4. I did an "erase apps and data", installed a bunch of apps, both app store and via Preware, and found that it functions perfectly. But there is no 'Text Editor" app for 3.0.4. That's the only app that will accept non-latin characters. I need to be able to write in Arabic, and Picsel Smart Office, Memos and a couple of others I tried just don't accept non-latin characters. So I'm staying on 3.0.2 for the meantime (installed the new uberkernel yesterday, so it's faster than ever) so that I can still write in Arabic and Hebrew, not just on web sites.
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  12. #592  
    hello,
    I want to ask if I install the Arabic keyboard in my TB ..
    Is it going to read Arabic too?
    Last edited by The Top; 01/06/2012 at 02:44 PM.
  13. #593  
    Yes.
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  14. #594  
    Hi CvvB,
    Thanx for your amazing work. Today I got my 1st Pre 3 mobile and TouchPad on the way.
    My Pre is with 2.2.4 any updates regarding the libraries?
  15.    #595  
    Quote Originally Posted by jhussain1 View Post
    My question to CvvB is that why my system did not restart as in the guide after luna
    was sent to tp?
    Is it because I have password set for developer mode?
    I read in one of the threads, that there should be no password. Is this correct?

    Anyway at this time everything is working good.

    Thanks CvvB and others for their inputs.
    The restart should happen except in some rare occasions. Bottom line, if it hanged or restarted, then Arabization was successful. It should mostly restart, but sometimes I observed that it just hanged and this could happen in the midst of a load of the library, which is rare.

    Quote Originally Posted by b3d0u1n View Post
    Since there's 59 pages of posts here I have not had a chance to read them all. However, just a tip for Mac users: webOS doesn't seem to like Mac fonts, even if they are TTF. I'm guessing OS X does the logical thing, and uses Unicode for its non-Western characters and Windows uses a different encoding.

    Gezza Pro from OS X was a no go, but Times New Roman from Debian's mscorefonts package did. Web pages are displaying fine, but Arabic letters on Facebook are not.

    Maybe all of this has been mentioned already; if so I apologize.
    If the font is Unicode standard, then it should be ok. From my experience with Apple's stuff, they don't follow any standard; it is most likely that they skipped Unicode standards, especially that Apple were amongst the first to implement multi-character in their operating system.

    Quote Originally Posted by fadi.sawires View Post
    can you please tell me the steps to have Arabic on my touchpad webos3.0.4 thanks
    Check first post .... Everything is mentioned in the first post.

    Quote Originally Posted by noor123 View Post
    hi ,

    is there any arabic HOW TO ?

    السلام عليكم

    إخواني هل في موقع فيه شرح عربي للطريقة ؟ شكرا
    Walikum Assalam,

    I will try to translate it if I had the time.

    Quote Originally Posted by The Top View Post
    hello,
    I want to ask if I install the Arabic keyboard in my TB ..
    Is it going to read Arabic too?
    You have to do both: Arabic Keyboard and the Arabization.

    Quote Originally Posted by rami223 View Post
    Hi CvvB,
    Thanx for your amazing work. Today I got my 1st Pre 3 mobile and TouchPad on the way.
    My Pre is with 2.2.4 any updates regarding the libraries?
    I am really sorry, I am swamped with my daily life. I am also stuck with a Pre 2 that is not Arabized. Don't worry, as soon as I get the chance, it will be done immediately .
  16. #596  
    Walikum Assalam,

    I will try to translate it if I had the time.
    I can help in translation


    I am really sorry, I am swamped with my daily life. I am also stuck with a Pre 2 that is not Arabized. Don't worry, as soon as I get the chance, it will be done immediately .
    Thanks soo much
  17.    #597  
    First post updated.

    I finally had the chance to finish the modification on the libWebKitLuna.so for webOS 2.2.4! After I did an MD5 sum check for the Pre 2, Pre 3 AT&T, Pre 3 Verizon, and Pre 3 Unlocked. I have found that Pre 3 with all its variants has a build of the library while the Pre 2 has a different build. As a result, I have done two modification and I didn't bother to check the difference at all, taking into account that Pre3 library would work on a Pre2 with no problem and visa versa. Such fact is expected as both are webOS 2.2.4's libraries.

    To be honest, the MD5 sum difference could be stemming from the fact that GNU could produce different registers-assignment within multiple times of compilation, which is irrelevant to general functionality ... who knows, right?

    Sorry to take a long time to have this done, I was busy as hell lately.

    Regards,
  18. #598  
    Just a note - WebOS 3.0.5 is being pushed right now.
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
    jafar79 likes this.
  19. #599  
    So if we upgrade to webos 3.0.5, do we need to reinstall Preware and other homebrew
    softwares?

    I have arabic keypad and other patches and softwares.

    Thanks,
  20. #600  
    Quote Originally Posted by shneor View Post
    Just a note - WebOS 3.0.5 is being pushed right now.
    I found out this accidentally this afternoon while I was trying to show a friend how to upgrade from 3.0.2 to 3.0.4. Instead of 3.0.4 showing up.. I got 3.0.5!

    Minor fixes and additions.. but at least the boat is still going!

Tags for this Thread

Posting Permissions