Results 1 to 7 of 7
  1.    #1  
    has anyone posted guidelines or a good writeup somewhere on guidelines on writing apps that are compatible with all (active in the wild) webos versions?

    obviously it might not always be possible (for example if you are exploiting features that are unique to a particular device or webos version), but GENERALLY speaking. as in: "if you want your application to work on all versions of webos, code like this, and not like that" advice.

    adv-apologies-ance if this is a stupid question.
  2. #2  
    Right now the main problem between the versions is going from 1.X to 2.X.

    The synergy access is completely different. We've been told that 3.X doesn't use HTML at all.
    Developer
    DigiKat Software Company
    Http://www.digikatsoftware.com
  3. chasden's Avatar
    Posts
    6 Posts
    Global Posts
    9 Global Posts
    #3  
    This thread is a bit old, but I thought it was a good place as any to ask... Is anyone aware of specific WebOS 2.0 and 1.0 compatibility issues?

    More specifically, I'm developing an app that is working fine under 1.4.5 (using the 1.4.5 SDK) which runs fine on a Pre running 1.4.5. On a Pre2 running WebOS 2.1 the AJAX calls seem to be failing. Anyone have any insight into this?
  4. #4  
    yea I had issues as well with using the prototype ajax call. I ended up just using an XmlHttpRequest() object, with onreadystatechanged callback. That works in both versions of Webos
  5. chasden's Avatar
    Posts
    6 Posts
    Global Posts
    9 Global Posts
    #5  
    Thanks for the reply. I'll give that a shot.

    Quote Originally Posted by drahgon View Post
    yea I had issues as well with using the prototype ajax call. I ended up just using an XmlHttpRequest() object, with onreadystatechanged callback. That works in both versions of Webos
  6. chasden's Avatar
    Posts
    6 Posts
    Global Posts
    9 Global Posts
    #6  
    Swapping out the prototype Ajax.Request code with XHR also does not work on my Pre 2, but works fine on my Pre running 1.4.5.

    Any other ideas?
  7. chasden's Avatar
    Posts
    6 Posts
    Global Posts
    9 Global Posts
    #7  
    Just wanted say that the problem I was experiencing under WebOS 2.x, which I thought was an AJAX problem was in fact related to how WebOS 2.x handles JSON data. Key/value pairs must use double quotes in WebOS 2.x, while WebOS 1.x would accept single quotes. After searching and replacing my single quotes for double quotes, my app was suddenly working on a Pre2.

    Hope this update save someone else some time and effort!

    See this thread for a full discussion of the issue:
    https://developer.palm.com/distribut...p=67378#p67378

Posting Permissions