Results 1 to 6 of 6
  1.    #1  
    Ok, I read Derek's article today (From zero to webOS developer in one month), and am even more motivated to learn to develop in WebOS, but I don't want to learn to develop on the "old" Mojo framework, but Enyo instead. I downloaded the Enyo SDK (and Eclipse as an alternative to Ares). So how do I get Ares and/or Eclipse to point to the new Enyo framework so I am learning "the latest," or am I off base here? Thanks for the tips!

    Kurt
  2. #2  
    Quote Originally Posted by kvandy1 View Post
    Ok, I read Derek's article today (From zero to webOS developer in one month), and am even more motivated to learn to develop in WebOS, but I don't want to learn to develop on the "old" Mojo framework, but Enyo instead. I downloaded the Enyo SDK (and Eclipse as an alternative to Ares). So how do I get Ares and/or Eclipse to point to the new Enyo framework so I am learning "the latest," or am I off base here? Thanks for the tips!

    Kurt
    Enyo development is under an NDA and can only be discussed in the early access forums. You should ask your question there.
  3. #3  
    Enyo is still just a framework... there are no plugs into the API's yet... you will still have to use mojo for now anyway
  4.    #4  
    Thanks for pointing that out - I will post all future Enyo questions there.
  5. #5  
    Quote Originally Posted by antonio3 View Post
    Enyo is still just a framework... there are no plugs into the API's yet... you will still have to use mojo for now anyway
    Is this still the case? Can we integrate in Eclipse? And how would I do this?
    Motorola Startac-> Motorola RAZR -> Motorola RAZR V3 -> Blackberry Curve -> Blackberry Bold -> Iphone 3G -> Iphone 3GS -> Palm Pre -> Blackerry Bold 2 -> Iphone 4 -> Palm Pre 2 -> HP Veer
  6. #6  
    Quote Originally Posted by benleroux View Post
    Is this still the case? Can we integrate in Eclipse? And how would I do this?
    I'm really new at this as well and I'm coming at this with only minor experience in HTML. I'm going to be focusing on the TP for now so I chose to start with enyo and skip mojo per a couple of suggestions I read in the forums. I followed the directions on the "Developing with the Eclipse™ IDE" site under the resources section of the developer site.

    I hope that is what You're asking. The package installed is version 2+ but I do have the latest 3.0 SDK build installed. I was told that If I'm going to be doing TP exclusively to skip Ares and use this. Some feedback would be awesome!

    I do have and really like notepad++ and I'm too inexperienced to make a preferred choice of which I should be using. When I do stuff, I tend to do it as efficiently and cleanly as possibly; I'm extremely picky and detail oriented so I think I would do well with being an app developer.

    Here is a snippet from the default contents of the index.html file when I choose new basic Applilcation from eclipse: "<script src="/usr/palm/frameworks/mojo/mojo.jsjsjs&$quot$; $type$=&$quot$;$text$/$javascript$&$quot$; $x$-$mojo$-$version$=&$quot$;$1$&$quot$;&$gt$;&$lt$;/$script$&$gt$;&$quot$;
    Mojo version is defaulting to 1, TP is 2. I presume I just ensure that is changed to 2 and I'm fine.
    Last edited by observator; 07/10/2011 at 09:38 PM.

Posting Permissions