Results 1 to 13 of 13
Like Tree2Likes
  • 2 Post By jayteeee
  1.    #1  
    I use multiple Palm Os programs for work and still love the Palm Desktop PIM using Classic. There are no WebOS programs that will do what I need yet. Is there a way to prevent the update to WebOS 2.0 until HP or some third party finds a way to help all the Classic users? This way I can still use my Pre Plus. If there is no way to block the update, then I may have to go back to my old Tungsten or change platforms. Thank you for you help/advice.
  2. #2  
    Quote Originally Posted by jcgreenfield View Post
    I use multiple Palm Os programs for work and still love the Palm Desktop PIM using Classic. There are no WebOS programs that will do what I need yet. Is there a way to prevent the update to WebOS 2.0 until HP or some third party finds a way to help all the Classic users? This way I can still use my Pre Plus. If there is no way to block the update, then I may have to go back to my old Tungsten or change platforms. Thank you for you help/advice.
    Come on, use the search.

    Basically you disable the update daemon by removing the execute permissions on it.



    -- Sent from my Palm Pre using Forums Beta
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  3. #3  
    I read the other posts, but can't figure out how to enter the code that will disable automatic updates, which is posted below, thanks WebOSI,
    Do i launch Terminal and enter it one line at a time?


    Here is a quick and dirty way to block webOS updates:

    cd /usr/bin
    mount -o remount,rw /
    chmod -x UpdateDaemon
    mount -o remount,ro /

    Then, either reboot or execute:
    killall UpdateDaemon

    No more executing the update program.



    Re-Enable Updates

    If you disabled your update you might want to re-enable it at some point.

    cd /usr/bin
    mount -o remount,rw /
    chmod +x UpdateDaemon
    mount -o remount,ro /

    Then restart your phone and automatic updating should be back.
  4. #4  
    Quote Originally Posted by NuttyBunny View Post
    Come on, use the search.

    Basically you disable the update daemon by removing the execute permissions on it.



    -- Sent from my Palm Pre using [url= Beta[/url]
    The person is new, we should try to be a little more understanding of that.
    Sent from my favorite gadget!
  5. #5  
    Quote Originally Posted by BS Mann View Post
    I read the other posts, but can't figure out how to enter the code that will disable automatic updates, which is posted below, thanks WebOSI,
    Do i launch Terminal and enter it one line at a time?


    Here is a quick and dirty way to block webOS updates:

    cd /usr/bin
    mount -o remount,rw /
    chmod -x UpdateDaemon
    mount -o remount,ro /

    Then, either reboot or execute:
    killall UpdateDaemon

    No more executing the update program.



    Re-Enable Updates

    If you disabled your update you might want to re-enable it at some point.

    cd /usr/bin
    mount -o remount,rw /
    chmod +x UpdateDaemon
    mount -o remount,ro /

    Then restart your phone and automatic updating should be back.
    This also works to prevent the 3.0.4 automatic updates on the Touchpad. Thank you!

    Kind regards

    D.
  6. #6  
    Thanks for the tip dude
    this stop my hp touchpad from updating and losing patches and junk and porking my moboot fill me
  7. #7  
    I see what to enter, but where/how do we enter this code? Step by step
  8. #8  
    the word is terminal (xecutah), but beware if you don't understand the power of linux command line, you should stay away from it.
    You could render your device unuseable by simply forgetting one character, only recoverable by a doctor session.
  9. #9  
    OK, installed terminal (xecutah and other 2 required installs) and entered the lines as described above. Is there any way to verify that the autoupdate is disabled. In system updates the "checking for updates"... just spins away or is that my verification. Thanks guys for this post. I was afraid of the update messing up my CM7 Moboot.
  10. #10  
    I would just like to point out that the procedure described in this thread is overly complex considering that all you have to do to accomplish the same end is:

    1. run Internalz Pro in master mode (flip the switch at the bottom of Internalz Pro's Preferences)

    2. navigate to (root)/usr/bin

    3. scroll down to and get info on "UpdateDaemon"

    4. change the linux permissions of UpdateDaemon to -x -x -x from their default of +x +x -x

    5. press "ok" and then restart your WebOS device (Touchpad or phone).

    6. Profit! Sorry, meant Done!

    To reverse this, just go back in with Internalz Pro and change the permissions of UpdateDaemon back to +x +x -x and then restart the device.

    Easy peasy. No more unwanted, surprise OS updates before you "de-patch."

    I advise that you don't leave "Internalz Pro" in master mode and use master mode only when necessary.

    By the way, changing the permission on "UpdateDaemon" has absolutely no effect on updating software through HP or Preware. It only keeps the OS from updating.

    I hope this helps out as this is what I did recently to keep my TP from updating from 3.04 to 3.05 until the patches I wanted were available. Worked perfectly, of course!
    Last edited by jayteeee; 01/31/2012 at 03:49 PM.
    arasarn and WknThDg like this.
  11. #11  
    Quote Originally Posted by BS Mann View Post
    Here is a quick and dirty way to block webOS updates:
    Will the UpdateDaemon still OFF if I will check manualy for available firmware updates after that (Settings -> Device Info)?
  12. #12  
    Quote Originally Posted by jayteeee View Post
    I would just like to point out that the procedure described in this thread is overly complex considering that all you have to do to accomplish the same end is:

    1. run Internalz Pro in master mode (flip the switch at the bottom of Internalz Pro's Preferences)
    2. navigate to (root)/usr/bin
    3. scroll down to and get info on "UpdateDaemon"
    4. change the linux permissions of UpdateDaemon to -x -x -x from their default of +x +x -x
    5. press "ok" and then restart your WebOS device (Touchpad or phone).
    6. Profit! Sorry, meant Done!

    To reverse this, just go back in with Internalz Pro and change the permissions of UpdateDaemon back to +x +x -x and then restart the device.

    Easy peasy. No more unwanted, surprise OS updates before you "de-patch."

    I advise that you don't leave "Internalz Pro" in master mode and use master mode only when necessary.

    By the way, changing the permission on "UpdateDaemon" has absolutely no effect on updating software through HP or Preware. It only keeps the OS from updating.

    I hope this helps out as this is what I did recently to keep my TP from updating from 3.04 to 3.05 until the patches I wanted were available. Worked perfectly, of course!
    GREAT TIP!!!
    Just a note... this prevents both WebOS Automatic & Manual System Updates.
    See screenshots below:
    UpdateDaemon (System Updates Enabled-Default)
    UpdateDaemon (System Updates Disabled-Modified)
    System Updates Disabled Confirmation
  13. #13  
    If you haven't been pushed a 2.0 update yet, you probably never will. The Pre/Pre+ never officially got 2.1 (except for one foreign Pre+ model IIRC)

    Also, there's a way to hack Classic onto webOS 2 -- works on my Pre 2 -- webOS 2.2.4
    m505 > Z|71 > T|C > T|T3 > LifeDrive > iPod touch 4 >
    Pre 2 > Treo Pro > Aria > Treo 650 > Lumia 920 > BB Z10 > BB Q10
    Lumia 830 > 635 > iPhone 5s > Galaxy Alpha > Lumia 640 >
    iPhone 5c > Nexus 5 > Nexus 5X > Blackberry Priv
    My Palm OS Archive

Posting Permissions