Results 1 to 8 of 8
  1.    #1  
    i have windows vista and Ive downloaded the latest version of virtualbox and the latest sdk. when i click on the palm emulator it wont start.
  2. #2  
    Quote Originally Posted by hazeb43 View Post
    i have windows vista and Ive downloaded the latest version of virtualbox and the latest sdk. when i click on the palm emulator it wont start.
    You say you have Windows Vista. Are you using x86 or x64?
    Arthur Thornton

    Former webOS DevRel Engineer at Palm, HP, and LG
    Former webOS app developer (built Voice Memos, Sparrow, and several homebrew apps and patches)
    Former blogger for webOS Nation and webOS Roundup
  3.    #3  
    x86
  4. #4  
    Try reinstalling VirtualBox. That is what did it when I had trouble.
  5. #5  
    Quote Originally Posted by hazeb43 View Post
    x86
    Do you have Java installed?
    Arthur Thornton

    Former webOS DevRel Engineer at Palm, HP, and LG
    Former webOS app developer (built Voice Memos, Sparrow, and several homebrew apps and patches)
    Former blogger for webOS Nation and webOS Roundup
  6. WyreNut's Avatar
    Posts
    123 Posts
    Global Posts
    127 Global Posts
    #6  
    I had the same problems getting the emulator to open on my Vista64 laptop, and reported it in the Dev forum.

    Two extra steps were necessary to get the Emul to run:

    1. Even though Palm's Dev website's #2 step checked my version of Java as "Correct", it misidentified the 32bit version as the right one. I had to download a 64bit version (using IE 64) to grab it.

    2. I then had to enter a new System Environment Path to direct windows to the 64 bit folder for Java :

    ;C:\Program Files\Java\jre6\bin

    Check to see if you have Java executables in the system path. Here is a quick rundown:

    Open a command prompt (Start->Run - Then type "cmd" and press enter)
    Simply type "java" at the command prompt and press enter.
    If you get a file not found, then the path to the Java executables is not located in the system path.

    To correct this, open your control panel. Click on "System" and "System" again then "Advanced System Settings". Then click "Environment Variables" button. Go down to the "System" variables box and scroll down and find the variable "Path". Edit the system path to add a:

    ;C:\Program Files\Java\jre6\bin

    to the end of it (assuming you are running a 64bit version of Windows, otherwise add the "(x86)" to the Program Files to direct to the 32 bit Java.

    Don't type any quotes "".

    Finally the Emul opened! Palm's troubleshooting suggestions are comprised of "Uninstall/Reinstall" which I tried twice, but then realized I was defining the topic of "insanity"... Same task, expecting different results?

    Hope this helps! This is the only way I can play with 1.4.5 since I have an AT&T Pre Plus...

    WyreNut
    Pre2/3/TouchPad, and TouchDroid user.
  7. #7  
    Quote Originally Posted by WyreNut View Post
    I had the same problems getting the emulator to open on my Vista64 laptop, and reported it in the Dev forum.

    Two extra steps were necessary to get the Emul to run:

    1. Even though Palm's Dev website's #2 step checked my version of Java as "Correct", it misidentified the 32bit version as the right one. I had to download a 64bit version (using IE 64) to grab it.

    2. I then had to enter a new System Environment Path to direct windows to the 64 bit folder for Java :

    ;C:\Program Files\Java\jre6\bin

    Check to see if you have Java executables in the system path. Here is a quick rundown:

    Open a command prompt (Start->Run - Then type "cmd" and press enter)
    Simply type "java" at the command prompt and press enter.
    If you get a file not found, then the path to the Java executables is not located in the system path.

    To correct this, open your control panel. Click on "System" and "System" again then "Advanced System Settings". Then click "Environment Variables" button. Go down to the "System" variables box and scroll down and find the variable "Path". Edit the system path to add a:

    ;C:\Program Files\Java\jre6\bin

    to the end of it (assuming you are running a 64bit version of Windows, otherwise add the "(x86)" to the Program Files to direct to the 32 bit Java.

    Don't type any quotes "".

    Finally the Emul opened! Palm's troubleshooting suggestions are comprised of "Uninstall/Reinstall" which I tried twice, but then realized I was defining the topic of "insanity"... Same task, expecting different results?

    Hope this helps! This is the only way I can play with 1.4.5 since I have an AT&T Pre Plus...

    WyreNut
    The user already said they're on x86.

    Also note that only 64-bit Windows has a "Program Files (x86)" directory. The x86 version puts all programs into "Program Files"
    Arthur Thornton

    Former webOS DevRel Engineer at Palm, HP, and LG
    Former webOS app developer (built Voice Memos, Sparrow, and several homebrew apps and patches)
    Former blogger for webOS Nation and webOS Roundup
  8. WyreNut's Avatar
    Posts
    123 Posts
    Global Posts
    127 Global Posts
    #8  
    Then perhaps my post will help users with 64bit versions when they search for "emulator won't start up".

    WyreNut
    Pre2/3/TouchPad, and TouchDroid user.

Posting Permissions