Results 1 to 8 of 8
  1.    #1  
    So now that I've got sftp access to my pre, I'm getting annoyed at having to change the ip address in FileZilla every time I get on a different router (this happens more than I thought it would). So I set up a dyndns account and I was trying to figure out how to modify this walkthrough here to get my WiFi addy not my EVDo addy. I assume it happens in this line

    curl -s --retry 6 "http://XXX:YYY@members.dyndns.org/nic/update?hostname=ZZZ.ZZZ.com&myip=${IPLOCAL}&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"

    IPLOCAL contains the EVDo IP address (ppp0), how can I make it contain the WiFi addy instead (ppp1, I'm guessing)?

    Thanks!

    edit: I'm trying to use method B of the walkthrough.
    Last edited by Suava; 07/23/2010 at 04:08 PM. Reason: extra info
  2. ay
    ay is offline
    ay's Avatar
    Posts
    720 Posts
    Global Posts
    772 Global Posts
    #2  
    Quote Originally Posted by Suava View Post
    So now that I've got sftp access to my pre, I'm getting annoyed at having to change the ip address in FileZilla every time I get on a different router (this happens more than I thought it would). So I set up a dyndns account and I was trying to figure out how to modify this walkthrough here to get my WiFi addy not my EVDo addy. I assume it happens in this line

    curl -s --retry 6 "http://XXX:YYY@members.dyndns.org/nic/update?hostname=ZZZ.ZZZ.com&myip=${IPLOCAL}&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"

    IPLOCAL contains the EVDo IP address (ppp0), how can I make it contain the WiFi addy instead (ppp1, I'm guessing)?

    Thanks!

    edit: I'm trying to use method B of the walkthrough.
    If each of the networks you use for wi-fi uses the same IP address range, you can just set a static IP address on your Pre. That's what I do. Generally speaking, I only connect to wi-fi on my home and work networks, so I just set a static IP address on the Pre that works for both networks. On the rare occasion that I need to connect to a different network, I just remove the static IP address from the Pre, and then reset it back again when I'm done. Would that work for you?
  3.    #3  
    Quote Originally Posted by ay View Post
    Would that work for you?
    I think I know how to do that on my router at home (which I can control), but how do I do this on the router at work and at the coffee shop and other random hot spots I linger around during the course of a day (which I do not have admin access too)? Is there a way to make the Pre request a certain IP?
  4. ay
    ay is offline
    ay's Avatar
    Posts
    720 Posts
    Global Posts
    772 Global Posts
    #4  
    Quote Originally Posted by Suava View Post
    I think I know how to do that on my router at home (which I can control), but how do I do this on the router at work and at the coffee shop and other random hot spots I linger around during the course of a day (which I do not have admin access too)? Is there a way to make the Pre request a certain IP?
    Yes - that's actually what I was indicating to do (as opposed to doing it from your router). You'll need to do this for each network though (i.e. - work, home, coffee shop, etc.). If you can set the same IP address for each network, that would be great, but it may not work - it depends on what range of IP addresses each network uses. For me, my home and office both use the same IP range (and I control both routers), so it was easy enough for me to have the same network name and IP address for both locations. Worst case scenario, you'll have a few different connections in FileZilla (Palm Pre home, Palm Pre office, Palm Pre coffee shop), but at least you won't need to keep changing the IP address manually in FileZilla.

    To set the IP address static for each connection on the Pre, open Wi-Fi Preferences, click the particular network (i.e.-home, work, coffee shop, etc.), set Automatic IP settings to Off, then enter the applicable IP address manually along with the applicable subnet address, gateway, and dns server, and then click Done. You can use whichever IP address the particular router gave you when you connected and make that static if that's easiest (that will confirm you're in the right IP address range). And then you'll always have that IP address when you connect at that location so long as someone else hasn't already snagged that IP address at that particular moment - you won't likely have this issue at home where you can reserve the IP address for yourself, but you could theoretically have to wait for it to become free again at the coffee shop (unless you pick one high up in the range that isn't likely to be grabbed). I hope this makes sense? If not, please feel free to ask any questions, and I'll try to continue to help (although I may not log back onto this site again until tomorrow - the wife is "patiently" waiting for me to turn off the computer already ).
  5.    #5  
    Quote Originally Posted by ay View Post
    To set the IP address static for each connection on the Pre, ....
    Rockin', thanks!
  6.    #6  
    So I ran into a little issue in that every time I open WiFi preferences it defaults to "automatic" so the solution above does not seem to be working well for me

    Ok, so I've been playing with this a bit more, since I want to replicate the EVDO walkthrough for WiFi. I'm a bit of a noob when it comes to the *nix backend of my pretty OSX gui, but I poked around there some and did some googling and it looks like for WebOS eth0 is the WiFi interface. (I managed to get ssh working so I can use Terminal app on my mac which makes things infinitely easier. While poking around in webos's /etc/ directory I found some references to something called bnep0, which I'm hoping is a way to connect the pre to another computer via bluetooth, but that's for another day.)

    Anyway, I'd still like to figure out how to update dyndns every time my Pre gets assigned another WiFi ip address. Can someone who knows more about this stuff please help?
  7. ay
    ay is offline
    ay's Avatar
    Posts
    720 Posts
    Global Posts
    772 Global Posts
    #7  
    Quote Originally Posted by Suava View Post
    So I ran into a little issue in that every time I open WiFi preferences it defaults to "automatic" so the solution above does not seem to be working well for me

    Ok, so I've been playing with this a bit more, since I want to replicate the EVDO walkthrough for WiFi. I'm a bit of a noob when it comes to the *nix backend of my pretty OSX gui, but I poked around there some and did some googling and it looks like for WebOS eth0 is the WiFi interface. (I managed to get ssh working so I can use Terminal app on my mac which makes things infinitely easier. While poking around in webos's /etc/ directory I found some references to something called bnep0, which I'm hoping is a way to connect the pre to another computer via bluetooth, but that's for another day.)

    Anyway, I'd still like to figure out how to update dyndns every time my Pre gets assigned another WiFi ip address. Can someone who knows more about this stuff please help?
    a) I skimmed the link you provided (although admittedly rather quickly), and it looks like that is only for using a dynamic IP address based on your cell phone service provider's signal (evdo), not for when you're connected to wi-fi. Did I miss something? If I'm correct, it won't do what you're looking to do.

    b) Are you saying that each time you open the specific wi-fi network under Wi-Fi Preferences that you're connected to it defaults back to Automatic IP Settings even though you had previously set that specific network connection to static? Or are you referring to networks you haven't yet set to static? You need to manually set each specific network to static the first time you connect to it, and then you should be all set after that. The settings should not be switching from static back to Automatic on its own. If that's what's actually happening to you, then something seems to be wrong with your phone....

    Can you post snap shots of what you're doing with regards to the automatic/static settings to show specifically what you're seeing and doing? If so, I can see if I can help further on the method we previously "discussed". It works perfectly for me, so I'm not sure why it wouldn't for you as well unless something isn't getting communicated clearly between us?
  8.    #8  
    Quote Originally Posted by ay View Post
    a) I skimmed the link you provided (although admittedly rather quickly), and it looks like that is only for using a dynamic IP address based on your cell phone service provider's signal (evdo), not for when you're connected to wi-fi. Did I miss something? If I'm correct, it won't do what you're looking to do.
    Right, following that link it only updates when ppp0 changes. I looked though WebOS's guts but I couldn't find anything that screamed out to me "put a script in this folder and I'll run it every time eth0 (the wifi connection) changes."

    Quote Originally Posted by ay View Post
    b) Are you saying that each time you open the specific wi-fi network under Wi-Fi Preferences that you're connected to it defaults back to Automatic IP Settings even though you had previously set that specific network connection to static? Or are you referring to networks you haven't yet set to static? You need to manually set each specific network to static the first time you connect to it, and then you should be all set after that. The settings should not be switching from static back to Automatic on its own. If that's what's actually happening to you, then something seems to be wrong with your phone....

    Can you post snap shots of what you're doing with regards to the automatic/static settings to show specifically what you're seeing and doing? If so, I can see if I can help further on the method we previously "discussed". It works perfectly for me, so I'm not sure why it wouldn't for you as well unless something isn't getting communicated clearly between us?
    Yes, every time I open wifi prefs on a specific connection it's back to automatic-on (even though I turned it off and entered an ip addy previously). Anyway, I'd really like to get the first method working regardless of if I can get my wifi prefs to stay on manual.

Tags for this Thread

Posting Permissions