Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 78
  1. #21  
    i had the same problem, but i had a easier successful method.

    i installed terminus

    then just changed my "user" password

    # passwd <user_name>

    after that i was able to ssh in again. hope that helps anyone.
  2. #22  
    See http://forums.precentral.net/2275484-post5.html for the solution to SSH problems.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  3.    #23  
    fixed. Thanks rod!
    "When there is no more room in hell, the dead will walk the earth"


    PM me your questions, If I cant find an answer, I'll show you who can.
  4. #24  
    Quote Originally Posted by gu12u7 View Post
    i had the same problem, but i had a easier successful method.

    i installed terminus

    then just changed my "user" password

    # passwd <user_name>

    after that i was able to ssh in again. hope that helps anyone.
    I had used the "old" SSH and Putty/WinSCP method of accessing my Pre over WiFi.

    This method wasn't quite enough for me, but I did not have to do all the steps that dl1ely suggested.

    I installed and ran terminus.

    Made the file system writeable: "mount -o remount,rw /"

    added back my original user name

    "adduser myoldname"

    The system prompted me for a new password. I just used the one I had been using with Putty/WinSCP.

    Made the file system read only "mount -o remount,ro /"

    exited and was able to SSH in with my previous settings on my PC.

    The result is it created a new folder in /home

    and my old user folder is in /var/home

    Both are empty. The new one is owned by root, but that does not appear to be an issue.

    Everything works, although I probably have violated some best practices and I expect i may have to repeat the process on a future update. But I tend to store everything on my /media/internal drive or under /opt
  5. aric's Avatar
    Posts
    104 Posts
    Global Posts
    108 Global Posts
    #25  
    quick question.

    i used to have dropbear installed from a long time ago. when the ip address of the Pre would change and I ssh in, it would ask if I wanted to accept the connection and ask for the password and reconnect. I uninstalled dropbear yesterday and installed openssh using Preware, followed the instructions for generating a key and everything was groovy.

    Today, the power went out for a bit and the when the router came back up it did is DCHP thing and reassigned new IP addressed to all the devices hooked up, both wired and wireless. OK, now the Pre has a new address. Didn't used to be a problem with dropbear (I'm sure because it was less secure), but with openssh I get this message:

    nano-mac-2:.ssh aric$ ssh root@192.168.0.25
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that the RSA host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    1e:e4:02:48:fd:a7:bc:17:08:42:05:c7:9d:b7:5b:a3.
    Please contact your system administrator.
    Add correct host key in /Users/aric/.ssh/known_hosts to get rid of this message.
    Offending key in /Users/aric/.ssh/known_hosts:6
    RSA host key for 192.168.0.25 has changed and you have requested strict checking.
    Host key verification failed.


    ANSWER: Sorry for the long post, I'll leave it up just in case someone else finds themselves in a similar situation. All I had to do was delete the know_host file in the .ssh directory. (rm /~/.ssh/know_host). (/Users/username/.ssh directory) (OS X 10.6.2)
    Last edited by aric; 03/03/2010 at 07:18 PM. Reason: more info
  6. SDash's Avatar
    Posts
    256 Posts
    Global Posts
    260 Global Posts
    #26  
    I haven't gotten used to the new installation method of openssh and I feel like I'm missing something. After creating the keys and putting it in the authorized_keys directory and for the putty client to use I receive a "Server refused our keys".

    I have a feeling i'm missing a step somewhere before installing openssh or problem with permissions.

    Any help is appreciated. Thanks.

    EDIT: Sorry, I figured it out myself after all. I had thought that the "authorized_keys" was a folder not a file. I guess I was misled by the name.
    Last edited by SDash; 03/04/2010 at 02:21 AM.
  7. #27  
    Previous to 1.4, I had no trouble running Putty and WinSCP to get to my pre. After installing 1.4, both broke.

    I first followed the "install the OpenSSH SFTP Server" from Preware suggestion, didn't get any further. I then installed terminus, then added back the user that 1.4 must have deleted, and was able to get a Putty connection to work, but when I tried WinSCP, it looked like everything was working fine, but I got the following message instead of the two file lists I previously got:

    Connection has been unexpectedly closed. Server sent command exit status 1.
    Cannot initialize SFTP protocol. Is the host running a SFTP server?

    Any idea how to
    a. check if the sftp server is running on my pre?
    b. ensure that it starts if not running
  8.    #28  
    Quote Originally Posted by heth View Post
    Is it actually possible to access the pre via ssh while being on 3G? Iīve read somewhere here on the forums that it wonīt work as most of the providers somehow block this.

    I can confirm that using lighty webserver on my pre, I am not able to access that while being on 3G and thatīs with port 80 which should run fine.
    works fine on sprint. Although wifi is faster.
  9. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #29  
    you'll have to use novacom or webOS QuickInstall's command line.... There you can issue the command 'ps -ef > /processes.log' then use QuickInstall to copy the file to your PC and open it in notepad and see if SFTP is runing that way. If it's not running then you can use QuickInstall's command line to run /opt/libexec/sftp-server
  10. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #30  
    Quote Originally Posted by mrloserpunk View Post
    works fine on sprint. Although wifi is faster.

    What worx fine? Lighttpd or SSH?
  11.    #31  
    Quote Originally Posted by DrewPre View Post
    What worx fine? Lighttpd or SSH?
    SSH

    What is lighttpd?
    "When there is no more room in hell, the dead will walk the earth"


    PM me your questions, If I cant find an answer, I'll show you who can.
  12. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #32  
    I tried to access lighttpd [what heth refers to as lighty webserver] over ppp0 and couldn't. I verified it worked over usb0. got the message 'Lighttpd server is running'. Lighty server [lighttpd] is a light weight http server.

    I used the same method to try and get ssh workiing over ppp0 [evdo]. It doesnt, even tho usb0 [USBnet] worx.

    Plz explain how you do this...
  13.    #33  
    all that is above my head. No server here. Just using Winscp to access my pre over evdo. Sorry!

    I use port 222 and have it configured from here

    how about first time using "PM me your questions, If I cant find an answer, I'll show you who can" in my tag and i'm it's saying over my head............
    Last edited by mrloserpunk; 03/07/2010 at 02:45 AM.
    "When there is no more room in hell, the dead will walk the earth"


    PM me your questions, If I cant find an answer, I'll show you who can.
  14. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #34  
    And for the record, lighttpd [Lightty webserver] doesn't work on any port over ppp0/EVDO/3G.... I have tried setting up lighttpd on ports 12451, 8081, 1039, & 97 and although it works on all of those ports over USB0/USBnet...it does not work over ppp0/EVDO/3G.

    This suggests, they [sprint] have some sort of packet inspection that is blocking http packets not that they're blocking port numbers.

    I suspect the same for SSH
  15.    #35  
    can i prove I'm ssh into the pre over evdo somehow?

    wait are you saying you suspect you cant ssh into the pre over sprint evdo?
    "When there is no more room in hell, the dead will walk the earth"


    PM me your questions, If I cant find an answer, I'll show you who can.
  16. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #36  
    Quote Originally Posted by mrloserpunk View Post
    all that is above my head. No server here. Just using Winscp to access my pre over evdo. Sorry!

    I use port 222 and have it configured from here
    If you're using those instructions you're accessing ssh over USBnet, not EVDO.

    USBnet uses a private class ip address range [e.g. 192.168.x.x, 172.16.x.x., 10.1.x.x, etc]

    EVDO uses a public range accessible by everyone on the interweb.

    At one time I was able to set up lighttpd, dynamicdns.org, and google maps so that I could browse to http://drewpre.dyndns.org and get a google map displaying the exact location of my Palm pre at any time without any cards open. If my Pre was on, I would always be able to find it online.

    Not anymore.
  17.    #37  
    so, usbnet is more than usb? I'm not connected via usb. Wifi is not on. I'm accessing an IP other than my cable internets.... I'm operating over evdo right??? (not meant to be a smart*** here)
    "When there is no more room in hell, the dead will walk the earth"


    PM me your questions, If I cant find an answer, I'll show you who can.
  18. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #38  
    More than likely you're using WinSCP to SSH to your PRE on ip address 192.168.0.202 and port number 222.

    if you were using WinSCP to SSH to your Pre over EVDO it would be using an ip address of something like... 93.208.243.162 or 70.10.201.201
  19.    #39  
    I'm going in via 2 ip's

    One over Wifi (192.)

    Second over Evdo (173.)??


    I have 2 profiles in winscp saved. One giving me access from anywere, one only @ home but faster
    "When there is no more room in hell, the dead will walk the earth"


    PM me your questions, If I cant find an answer, I'll show you who can.
  20. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #40  
    if you SSH to your Pre, run 'ifconfig'. Locate the interfaces ppp0, eth0, and usb0. [LO and USB0:1 are also there, but aren't needed for anything we do on PreCentral]

    Those are the interfaces for your EVDO [or 3G], WiFi, and USBnet network connections, respectively.

    Each interface has an ip address associated with it.

    Compare those ip addresses with the ip address you used to configure WinSCP.

    It wouldn't be EVDO/PPP0...that IP address changes everytime you reboot your Palm Pre or leave and re-enter sprints network coverage area. Consequently if you were using WinSCP to SSH over EVDO you would have to change WinSCP virtually every time you used it to match the constantly changing ip address for EVDO interface, ppp0.

    If you're never changed your WinSCP config [other than its initial setup] then you're probably accessing it via one of the other interfaces [USBnet or Wifi].
Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions