Results 1 to 1 of 1
  1.    #1  
    Hi there (first post, i own my Pre only a couple of days now... )

    Short story: I tried to use Mail via an OpenVPN tunnel, but the Pre seems to get the source IP address wrong... Possibly a bug?

    Long story:

    I installed openvpn via optware, configured it and it works ok!

    This is copy and paste from an SSH to the Pre via OpenVPN:

    Code:
    palm-webos-device root # ifconfig
     ...
    ppp0      Link encap:Point-to-Point Protocol  
              inet addr:10.148.xx.xx  P-t-P:10.64.64.64  Mask:255.255.255.255
     ...
    tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
              inet addr:10.1.3.34  P-t-P:10.1.3.33  Mask:255.255.255.255
     ...
    The routing table is ok (i omitted the USB device):
    Code:
    palm-webos-device root # netstat -rn
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
    10.64.64.64     0.0.0.0         255.255.255.255 UH        0 0          0 ppp0
    10.1.3.1        10.1.3.33       255.255.255.255 UGH       0 0          0 tun0
    10.1.3.33       0.0.0.0         255.255.255.255 UH        0 0          0 tun0
    10.1.1.0        10.1.3.33       255.255.255.0   UG        0 0          0 tun0
    10.1.2.0        10.1.3.33       255.255.255.0   UG        0 0          0 tun0
    0.0.0.0         10.64.64.64     0.0.0.0         UG        0 0          0 ppp0
    My Mailserver (both IMAP and SMTP) is 10.1.1.81. I can ping it OK, so the routing works:
    Code:
    palm-webos-device root # ping 10.1.1.81
    PING 10.1.1.81 (10.1.1.81): 56 data bytes
    64 bytes from 10.1.1.81: seq=0 ttl=62 time=522.675 ms
    64 bytes from 10.1.1.81: seq=1 ttl=62 time=151.581 ms
    64 bytes from 10.1.1.81: seq=2 ttl=62 time=151.092 ms
    ...
    My source address is 10.1.3.34. So far, all is well.

    And now the funny thing:

    If i send a mail, the Mail App doesn't get a connection to the server. I confirmed it with "tcpdump", also from optware:

    Code:
    palm-webos-device root # tcpdump -lni tun0 port 25 
    ...
    listening on tun0, link-type RAW (Raw IP), capture size 68 bytes
    ^C
    0 packets captured
    0 packets received by filter
    0 packets dropped by kernel
    which remained silent. For good measure i tried the ppp0 interface, too, and voila:
    Code:
    palm-webos-device root # tcpdump -lni ppp0 port 25
    ...
    listening on ppp0, link-type LINUX_SLL (Linux cooked), capture size 68 bytes
    18:21:53.568359 IP 10.148.xx.xx.41584 > 10.1.1.81.25: Flags [S], seq 3479289076, win 5840, options [mss 1460,sackOK,TS[|tcp]>
    18:21:56.560607 IP 10.148.xx.xx.41584 > 10.1.1.81.25: Flags [S], seq 3479289076, win 5840, options [mss 1460,sackOK,TS[|tcp]>
    18:22:02.560668 IP 10.148.xx.xx.41584 > 10.1.1.81.25: Flags [S], seq 3479289076, win 5840, options [mss 1460,sackOK,TS[|tcp]>
    It looks like the Pre uses the "ppp0" source address and the default route, even for a destination in the "tun0" network and a working routing entry (10.1.1.0/24). Of course, that can't work.

    I get the same behaviour for the Mail App and port 143 (IMAP). I didn't test other Apps yet.

    Looks definitely like a bug to me.

    Any suggestions or a name/address at Palm i can forward this to?

    Thanks


    EDIT:

    It works OK when i use our local WLAN without VPN. But in that case i have another default route into our intranet:

    Code:
    palm-webos-device root # netstat -rn
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
    10.64.64.64     0.0.0.0         255.255.255.255 UH        0 0          0 ppp0
    10.1.1.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
    0.0.0.0         10.1.1.1        0.0.0.0         UG        0 0          0 eth0
    0.0.0.0         10.64.64.64     0.0.0.0         UG        0 0          0 ppp0
    and my source address on eth0 is in the 10.1.1.0/24 range...


    -Walter
    Last edited by WalterH; 02/26/2010 at 11:49 AM.

Posting Permissions