Page 4 of 12 FirstFirst 123456789 ... LastLast
Results 61 to 80 of 233
  1. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #61  
    With the exception of some cleanup functions, I've pretty much finished with the logic of the back-end service. The Utility will export and import any table from any database. Including application databases, but especially the PalmDatabse.db3 file. Of course exporting and importing will eliminate the need for a webOS version check so errors being reported with regard to that will be rendered irrelevant.

    The creation[recreation] of some fields within certain tables [com_palm_pim_FolderEntry, com_palm_pim_Persons, etc] of the PalmDatabase will be done without the COLLATE LOCALIZED_SECONDARY option. This option requires the external extension 'sqlite3_palm_extension.so', and there currently is no way to load this extension from within Java based services with the Pre's stock configuration.

    I am not exactly sure what affect that will have on a Pre, post-restore. The two tables mentioned above deal with Contacts, Emails messages and Chat messages. Any problems with Contacts can be circumvented by simply adding accounts and syncing prior to performing a restore. Thus the com_palm_pim_Persons table and all it's fields will be created already. The situation with Text Messages may create problems that are not obviously resolved though. Maybe thru sending yourself a text message prior to a restore as well. However, all my test in the emulator thus far have shown no noticeable errors or malformed or out of order texts. Email messages I guess could be checked as well prior to restore.

    I still need to update the front-end UI [mostly cosmetic but some logic] but I am going to need volunteers on this one to thoroughly test this.

    I could also use some advice... How does one list the installed apps on the Pre???

    The palm://com.palm.applicationManager/listApps d-bus service seems to be a private service available only to com.palm.* applications.

    Anyone have any ideas on how to do this???
    Last edited by DrewPre; 05/29/2010 at 05:27 PM.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  2. #62  
    Quote Originally Posted by DrewPre View Post
    Yea, I guess I misspoke. Although my app doesn't touch the Sprint NAV application itself. It does touch the dB file for this app and it's directory. Subsequently during restore it restores the DB file when [presumably after a webos doctor] the app has yet to be run and thus create a db file for itself.

    This will be resolved in the next version of the app. It will export tables from html 5 db enabled apps and when it is called upon to restore a specific app it will attempt to import those tables back into the app's db file. IF AND ONLY IF the db file exists, otherwise it writes to a log and leaves it alone.
    Nice one!

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  3. #63  
    Quote Originally Posted by DrewPre View Post
    I could also use some advice... How does one list the installed apps on the Pre???

    The palm://com.palm.applicationManager/listApps d-bus service seems to be a private service available only to com.palm.* applications.

    Anyone have any ideas on how to do this???
    For Save/Restore, I get the C service to call that private dbus applicationManager method and then return the results back up to Mojo.

    I don't know of a way to do it directly from Mojo without a helper service.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  4. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #64  
    Heh!

    Dude, I am just getting a hang of java and javascript. C??? HAHAHA!!

    I still haven't messed with that make file for php-fcgi yet. i went as far as the tutorial on webos-internals and haven't picked it up since.

    In due time tho. You're apps have always been the inspiration for me. Just look how the front end emulates Luna manager. The back end emulated package manager and now you've move preware to C.

    So I guess that's next for me also. heh!!! Baby steps tho.... How do you eat an Elephant? One bite at a time.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  5. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #65  
    And by the way... I am very impressed with the drastic increase in performance of PreWare since you've converted it to C.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  6. #66  
    I havent seen anywhere on how long the backup takes on average. Mine has been going for 25 min now. Is it stuck or doing what its supposed to do?
  7. #67  
    ok.. did the backup, doctored, reinstalled, patched, themed etc. go to restore and it tells me that its a diff version of webos and restoring could render the phone inoperable?!? I am positive i had 1.4.1.1 and that is what I have now. I verified after I doctored. Is this just a standard message? Is it safe to proceed? I dont plan to unless told otherwise. Thanks DrewPre!!
  8. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #68  
    I think there is an error in the logic somewhere...I intended that message to just be shown for archives made with versions of Pre Backup Util prior to 1.6.0.

    If you made the backup with 1.6.0 and are restoring with 1.6.0 [and your webOS versions are the same] you should be okay.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  9. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #69  
    can someone create a backup [under a meg] and see if it will create the false positive warning on the webOS version and then send me a copy of the archive along with the database file located in /media/internal/.app-storage/com.tntservices.prebackupuitilty

    I can't seem to recreate the false positive consistently enough to fix it.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  10. 12gage's Avatar
    Posts
    123 Posts
    Global Posts
    130 Global Posts
    #70  
    I tired to back up my phone but I have so many large games that I didn't have enough space to do so. could there be a way to select which apps to back up so I could skip the games? thanks in advance, and thanks for all of your hard work
  11. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #71  
    you could deselect everything except bookmarks and see if it will generate that error/warning

    currently I am in a holding pattern ..... I need to port the service over to C++.... I don't know C++ of course....and I have a few real world things going on that .... welll... are quite critical.

    However, once it's ported over to C++ and the problem with collation sequence LOAD_SECONDARY is resolved [and it will be since SQLite is written in C++] then I can work on enumerating all the applications and providing an interface to select/deselect each.

    In fact, I toyed with the idea of consolidating my efforts with Rod's Save/Restore... I think his knowledge of webos-internals apps and patches combined with a reliable way to export/import data to/from Palmdatabase.db3 [which I think I resolved except for the collation problem] could create an incredible app.
    Last edited by DrewPre; 06/06/2010 at 02:48 AM.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  12. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #72  
    I believe I have fixed the false positive on the webOS version warning.

    Update is available....

    Could use some feedback on that.

    Not going to update the service to include the sqlite import/export of PalmDatabase and app dbs until I re-write everything in C

    There's a learning curve involved and just don't have the time to set aside for that right now. Consequently, the solution to the above problem isn't the best solution but it works for the short term. [e.g. the volume lables on the archives aren't re-written but the info in the PBU DB for the referenced archive is accurate now]

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  13. PaulyZ's Avatar
    Posts
    20 Posts
    Global Posts
    21 Global Posts
    #73  
    DrewPre Thanks for your hard work - I think this is just what I've been looking for. Received a replacement and wanted to back up whatever I could before sending the old phone back. Question...

    How long does the backup usually take? I offloaded all pics/video to my pc already, then I started the process maybe 20 minutes ago and it's still spinning.

    Thanks again - and in advance!
  14. PaulyZ's Avatar
    Posts
    20 Posts
    Global Posts
    21 Global Posts
    #74  
    Update - this backup has been spinning for almost 3 hrs. I'm about to uninstall & reinstall, then try again. Of course, any input is greatly appreciated.
  15. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #75  
    you made your post at 10:22 pm.

    I was made aware of a bug that was fixed somewhere around 6pm tonight.

    an 80mb backup should take about 10 minutes. I would venture a guess if it's running a lot longer than that then you have the version that has the bug.

    Uninstall, restart, reinstall and try again.

    to be safe, just do that anyway and try again.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  16. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #76  
    ha just missed ya.

    I am gonna try and remove and reinstall again just to make sure that it is working.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  17. PaulyZ's Avatar
    Posts
    20 Posts
    Global Posts
    21 Global Posts
    #77  
    Great, thanks DrewPre! Running it now, I'm 5 minutes into a backup...

    I see that you instructed me to ininstall, restart, reinstall, but has anyone else experienced after installing that no icon shows, but then after a restart an icon appears? Same for uninstall... icon shows until restart, then it's gone. I always get the oddball stuff.
    Last edited by PaulyZ; 06/09/2010 at 04:10 PM.
  18. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #78  
    First, let me know if the backup finishes.

    Second, I experienced that as well. I think it's because of the postinst and prerm scripts i used.

    between Jason's ipkg builder and Rod's PreWare, I am not exactly sure if I should be using postinst & prerm or pmPostInstall & pmPreRemove scripts

    also if you're paying attention during the installation of Pre Backup Utililty the script runs the Java Restart prior to PreWare giving you the prompt that asks if you want to restart Java services.

    I noticed that the Ev icon goes down prior to the prompt.

    As for the icons, a luna restart should work also in lieu of a device restart

    I think there have been two recent updates to PreWare so in addition to the ambiguity on my part as to which scripts I should be using there is a problem with one of the recent version updates to PreWare.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  19. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
    #79  
    FTR, my uninstall/re-install was successful [aside from the aforementioned little quirks] and backup and restores complete successfully.

    Palm Pre Backup Utility...done!
    Locate Pre....done!
  20. PaulyZ's Avatar
    Posts
    20 Posts
    Global Posts
    21 Global Posts
    #80  
    The backup finished, I'm loading Preware on this thing & restarting now... I'll be performing the Save/Restore then the Pre Backup Utility restore once I move all the files over. I'll keep you posted.

    BTW I'm just over in Gwinnett & sending good vibes for the job prospect you talked abt recently. Thx again DP
Page 4 of 12 FirstFirst 123456789 ... LastLast

Tags for this Thread

Posting Permissions