Results 1 to 8 of 8
  1.    #1  
    I'm trying to set up SDK to create an app and I'm getting the follwoing error running the emlator:

    C:\Documents and Settings\ddegraff>"C:\Program Files\Palm\SDK\bin\palm-emulator.
    bat"
    Exception in thread "main" java.lang.UnsupportedClassVersionError: com/palm/webo
    s/emulator/ui/CommandLineParser (Unsupported major.minor version 49.0)
    at java.lang.ClassLoader.defineClass0(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)


    I have the following java installed:

    C:\Documents and Settings\ddegraff>java -version
    java version "1.3.1_01"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1_01)
    Java HotSpot(TM) Client VM (build 1.3.1_01, mixed mode)

    Any ideas? I following the instructions install Palm SDK Mojo on Windows.
  2. #2  
    I'm having the same problem. Any one with any thoughts?

    Thanks in advance.
  3. #3  
    Quote Originally Posted by kimshusband View Post
    I'm having the same problem. Any one with any thoughts?

    Thanks in advance.
    love the username!
    My site: Shanerooni, LLC
    Follow me on Twitter
    My apps: GuessWhat? | MazeHunter3D | Small Wonders | PhakePhoney | AutismAware | PicSketcher | Cubix | QuickSolve | QuickSpell | QuickTrace | QuickWhack | QuickSuite | Soccer Shots | Ballooning |
    Cubix
  4. #4  
    thanks... husband and dad first
  5. jrowens27's Avatar
    Posts
    10 Posts
    Global Posts
    11 Global Posts
    #5  
    Did anyone find an answer to this issue?
  6. spdqbr's Avatar
    Posts
    78 Posts
    Global Posts
    80 Global Posts
    #6  
    "Unsupported major.minor version 49.0" is usually an indication by java that the version of java you are running is not compatible with the class files you're trying to run. And in fact "java version "1.3.1_01"" confirms it.

    Palm says you need java 1.6 to run the PDK.
  7. #7  
    The java version is not the problem, as you can see from these captures. Anyone else have a thought?

    Sorry about the lack of actual links... I'm not sure why one has to have a post count of 10 to post links??? Whatever, I guess.

    img705.imageshack.us/img705/42/20100323083654.jpg
    img28.imageshack.us/img28/9238/20100323083701.jpg
    img260.imageshack.us/img260/518/20100323083630.jpg
  8. #8  
    I had this same issue as well when trying to run the emulator. It seems i had several old versions of the JRE installed, and the path setting in my environmental variables was still pointing to the older java install.

    I had something like this in my path:
    C:\Program Files\Oracle\jre\1.3.1\bin

    and changed it to:
    C:\Program Files\Java\jre6\bin

    emulator worked fine after the change..

Posting Permissions