Results 1 to 9 of 9
  1.    #1  
    okay so when i'm in winSCP i can't edit files. i can't delete.. let's say a picture....

    because i don't have correct privileges.

    i know you can do sudo in putty... but how do you do it in a gui of winscp?

    thanks
  2. #2  
    While in WInSCP, go up to Commands and then click Open in Putty (Control-P) , this will launch a Putty window. Once in there, running sudo will give you the rights you need. I also have to run the command that sets read/write on the file system, this is done running: "mount -o remount,rw /" and then "mount -o remount,ro /" to set them back to read only.
  3.    #3  
    Quote Originally Posted by mike_pre View Post
    While in WInSCP, go up to Commands and then click Open in Putty (Control-P) , this will launch a Putty window. Once in there, running sudo will give you the rights you need. I also have to run the command that sets read/write on the file system, this is done running: "mount -o remount,rw /" and then "mount -o remount,ro /" to set them back to read only.
    so.. you can't do sudu as a gui type?

    if you want to delete a file you have to do it through command line?
  4. #4  
    No you just need to open a putty window and run what Mike pre said or rootfs_open -w. Then you use winscp like you would windows explorer. You can also setup winscp to open up putty automatically with your information in and then all you have to do is the sudo command.
  5.    #5  
    Quote Originally Posted by mamouton View Post
    No you just need to open a putty window and run what Mike pre said or rootfs_open -w. Then you use winscp like you would windows explorer. You can also setup winscp to open up putty automatically with your information in and then all you have to do is the sudo command.
    did...
    rootfs_open -w
    and got
    Code:
    derik123derik123@palm-webos-device:~$ rootfs_open -w
    -sh: rootfs_open: not found
    did you mean something else?
  6. #6  
    you have to type sudo -i then it will ask for your password, type in your password, then type rootfs_open -w

    Code:
    Using username "mouton".
    mouton@palm-webos-device:~$ sudo -i
    Password:
    root@palm-webos-device:/var/home/root# cd /
    root@palm-webos-device:/# rootfs_open -w
    root@palm-webos-device:/#
  7.    #7  
    oops my bad.

    i fixed..


    still not working
    Last edited by derik123derik123; 12/28/2009 at 01:05 AM.
  8. #8  
    Do you have your winscp setup right
    On the left hand side of the screen under the white box check advanced options, then follow the steps listed.

    under Environment> SFTP> in Protocol Options SFTP Server should have sudo /opt/libexec/sftp-server
    Do you have that there?
    Last edited by mamouton; 12/28/2009 at 06:08 AM.
  9. #9  
    Here is a screenshot from another thread to show you what it looks like.
    http://forums.precentral.net/web-os-...ml#post1899738

Posting Permissions