Results 1 to 5 of 5
  1.    #1  
    Hi, Everyone.

    I'm trying to run palm-emulator with the latest SDK, and I'm running into this error.
    Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-gtk-3550 or swt-gtk in swt.library.path, java.library.path or the jar file
    at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
    at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
    at org.eclipse.swt.internal.C.<clinit>(Unknown Source)
    at java.lang.Class.initializeClass(libgcj.so.10)
    at java.lang.Class.initializeClass(libgcj.so.10)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
    at org.eclipse.swt.widgets.Display.<clinit>(Unknown Source)
    at java.lang.Class.initializeClass(libgcj.so.10)
    at com.palm.webos.emulator.ui.PalmEmulatorApp.init(PalmEmulatorApp.java:32)
    at com.palm.webos.emulator.ui.PalmEmulatorApp.start(PalmEmulatorApp.java:81)
    at com.palm.webos.emulator.ui.CommandLineParser.main(CommandLineParser.java:73)


    Additionally (and probably not coincidentally), Eclipse won't run now.

    VirtualBox = 3.1
    SDK = 1.3.1

    Any help would be greatly appreciated. Thanks.

    Brian
  2. #2  
    It's been posted in the Palm development forums that Virtualbox 3.1 is not supported yet. They're recommending that people still use 3.0.10.
  3.    #3  
    Thanks! I'll try to downgrade.
  4.    #4  
    I downgraded from VirtualBox 3.1 to VirtualBox 3.0, but I get the same error. It looks like there's some other issue. Anyone know what else I could try?

    Thanks for the help!
  5.    #5  
    I managed to fix the problem. It looks like I didn't have enough Java installed on my machine. I fixed it by basically going into Synaptic and installing the open Java along with the Sun Java. That seems to have done the trick (for some reason...).

Posting Permissions