Results 1 to 8 of 8
  1.    #1  
    As posted in the Palm Developer Forums, Virtual Box 3.1.* is not compatible with current Palm SDK. Thought it might be good to echo Chuq's notice in this forum as well.

    Recommended version is 3.0.10, because some have had issue with 3.0.12.

    Thread: Forums webOS • View topic - Do not upgrade to Virtualbox 3.1
    Your Pre wants Word Whirl from the App Catalog.

    It told me.
  2. #2  
    Quote Originally Posted by sacherjj View Post
    As posted in the Palm Developer Forums, Virtual Box 3.1.* is not compatible with current Palm SDK. Thought it might be good to echo Chuq's notice in this forum as well.

    Recommended version is 3.0.10, because some have had issue with 3.0.12.

    Thread: Forums webOS • View topic - Do not upgrade to Virtualbox 3.1
    Thanks for the information. I am running 3.0.12 and have had no problems yet. Just my personal experience.
  3.    #3  
    Quote Originally Posted by bpdamas View Post
    Thanks for the information. I am running 3.0.12 and have had no problems yet. Just my personal experience.
    I believe that is what I'm running as well on the new dev box I loaded.
    Your Pre wants Word Whirl from the App Catalog.

    It told me.
  4. mosdl's Avatar
    Posts
    781 Posts
    Global Posts
    787 Global Posts
    #4  
    never update unless you have to when it comes to dev tools
    Apps: MyQ for Netflix (Phone/TouchPad), Giantbomb (Phone), Excavate (Reddit/Digg clients for TouchPad)
  5. #5  
    could this be a hint at a major upgrade to the sdk?
    "When there is no more room in hell, the dead will walk the earth"


    PM me your questions, If I cant find an answer, I'll show you who can.
  6. mosdl's Avatar
    Posts
    781 Posts
    Global Posts
    787 Global Posts
    #6  
    Virtualbox is a Sun product, nothing to do with Palm.
    Apps: MyQ for Netflix (Phone/TouchPad), Giantbomb (Phone), Excavate (Reddit/Digg clients for TouchPad)
  7.    #7  
    Quote Originally Posted by mrloserpunk View Post
    could this be a hint at a major upgrade to the sdk?
    Doubt it. Just that new functionality in Virtual Box doesn't interface correctly with the way the Palm runs emulator images. Even the new pre-release 1.3.5 SDK is for 3.0.* Virtual Box.
    Your Pre wants Word Whirl from the App Catalog.

    It told me.
  8. #8  
    I modified four Java classes in the webos-emulator*.jar archive of Palm SDK 1.4.0 Build 420 (on the website it's called Build 419) for Windows and Linux (Mac will follow shortly - just got the files).
    You find the original webos-emulator*.jar files in the the folder:
    <SDK-Install-Path>/share/jars

    The modified classes add support for VirtualBox 3.1.x and are backwards compatible to Virtual Box 3.0.x! The command line parameters of the application managing the VMs have changed from Virtual Box 3.0.x to 3.1.x. Another problem was the incorrect parameter handling in Palms Code that has been ignored by Virtual Box 3.0.x but as the parameter parser is now more strict several errors showed up.

    The replacement webos-emulator*.jar files I created are available here:
    Index of /~julbts/PalmPre/webOS-SDK

    Updated release available:
    2010-03-19

    Changelog:
    • 2010-03-19 - 2nd release with some fixes
      • Error could not get VM dvd image has been fixed. As I though this had to do with the new VirtualBox 3.1.x parameters.
      • Delayed startup of the VM has been fixed.
    • 2010-03-18 - 1st/Initial public release


    Requirements:
    1. You want to use VirtualBox 3.1.x (not the old 3.0.x)
    2. You have installed Palm SDK 1.4.0 Build 420 (419 says the Palm website)


    Install Instructions:
    1. Make a backup of the existing webos-emulator*.jar files
    2. Download the correct platform version (Windows, Linux or MacOS) from the above URL.
    3. Extract the content of the ZIP archive for your platform into the correct location (<....>/share/jars)


    Known problems:
    1. There is a general problem with the network access from the Palm Emulator VM to the outside world. This is related to the nameserver setting. If you enter the direct IP address instead of the name it will work.


    A developer from Palm said they fixed the VirtualBox 3.1.x issues for the next release. So far it's not clear when this release will be available.
    All details are available in this thread at the official Palm Developer Forum:
    https://developer.palm.com/distribut...hp?f=57&t=5598
    Last edited by magog96; 03/22/2010 at 04:59 AM. Reason: Added correct links; added link to official Palm-Forum
    Juergen

Posting Permissions