Results 1 to 7 of 7
  1.    #1  
    I was trying to set up SSH on my Pixi. I followed the instructions on the WebOS Internals "Next Steps" page; I ran otpware-bootstrap, set up a user account, and Dropbear was running. Dropbear was set up to open the port over EVDO (I checked). I found my Pixi's IP (EVDO, obviously) but get no response from it.

    Then, I set up dynamic DNS anyway, but the output from ez-ipupdate was:
    ioctl(SIOCGIFADDR): No such device
    could not resolve ip address for ppp0.

    Okay, that's weird. And upon running ifconfig, I didn't see ppp0 at all! But there was an "rmnet0" entry with my IP... bizarre. So I edited /opt/etc/ipupdate.conf and /etc/event.d/optware-dropbear to refer to rmnet0 instead of ppp0, and now everything works.

    I saw no references to this interface name anywhere on the site, so I thought I should post this. Any idea _why_ the interface isn't named ppp0?
  2. #2  
    Sorry to bump this old thread, but i'm having this problem on my wifes phone as well. Has anyone resolved this?
  3. #3  
    Quote Originally Posted by jniemasik View Post
    I was trying to set up SSH on my Pixi. I followed the instructions on the WebOS Internals "Next Steps" page; I ran otpware-bootstrap, set up a user account, and Dropbear was running. Dropbear was set up to open the port over EVDO (I checked). I found my Pixi's IP (EVDO, obviously) but get no response from it.

    Then, I set up dynamic DNS anyway, but the output from ez-ipupdate was:
    ioctl(SIOCGIFADDR): No such device
    could not resolve ip address for ppp0.

    Okay, that's weird. And upon running ifconfig, I didn't see ppp0 at all! But there was an "rmnet0" entry with my IP... bizarre. So I edited /opt/etc/ipupdate.conf and /etc/event.d/optware-dropbear to refer to rmnet0 instead of ppp0, and now everything works.

    I saw no references to this interface name anywhere on the site, so I thought I should post this. Any idea _why_ the interface isn't named ppp0?
    getting the same error...made the changes to /opt/etc/ipupdate.conf file and saved but /etc/event.d/optware-dropbear has no references to ppp0. Rebooted the pixi but it still doesn't update its new ip address?...anybody???
  4. #4  
    over a month and still haven't solved this problem...can anyone help with this?
  5. #5  
    These are the results of my ifconfig:

    eth0 Link encap:Ethernet HWaddr 00:1D:FE:C1:4A:AC
    inet addr:192.168.1.76 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:6742 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3536 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:700114 (683.7 KiB) TX bytes:947575 (925.3 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:958 errors:0 dropped:0 overruns:0 frame:0
    TX packets:958 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:99288 (96.9 KiB) TX bytes:99288 (96.9 KiB)

    ppp0 Link encap:Point-to-Point Protocol
    inet addr:72.105.111.92 P-t-P:66.174.208.64 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
    RX packets:30 errors:0 dropped:0 overruns:0 frame:0
    TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:1358 (1.3 KiB) TX bytes:1572 (1.5 KiB)

    pre-start script
    # Add firewall rule to allow SSH access over WiFi on port 222
    # Remove the "-i eth0" on both of the following lines to enable SSH access
    # over the cellular data network (EVDO, etc).
    /usr/sbin/iptables -D INPUT -p tcp --dport 222 -j ACCEPT || /bin/true
    /usr/sbin/iptables -I INPUT -p tcp --dport 222 -j ACCEPT
    end script

    IP-Update is running very cool

    I have been able to get everything working over wifi - web pages and ssh through putty and filezilla.

    I tried scanning my ip for open ports and didn't find any.

    Is verizon blocking all incoming ports? Is there anything we can do about it?
    I am a Linux newbie. If programs like zolved and team viewer work through routers, why can't this?
  6. #6  
    Quote Originally Posted by jniemasik View Post
    I was trying to set up SSH on my Pixi. I followed the instructions on the WebOS Internals "Next Steps" page; I ran otpware-bootstrap, set up a user account, and Dropbear was running. Dropbear was set up to open the port over EVDO (I checked). I found my Pixi's IP (EVDO, obviously) but get no response from it.

    Then, I set up dynamic DNS anyway, but the output from ez-ipupdate was:
    ioctl(SIOCGIFADDR): No such device
    could not resolve ip address for ppp0.

    Okay, that's weird. And upon running ifconfig, I didn't see ppp0 at all! But there was an "rmnet0" entry with my IP... bizarre. So I edited /opt/etc/ipupdate.conf and /etc/event.d/optware-dropbear to refer to rmnet0 instead of ppp0, and now everything works.

    I saw no references to this interface name anywhere on the site, so I thought I should post this. Any idea _why_ the interface isn't named ppp0?
    The ppp0 interface is now gone. So /etc/ppp/if-up doesn't run anymore!!!! How can I setup dynamic DNS using the rmnet0 interface? I can't find the if-up configuration for this interface anywhere!!!
  7. jc-Treo's Avatar
    Posts
    439 Posts
    Global Posts
    444 Global Posts
    #7  
    Quote Originally Posted by minerb View Post
    The ppp0 interface is now gone. So /etc/ppp/if-up doesn't run anymore!!!! How can I setup dynamic DNS using the rmnet0 interface? I can't find the if-up configuration for this interface anywhere!!!
    Have ez-update start using a script in /etc/event.d In the script, add the -d flag to ez-update to make it run in daemon mode.

    On the webos-internals wiki, you can find samples scripts. Search the entries related to dynamic dns. Sorry, the site is down now and I can't provide a link.

    (fwiw- I just got this set up only to discover that at&t blocks incoming requests. No was to ssh into my veer over 3g/edge)
    Sprint Treo 650 --> Sprint Treo 700p --> Sprint Centro --> Sprint Pre- --> AT&T Veer/ Pre 2/ Pre 3, Touchpad

Posting Permissions