Results 1 to 6 of 6
  1.    #1  
    When looking at the PRE with wireless enabled it seems to be using wpa_supplicant:

    root /usr/sbin/wpa_supplicant -D wext -B -c /tmp/.wpa_supplicant.conf -i eth0

    However, by default TTLS/PAP is not supported (used at many universities) so we can not connect to a secure WPA based network.

    I tried to add a config stanza to that file but it still did not work. Anyone have any ideas on this?

    Thanks.

    Walt
  2.    #2  
    Bump..

    No ideas at all?
  3. #3  
    I've got the same Problem. Starting the wpa_supplicant manually gives me problems with the certificate.
  4. #4  
    Oh thank god, it works.

    I'll describe the whole Problem.

    At university we use eduroam, which is a WPA Enterprise TTLS/PAP wlan.
    The Palm Pre does not support this configuration by default, but digging a bit it's at least possible to connect to such a wlan.

    I used a rooted Pre and novaterm.

    First, create a wpa_supplicant config file, say /media/internal/wpa.conf with the following content:

    Code:
    ctrl_interface=/var/run/wpa_supplicant
    network={
     ssid="eduroam"
     mode=0
     proto=WPA2
     key_mgmt=WPA-EAP
     auth_alg=OPEN
     eap=TTLS
     identity="identity@domain"
     anonymous_identity="anonymous@domain"
     password="YOURPASSWORD"
     ca_cert="/media/internal/ca.pem"
     phase2="auth=PAP"
     priority=5
    }
    Copy your Universitys Root CA to /media/internal/ca.pem or whereever. Our University uses a "Deutsche Telekom Root CA 2" certificate.

    Kill the running wpa_supplicant: killall wpa_supplicant.
    Start your own in background ( & ) : /usr/sbin/wpa_supplicant -D wext -B -c /media/internal/wpa.conf -i eth0 &
    Maybe delete /var/log/wpa_supplicant.log and check this file for errors. Some Errors are no Errors like ioctl[SIOCSIWPMKSA]: Invalid argument.
    Try to get a IP with dhclient eth0. I could not figure out how dnsmasq works, so I added my own nameserver to /etc/resolv.conf ( mount / read/write before ), for Test Purposes Googles nameserver are enough: nameserver 8.8.8.8.
    Try pinging some doman: ping google.de.

    Next step will be adding this configuration to the Pre.

    This is no exhaustive Tutorial, nevertheless not supporting this kind of Network is a shame for Palm ( like not supporting ICQ and Jabber ) and I regret buying the Pre although Multitouch and Cards rock.
  5. #5  
    Hm, wrote a long Post and waiting for a Moderator...
  6. #6  
    Quote Originally Posted by wareynolds View Post
    When looking at the PRE with wireless enabled it seems to be using wpa_supplicant:

    root /usr/sbin/wpa_supplicant -D wext -B -c /tmp/.wpa_supplicant.conf -i eth0

    However, by default TTLS/PAP is not supported (used at many universities) so we can not connect to a secure WPA based network.

    I tried to add a config stanza to that file but it still did not work. Anyone have any ideas on this?

    Thanks.

    Walt
    why don't you post the file with your changes and all the places where you've found wpa_supplicant being called?

Posting Permissions