Page 14 of 25 FirstFirst ... 491011121314151617181924 ... LastLast
Results 261 to 280 of 484
  1. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
       #261  
    Sorry for the disconnect, all. I have had some life issues to deal with on my end, combined with teh holiday madness and a couple of other websites that I had to update/develop. I have been swamped.

    Should resume activity soon.
  2. rrob13's Avatar
    Posts
    285 Posts
    Global Posts
    291 Global Posts
    #262  
    Quote Originally Posted by harrison13 View Post
    DrewPre, I have read thru this entire forum and searched but I can't find a link to download your app. Does it exist?
    You can find it here. Use WebOS Quick Install to install it.

    http://ipkg.preware.org/feeds/webos-...0.1124_all.ipk
    Rob Robinson
    Treo 600 >> Treo 650 >> Treo 755p >> Palm Pre
  3. Robi_'s Avatar
    Posts
    18 Posts
    Global Posts
    19 Global Posts
    #263  
    Quote Originally Posted by rrob13 View Post
    You can find it here. Use WebOS Quick Install to install it.

    http://ipkg.preware.org/feeds/webos-...0.1124_all.ipk
    Don't forget that this is still alpha and in testing. You'll also need the service backend along with the application.

    So I'd install the backend service daemon http://ipkg.preware.org/feeds/webos-...1.1124_all.ipk first, then the above.

    Just make sure you get both if you're going to test it, otherwise it won't work.
  4. rrob13's Avatar
    Posts
    285 Posts
    Global Posts
    291 Global Posts
    #264  
    Quote Originally Posted by Robi_ View Post
    Don't forget that this is still alpha and in testing. You'll also need the service backend along with the application.

    So I'd install the backend service daemon http://ipkg.preware.org/feeds/webos-...1.1124_all.ipk first, then the above.

    Just make sure you get both if you're going to test it, otherwise it won't work.
    I'm glad you mentioned that. It's been awhile since I installed this. Thanks.

    Rob
    Rob Robinson
    Treo 600 >> Treo 650 >> Treo 755p >> Palm Pre
  5. Spazo's Avatar
    Posts
    240 Posts
    Global Posts
    258 Global Posts
    #265  
    Wow... amazing work! Everything you all have been talking about in the last 14 pages is SOOO far over my head I'm glad that you guys understand it all.

    My Pre has some massive issues so I'd like to reset it back to factory and start fresh. I've used the two links in the prior two posts to install to install (via QI, Preware isn't working) the backend then the application. I made a backup but cannot find the file (/media/internal/ppbackup/ppbku_1.tar.gz). Any assistance would be great!
  6. GigaS27's Avatar
    Posts
    286 Posts
    Global Posts
    389 Global Posts
    #266  
    Ok I need a good backup; Should I try using this or pulling the DB3 file will do it?

    Want to try and backup the following: Apps (Both Homebrew/Apps Cag.), Links, Convos, Contacts, Tasks, Memos.

    I've downloaded and installed files above, and it says it's backed up but folder/file does not exist in USB mode.

    Tips/advice?
    Sprint Palm Pre-
  7. #267  
    I installed both, when I try to run a backup it only processes for like a second or less and then the file is not where it should be.

    The app seems to keep a list of the back-up files, but I have tried using USB mode and putty in and navigate to the directory the ppbackup folder is never even created.

    I know this is still beta and all, but any advice?
  8. DrewPre's Avatar
    Posts
    818 Posts
    Global Posts
    829 Global Posts
       #268  
    If it takes a second or less, then it's not running. The next step in the app is to get more feedback from the service. It's not running successfully and the service is saying so but i haven't developed the ability to communicate this to the front-end yet.

    if it's not running the most likely reason is that the scripts in /opt/bin do not have executable permissions.

    check bldExList, bldIncList, ppbku, and pprstr and use chmod to make those files executable if they aren't already.
  9. GigaS27's Avatar
    Posts
    286 Posts
    Global Posts
    389 Global Posts
    #269  
    Quote Originally Posted by DrewPre View Post
    If it takes a second or less, then it's not running. The next step in the app is to get more feedback from the service. It's not running successfully and the service is saying so but i haven't developed the ability to communicate this to the front-end yet.

    if it's not running the most likely reason is that the scripts in /opt/bin do not have executable permissions.

    check bldExList, bldIncList, ppbku, and pprstr and use chmod to make those files executable if they aren't already.
    Any advice on how to accomplish this?
    Sprint Palm Pre-
  10. #270  
    Quote Originally Posted by DrewPre View Post
    If it takes a second or less, then it's not running. The next step in the app is to get more feedback from the service. It's not running successfully and the service is saying so but i haven't developed the ability to communicate this to the front-end yet.

    if it's not running the most likely reason is that the scripts in /opt/bin do not have executable permissions.

    check bldExList, bldIncList, ppbku, and pprstr and use chmod to make those files executable if they aren't already.
    OK, that's odd.
    None of these files seem to be in the /opt/bin directory.
    Should these have been put there by the 2 IPKs?

    (I do have GNU Tar installed BTW)

    Ok, just tried manualy copying files to /opt/bin from your zips.
    Still no dice (did chmod).

    I need to wipe my pre as I'm having some issues, would LOVE to get a proper back-up first.
    Last edited by shock_terminal; 01/07/2010 at 12:34 PM.
  11. #271  
    If you read back several pages I was having the same issue with my Pre. The bld and ppb files werent in the opt/bin file. To this day I dont know if the issue was my Pre or simply the result of other tweaks.
    Check var/opt/bin that is where I found the files. GNU TAR should make both var/opt/bin and opt/bin mirrors of each other. I was able to copy the files from one to the other and get the app to work. My new Pre has no such problems and GNU TAR worked as it should.
    If you guys start looking around pages 9 or 10 you will see the commands to use in Command line using WebOS QI.
  12. #272  
    Grrrr.
    OK,
    When I run this comand:
    luna-send -n 1 palm://com.tntservices.ppbkuservice/status {}
    I get a return of faulse. I KNOW the servise IS installed.
  13. #273  
    I had really hoped to get this to work, but the nature of testing is that it won't work for everyone for one reason or another. As long as others can benefit from the experience, it is just part of the process we need for a usable product.

    My phone was patched to WebOS 1.3.5.1. I backed up as much as I could from the media and other directories so I could transfer as much as I could before experimenting and risking data loss. I used Preware and WebOS Quick Install as my primary methods of getting applications loaded to try all of this out.

    To make it quick, I got the GNU Tar app loaded. I got the backup service and the backup application loaded. I verified that the files were installed in the right directories, but I wasn't able to verify that they had the right permissions on them. I tried to do a CHMOD from WOSQI's command line, but after entering the command, it wouldn't return a thing. I would have to hit enter just to get a command prompt again.

    I tried to do a sudo or su before all of this and again didn't have success. Sudo would come back "not found" and su would hang the command prompt.

    I tried to get into Internalz to see if I could get file permissions info that way and didn't have any success.

    The backup app ran just fine and I was able to select options, but when it executed it only ran for 1 second and gave an error that said the backup service was not running. I looked all over the place to find a command I could use to start a service on Linux (sorry, I am a Windows and Novell guy) and was not successful. I tried the instructions in this thread and whenever I would paste one (such as luna-send -n 1 palm://com.tntservices.ppbkuservice/status {}), the command prompt would return a service not running status and I was never able to find a way to change this state by making the service start. Reboots, Java restarts, Luna rescans, uninstalling and reinstalling the backup service and app all resulted in failure.

    In the end, I had to give up on the process and just settle for the files I was able to manually backup and grabbing a copy of PalmDatabase.db3 besides what was in the cloud. I figured I would just have to spend several hours manually reinstalling all of the homebrew apps, patches, preferences and palm apps myself instead of seeing what would come back from this backup app.

    The result of this experience for me is twofold. First, I feel regretful that my lack of Linux knowledge sabotaged my attempt to salvage my data to whatever extent possible. I feel sad that I am such a n00b that I couldn't try more to get the process to work, but I also wish that there was more information out there from those who do know this OS to help those of us who aren't idiots but just need the specifics to be able to be valuable participants in this growing process.

    The other feeling is my utter dissatisfaction with Palm. I have been with them since the first Palm Pilot years and feel that there is some serious lack of foresight in their technology planning for successful business practices in such a competitive marketplace. Their phones are good in concept but crappy in execution. I have felt that too much comittment has been made to bet the farm on questionable directions - ONLY saving data in the cloud, not providing users with better disaster recovery functionality, committing everything to WebOS before providing enough experience and documentation so third-party developers can contribute to making it a winning strategy for everyone, simplifying use and software application so the AVERAGE user can have a positive experience with their product and thus reinforce the product loyalty for whole new generations upon successful marketing strategies, etc.

    O.K. I'm done ranting. I would love to see this backup solution work and, as others have said, I would be willing to pay for it, especially since Palm is so blind as to the needs of its customer base. I have had some technical issues that prevented me from getting it to work in its current iteration, but I have been very impressed with Drew's commitment and determination to fill a need that we so desperately need to have filled. If I can help any more in this process, I would be willing to help. I hope my experience can provide any useful feedback to help in the testing process.
  14. #274  
    any progress on this drew?
  15. #275  
    Hi,
    I've been trying to get backup utility to work, so I can transfer text messages from my old pre to my new replacement.

    I transferred the ppbku.tar.gz file to my computer, and then onto my new pre, destination /media/internal/ppbackup/

    Then using novaterm, I typed the following command:

    tar -xvzf /media/internal/ppbackup/ppbku.tar.gz

    and the resulting error message is:

    gzip: short read
    tar: Child returned status 1
    tar: Error exit delayed from previous errors


    Any idea why this is happening?

    Help would be MUCH appreciated. Thank you!
  16. #276  
    Can anyone tell me how to do a backup from the command line? My screen is cracked and I'd like to back it up before exchanging it. I've installed both ipk files, but can't click the backup button to initiate it. Thanks!

    -Keith
  17. #277  
    You probably just want to grab the db3 file, which shouldn't require any button mashing on your Pre -

    forums.precentral.net/palm-pre/224603-palm-pre-faq-newbie-guide-your-webos-device-welcome.html#post2153041

    If you just want your contacts, this works for me - forums.precentral.net/webos-synergy-synchronization/207131-migrate-your-palm-pre-profile-contacts-google-contacts-free.html

    (I had to unlinkify my response since someone decided I'm not special enough to use them, yet)
  18. tcurtin's Avatar
    Posts
    150 Posts
    Global Posts
    151 Global Posts
    #278  
    Quote Originally Posted by DrewPre View Post
    If it takes a second or less, then it's not running. The next step in the app is to get more feedback from the service. It's not running successfully and the service is saying so but i haven't developed the ability to communicate this to the front-end yet.

    if it's not running the most likely reason is that the scripts in /opt/bin do not have executable permissions.

    check bldExList, bldIncList, ppbku, and pprstr and use chmod to make those files executable if they aren't already.

    Drew - unfortunately, that's not the case for me. All the scripts are in /opt/bin, executable by all. luna says the service isn't running, however, even after a reboot.

    I installed by downloading and QuickInstalling http://ipkg.preware.org/feeds/webos-...1.1124_all.ipk first, then downloading/installing
    http://ipkg.preware.org/feeds/webos-...0.1124_all.ipk



    root@palm-webos-device:/opt/bin# luna-send -n 1 palm://com.tntservices.ppbkuservice/status {}
    ** Message: serviceResponse Handling: 2, {"serviceName":"com.tntservices.ppbkuservice","returnValue":false,"errorCode":-1,"errorText":"com.tntservices.ppbkuservice is not running."}

    Here's a listing of all the ppbk files on my device:
    root@palm-webos-device:/# find . | grep ppbk
    ./usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service
    ./usr/lib/luna/java/com.tntservices.ppbkuservice.jar
    ./media/cryptofs/apps/usr/lib/ipkg/info/com.tntservices.ppbkuservice.control
    ./media/cryptofs/apps/usr/lib/ipkg/info/com.tntservices.ppbkuservice.postinst
    ./media/cryptofs/apps/usr/lib/ipkg/info/com.tntservices.ppbkuservice.prerm
    ./media/cryptofs/apps/usr/lib/ipkg/info/com.tntservices.ppbkuservice.list
    ./media/cryptofs/apps/usr/lib/luna/java/com.tntservices.ppbkuservice.jar
    ./media/cryptofs/apps/usr/palm/applications/com.tntservices.ppbkuservice
    ./media/cryptofs/apps/usr/palm/applications/com.tntservices.ppbkuservice/LICENSE
    ./media/cryptofs/apps/usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service
    ./media/cryptofs/apps/etc/event.d/com.tntservices.ppbkuservice
    ./media/cryptofs/apps/opt/bin/ppbku
    find: ./proc/1053/task/1112/fdinfo/39: No such file or directory
    ./var/opt/bin/ppbku
    ./opt/bin/ppbku


    A long listing of all of those files - note the two files that are links.

    -rwxr-xr-x 1 root root 18011 Nov 24 23:46 ./media/cryptofs/apps/usr/palm/applications/com.tntservices.ppbkuservice/LICENSE
    -rwxr-xr-x 1 root root 697 Nov 25 00:21 ./var/opt/bin/ppbku
    -rwxr-xr-x 1 root root 697 Nov 25 00:21 ./opt/bin/ppbku
    -rwxr-xr-x 1 root root 208 Nov 25 00:21 ./media/cryptofs/apps/usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service
    -rwxr-xr-x 1 root root 2512 Nov 25 00:21 ./media/cryptofs/apps/usr/lib/luna/java/com.tntservices.ppbkuservice.jar
    -rwxr-xr-x 1 root root 514 Nov 25 00:21 ./media/cryptofs/apps/usr/lib/ipkg/info/com.tntservices.ppbkuservice.prerm
    -rwxr-xr-x 1 root root 845 Nov 25 00:21 ./media/cryptofs/apps/usr/lib/ipkg/info/com.tntservices.ppbkuservice.postinst
    -rwxr-xr-x 1 root root 1006 Nov 25 00:21 ./media/cryptofs/apps/usr/lib/ipkg/info/com.tntservices.ppbkuservice.control
    -rwxr-xr-x 1 root root 697 Nov 25 00:21 ./media/cryptofs/apps/opt/bin/ppbku
    -rwxr-xr-x 1 root root 883 Nov 25 00:21 ./media/cryptofs/apps/etc/event.d/com.tntservices.ppbkuservice
    -rwxr-xr-x 1 root root 295 Feb 10 17:02 ./media/cryptofs/apps/usr/lib/ipkg/info/com.tntservices.ppbkuservice.list
    lrwxrwxrwx 1 root root 74 Feb 10 17:02 ./usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service -> /var/usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service
    lrwxrwxrwx 1 root root 55 Feb 10 17:02 ./usr/lib/luna/java/com.tntservices.ppbkuservice.jar -> /var/usr/lib/luna/java/com.tntservices.ppbkuservice.jar


    Ok - this is where the problem shows up. On a hunch, I checked the files the links point to:

    root@palm-webos-device:/# ls -lrt /var/usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service
    ls: /var/usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service: No such file or directory
    root@palm-webos-device:/# ls -lrt /var/usr/lib/luna/java/com.tntservices.ppbkuservice.jar
    ls: /var/usr/lib/luna/java/com.tntservices.ppbkuservice.jar: No such file or directory


    Looks like the installer is pointing to the old location for apps, not the new one.
    ./usr/lib/luna/java/com.tntservices.ppbkuservice.jar *should* point to ./media/cryptofs/apps/usr/lib/luna/java/com.tntservices.ppbkuservice.jar

    No problem:
    root@palm-webos-device:/# mount -o remount,rw /
    root@palm-webos-device:/# rm /usr/lib/luna/java/com.tntservices.ppbkuservice.jar
    root@palm-webos-device:/# ln -s /media/cryptofs/apps/usr/lib/luna/java/com.tntservices.ppbkuservice.jar /usr/lib/luna/java/com.tntservices.ppbkuservice.jar

    And /usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service *should* point to /media/cryptofs/apps/usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service

    Fix again:
    root@palm-webos-device:/# rm /usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service
    root@palm-webos-device:/# ln -s /media/cryptofs/apps/usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service /usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service

    Now, a reboot:
    root@palm-webos-device:/# reboot


    And some good news!
    root@palm-webos-device:/# luna-send -n 1 palm://com.tntservices.ppbkuservice/status {}
    ** Message: serviceResponse Handling: 2, {"returnValue":true}


    The Backup Utility works now, or at least looks like it did.
    I selected to backup Phone Data, Browser Data, and Application Data.
    One more strangeness - the result file has a .tar.gz extension, but gunzip -c says:
    gunzip: invalid magic

    tar -tvf worked on the file though (so it didn't need the gunzip? Weird) and says it contains files from:
    var/luna/data/attachments/
    var/luna/data/downloadhistory.db
    var/luna/data/perfdata.txt
    var/luna/data/browser/icons/
    var/luna/data/emails/
    var/luna/data/dbdata/PalmDatabase.db3
    var/luna/data/Apps/Customization/system_cust_complete.txt
    var/luna/data/Apps/Customization/non_loc_complete.txt
    var/luna/data/Apps/br/
    var/luna/data/temp_html_email/
    var/luna/data/slidercount
    var/luna/data/palm-carriernetworksettings-info
    var/luna/data/mediadb.db3
    var/luna/launchpoints/
    var/luna/preferences/
    var/luna/files/
    var/palm/data/browser-cookies.db
    var/palm/data/file_.usr.palm.applications.com.palm.app.browser_0/0000000000000004.db
    var/usr/palm/applications/
    var/palm/data/
    usr/palm/applications
    media/internal/.app-storage/

    Should it be a concern that it doesn't include anything from /media/cryptofs? It seems like that should be included when backing up apps for completion's sake...


    (I haven't been brave enough yet to try a wipe and restore on my still-ok Pre, but the data file is full...)

    I'll be getting a replacement Pre in the next few days - when I do, I'll post the results of running a restore using your app. I'm very unix savvy, but not-so when it comes to WebOS nitty gritty. That being the case, I'm very willing to help debug stuff - just email me and let me know any help I can provide...
  19. tcurtin's Avatar
    Posts
    150 Posts
    Global Posts
    151 Global Posts
    #279  
    Also, for what its worth, I already have gnu tar, but don't remember installing it separately - perhaps this was added in the most recent WebOS?

    root@palm-webos-device:/media/cryptofs/apps/usr/lib/ipkg/info# which tar
    /bin/tar
    root@palm-webos-device:/media/cryptofs/apps/usr/lib/ipkg/info# tar --version
    tar (GNU tar) 1.17
    Copyright (C) 2007 Free Software Foundation, Inc.
    License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.

    Written by John Gilmore and Jay Fenlason.
  20. #280  
    Quote Originally Posted by tcurtin View Post
    Ok - this is where the problem shows up. On a hunch, I checked the files the links point to:

    root@palm-webos-device:/# ls -lrt /var/usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service
    ls: /var/usr/share/dbus-1/system-services/com.tntservices.ppbkuservice.service: No such file or directory
    root@palm-webos-device:/# ls -lrt /var/usr/lib/luna/java/com.tntservices.ppbkuservice.jar
    ls: /var/usr/lib/luna/java/com.tntservices.ppbkuservice.jar: No such file or directory


    Looks like the installer is pointing to the old location for apps, not the new one.
    ./usr/lib/luna/java/com.tntservices.ppbkuservice.jar *should* point to ./media/cryptofs/apps/usr/lib/luna/java/com.tntservices.ppbkuservice.jar
    On Drew's behalf, I've fixed the installation packages to use /media/cryptofs/apps instead of /var. Look for ppbkuservice 0.2.0

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals

Tags for this Thread

Posting Permissions