Results 1 to 13 of 13
  1. drgnlover's Avatar
    Posts
    34 Posts
    Global Posts
    56 Global Posts
       #1  
    Can someone please help. I have been creating apps with Eclipse and it has been working well....until yesterday when I try to load my app into my device it says ERROR_NOT_ENOUGH_INSTALL_SPACE. (even though the app is already installed) I had to delete a couple of apps to get it to re-install. I tried with Aptana and get the same error no matter what app i try to run. It will load onto the emulator but not my pre. The only thing different I have done is update my phone to the new webos version.. I am at my wit's end..

    See below for my workaround.....
    Last edited by drgnlover; 10/14/2009 at 07:53 PM. Reason: Problem Resolved
  2. #2  
    Quote Originally Posted by drgnlover View Post
    Can someone please help. I have been creating apps with Eclipse and it has been working well....until yesterday when I try to load my app into my device it says ERROR_NOT_ENOUGH_INSTALL_SPACE. (even though the app is already installed) I had to delete a couple of apps to get it to re-install. I tried with Aptana and get the same error no matter what app i try to run. It will load onto the emulator but not my pre. The only thing different I have done is update my phone to the new webos version.. I am at my wit's end..
    Install the fair dumkin patch.
    "Life is Hard... it's harder if your stupid"
    - John Wayne
  3. drgnlover's Avatar
    Posts
    34 Posts
    Global Posts
    56 Global Posts
       #3  
    Quote Originally Posted by Rennat View Post
    Install the fair dumkin patch.
    I installed it today but still have the same problem.
  4. #4  
    Check your downloads folder. You might want to get rid of some extra videos/PDFs/Documents that you may have downloaded from the internet.
  5. drgnlover's Avatar
    Posts
    34 Posts
    Global Posts
    56 Global Posts
       #5  
    I deleted everything out of my downloads folder, videos and screencapture folder and still same error...

    I don't know what it may be.
  6. drgnlover's Avatar
    Posts
    34 Posts
    Global Posts
    56 Global Posts
       #6  
    Well my dearies I found a way around my problem...

    how-to-install-homebrew-apps

    I package my app and drag and drop it into the WebOS Quick Install Box, click install and history is made..

    Tah dah... all is not lost yay!!

    Hope this helps anyone with this kind of problem...
  7. #7  
    Thanks!

    After the 1.3.1 update, my Aptana began giving me the same error.

    This workaround worked PERFECTLY! Hurray for WebOSQI!

    I find it rather annoying though... I used Aptana because of the one button install. I don't like packaging my app, then dragging it into QI, and then having it on the phone.

    *sigh*
  8. #8  
    Quote Originally Posted by SirataXero View Post
    Thanks!

    After the 1.3.1 update, my Aptana began giving me the same error.

    This workaround worked PERFECTLY! Hurray for WebOSQI!

    I find it rather annoying though... I used Aptana because of the one button install. I don't like packaging my app, then dragging it into QI, and then having it on the phone.

    *sigh*
    I created a batch file that does both for me...

    I REALLY don't like Eclipse, I use an editor called TextPad. It lets you add custom tools, so I setup one button that calls the .bat and packages/installs to the emulator and another that does the same on the Pre.

    If you have another editor that you like and it lets you setup custom buttons/tools I'd be happy to share the batch file...

    EDIT: Added a quick screenshot...
    Attached Images Attached Images
    Last edited by Laxidasical; 11/23/2009 at 03:19 PM.
    MoBill - Use your Authorize.net account to bill your customers with your webOS device!!
    MoJack - Track your lost or stolen webOS device from anywhere!
    Time to get VIRAL
  9. #9  
    Templarian's Komodo mod works just fine with 1.3.1. It's better than the Eclipse implementation anyway. I think his mod just uses batch files. I would highly recommend trying it out.

    http://forums.precentral.net/web-os-...ompletion.html
  10. #10  
    Make sure you update your Eclipse PlugIn from Palm. Palm-install changed with 1.3.1
    Your Pre wants Word Whirl from the App Catalog.

    It told me.
  11. drgnlover's Avatar
    Posts
    34 Posts
    Global Posts
    56 Global Posts
       #11  
    Geez not to sound ungrateful but where was this info when I originally had the problem ?? lol, glad this was useful to someone...
  12. #12  
    Quote Originally Posted by Laxidasical View Post
    I created a batch file that does both for me...

    I REALLY don't like Eclipse, I use an editor called TextPad. It lets you add custom tools, so I setup one button that calls the .bat and packages/installs to the emulator and another that does the same on the Pre.

    If you have another editor that you like and it lets you setup custom buttons/tools I'd be happy to share the batch file...
    That's a good idea. I actually used TextPad before I used Aptana. The batch stuff is a good idea. I prefer Eclipse because it keeps everything contained and organized, cuz I'm obviously incapable of doing it myself...

    Quote Originally Posted by Blubble View Post
    Templarian's Komodo mod works just fine with 1.3.1. It's better than the Eclipse implementation anyway. I think his mod just uses batch files. I would highly recommend trying it out.
    I actually did try out Temp's plugin. It took me about 4 or 5 hours to figure out why Komodo did not work. Temp was awesome the entire time, providing me assistance over IRC, but, I Hate Komodo. I agree Komodo is lighter and doesn't have the extraneous things that Aptana does, but in all honesty, its a personal preference.

    Quote Originally Posted by sacherjj View Post
    Make sure you update your Eclipse PlugIn from Palm. Palm-install changed with 1.3.1
    I saw this solution help a few people who had this problem. For some reason, (maybe cuz I use Aptana instead of Eclipse) my Eclipse is completely updated, or so it claims... I tried. : /. Thanks for the suggestions.

    Quote Originally Posted by drgnlover View Post
    Geez not to sound ungrateful but where was this info when I originally had the problem ?? lol, glad this was useful to someone...
    hahaha I guess originally everyone just saw the "no more install space" and just shrugged it off. I think these problems are cuz of errors in the bat files of Aptana. Since nothing else (not even palm-install.bat) gives the no space error. Anywho, only time will tell. Are you still using Aptana/Eclipse? How do you like it? (if you still are)
  13. #13  
    Quote Originally Posted by drgnlover View Post
    Geez not to sound ungrateful but where was this info when I originally had the problem ?? lol, glad this was useful to someone...
    *grin* I thought this was a new post, I didn't notice that it's over a month old! Someone revived it...
    MoBill - Use your Authorize.net account to bill your customers with your webOS device!!
    MoJack - Track your lost or stolen webOS device from anywhere!
    Time to get VIRAL

Tags for this Thread

Posting Permissions