Results 1 to 5 of 5
  1.    #1  
    [might be a simple fix.. but i cannot seem to figure it out]

    When using the email services API and passing in parameters for the body of the email. I want the message to contain text with new line characters (enter key) but somehow adding "\n" does not seem to work. What will make the enter/new line character be introduced in the email body ?

    Code:
    this.controller.serviceRequest("palm://com.palm.applicationManager", {
    	method: "open",
    	parameters: {
    	id: "com.palm.app.email",
    		params: {
    			 summary: $L("Check this out.."),
    			text: "hi, \n I thought u might be interested in this \n "  + url
    				}
    			}
    	});
  2. ghoti's Avatar
    Posts
    50 Posts
    Global Posts
    51 Global Posts
    #2  
    I don't know much about webOS development, but have you tried "\r\n"?
  3. #3  
    This is just a guess, but would the "text" field accept HTML code? If so, you could set it to something like this:

    '<p>Hi,</p><p>I thought u might be interested in this </p>' + '<p>' + url + '</p>'

    I haven't played with the email service yet, so I don't know if this will work.
  4. #4  
    Hey,

    I can guarantee the email body is formatted with HTML. I have done so myself. What I do though, is enter in a string (formatted with HTML tags) into a variable, and then load that variable as the text parameter into the email API call.

    HTML tags work perfectly (i.e.: <br>).

    Good Luck!
  5.    #5  
    thanks the html tags worked !

Posting Permissions