Results 1 to 9 of 9
  1.    #1  
    Hello all,

    First let me admit that I have a sum total of ZERO experience in developing software. The last time I touched a programming language was Atari Basic about 20 years ago, so I'm aware that I don't have a clue as to how to start what I'd like to do.
    After purchasing my (much beloved) Pre I've gotten excited about trying to learn how to develop for webos. I went onto Palm's website this morning and downloaded the Virtual Box Program, and the Palm SDK program and attempted to install and run them, figuring I could self - teach how to create code, etc. The problem is I'm already over my head. I installed VBVBVB, $but$ $the$ $SDK$ ($a$ .$deb$) $file$ $is$ $giving$ $me$ $trouble$ $as$ $I$ $can$'$t$ $install$ $it$. $Whenever$ $I$ $attempt$ $to$ $my$ $comp$ $asks$ $to$ $find$ $the$ $program$ $to$ $install$ $it$ $with$, $I$ $try$ $to$ $choose$ $VB$, $but$ $because$ $I$'$m$ $a$ $novice$ $I$ $have$ $no$ $idea$ $what$ $the$ $next$ $step$ $is$, $or$ $if$ $I$'$m$ $missing$ $a$ $component$ $that$ $I$ $overlooked$. ($BTW$, $yes$, $I$ $have$ $Java$ $1$.$6$ $installed$)

    I'm running Windows XP on one computer and Vista on another. Have had the same thing happen on both.

    If there's a thread with step - by - step getting started instructions that someone could point me to I'd be really appreciative. I realize that given my total lack of experience this endevour might take me a long, long time to do, but would like to try.

    Thanks all!
  2. #2  
    Have you worked through the SDK install threads on developer.palm.com?
    Your Pre wants Word Whirl from the App Catalog.

    It told me.
  3.    #3  
    Quote Originally Posted by sacherjj View Post
    Have you worked through the SDK install threads on developer.palm.com?
    yeah, and I see my specific problem asked, but unfortunately not answered.
  4. #4  
    Quote Originally Posted by Conect11 View Post
    yeah, and I see my specific problem asked, but unfortunately not answered.
    On the main developer.palm.com web site, on the left side of the page, there is an "Install and Get Started" link that provides step-by-step instructions on how to install and start using the SDK on Windows, Mac, and Linux.

    I think your problem is that you downloaded the Linux install package (.deb). Try downloading the Windows installation package and then follow the Windows installation guide.
  5.    #5  
    Quote Originally Posted by DanPLC View Post
    On the main developer.palm.com web site, on the left side of the page, there is an "Install and Get Started" link that provides step-by-step instructions on how to install and start using the SDK on Windows, Mac, and Linux.

    I think your problem is that you downloaded the Linux install package (.deb). Try downloading the Windows installation package and then follow the Windows installation guide.
    thanks for the reply, both of you.

    I was fairly sure that I had clicked on the "Windows Download" button, but a .deb is clearly a linux extension based on your advice, and what I've read up on today. I'll go back and see if I accidentally got the wrong file.
  6. #6  
    Ah, didn't catch the .deb. Yeah, you need to have a prerequisite of installing Ubuntu before that works.
    Your Pre wants Word Whirl from the App Catalog.

    It told me.
  7.    #7  
    ok, somehow I DID manage to get the linux file, downloaded the Windows version and that problem's solved, thanks!!! Now my new problem... Windows began installing it, then in the middle of the installation the progress bar actually goes BACKWARDS after it gets about 75% done, then I get a message to the effect of "the installer was interrupted and can't finish, try again later, sucka!" (ok, it didn't call me a sucka, but I felt like one..."
    Admittedly I'm running on an ancient computer that's pretty much on its last legs (Dell Dimension 8200 with only 256 memory) but dang!
  8. #8  
    Quote Originally Posted by Conect11 View Post
    ok, somehow I DID manage to get the linux file, downloaded the Windows version and that problem's solved, thanks!!! Now my new problem... Windows began installing it, then in the middle of the installation the progress bar actually goes BACKWARDS after it gets about 75% done, then I get a message to the effect of "the installer was interrupted and can't finish, try again later, sucka!" (ok, it didn't call me a sucka, but I felt like one..."
    Admittedly I'm running on an ancient computer that's pretty much on its last legs (Dell Dimension 8200 with only 256 memory) but dang!
    I don't think you have enough memory to run the emulator. The Pre itself has 256MB of RAM, so I don't think that's going to work.

    So your installation problem is the least of your worries.
  9.    #9  
    Quote Originally Posted by DanPLC View Post
    I don't think you have enough memory to run the emulator. The Pre itself has 256MB of RAM, so I don't think that's going to work.

    So your installation problem is the least of your worries.
    agreed, moved to another computer and problem solved. Now to get to work...

Posting Permissions