Results 1 to 6 of 6
  1. stubbs's Avatar
    Posts
    425 Posts
    Global Posts
    442 Global Posts
       #1  
    Remember the bug with 1.1 or before where the camera would freeze for a few seconds at a time if you clocked higher than 550 MHz? For me, at least, it's gone! I'm happily running at 600 MHz with SmartReflex enabled.

    We'll see how my battery life does like this; after installing 1.2, at the stock 500 MHz, I was only draining 11% over 8 hours idle (overnight), which is better than I had with 1.1.

    Anybody else want to try this and report back?
  2. #2  
    How would I go about doing it?
  3. #3  
    Root your pre copy and paste this to it do not reset your phone because this will not stick.
    # -*- mode: shell-script; -*-
    description "Overclock to 600MHz + SmartReflex"
    author "Alex Markson"
    version 1.0start on stopped finish
    stop on runlevel [!2]console nonescript
    # SmartReflex
    # "SmartReflex™ driver allows for auto-compensation of VDD1 and
    # VDD2 voltages (around the voltages specified by current OPP)
    # by analyzing the silicon characteristics, temperature, voltage etc"# Enable SmartReflex
    echo -n 1 > /sys/power/sr_vdd1_autocomp
    echo -n 1 > /sys/power/sr_vdd2_autocomp# according to the OEM shell script in /etc/miniboot.sh
    # this seems like it needs to be set twice to make sure ?
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeedend script
  4. #4  
    Quote Originally Posted by andrclvn View Post
    Root your pre copy and paste this to it do not reset your phone because this will not stick.
    # -*- mode: shell-script; -*-
    description "Overclock to 600MHz + SmartReflex"
    author "Alex Markson"
    version 1.0start on stopped finish
    stop on runlevel [!2]console nonescript
    # SmartReflex
    # "SmartReflex™ driver allows for auto-compensation of VDD1 and
    # VDD2 voltages (around the voltages specified by current OPP)
    # by analyzing the silicon characteristics, temperature, voltage etc"# Enable SmartReflex
    echo -n 1 > /sys/power/sr_vdd1_autocomp
    echo -n 1 > /sys/power/sr_vdd2_autocomp# according to the OEM shell script in /etc/miniboot.sh
    # this seems like it needs to be set twice to make sure ?
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeedend script
    so in the putty cmd box you would do...

    Code:
    echo -n 1 > /sys/power/sr_vdd1_autocomp
    Code:
    echo -n 1 > /sys/power/sr_vdd2_autocomp
    Code:
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
    Code:
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeedend script
    one at a time? correct?
  5. #5  
    can someone confirm this?

    I like to try this...lol
  6. #6  
    running cat /proc/cpuinfo before this I get:

    Code:
    BogoMIPS        : 498.07
    after:

    Code:
    BogoMIPS        : 597.68
    So this does in fact work. The bigger question is whether or not the 100 MHz boost on the cpu actually does anything performance-wise. I don't know that the cpu is the bottleneck.

    NOTE: I wasn't able to echo the value into the file though. I had to edit it with vi. I also only had to edit the first three files derik123derik123 mentions. The last command he mentions is incorrect.

Tags for this Thread

Posting Permissions