Results 1 to 12 of 12
Like Tree1Likes
  • 1 Post By sveilien
  1.    #1  
    I'm try to run the WebOSQuickInstall.JAR with Java Platform SE Binary and it causes a "Could not find the main class, Program will exit" error.

    Did not work when this computer was Vista, still doesn't work as Win 7.

    Novacom and SDK are installed.

    I have scoured Google for an answer and even Sun's Java forum only recommends un/reinstalling Java 1.6. That does NOT work.

    It is obviously a Java problem. I have WebOSQuickInstall on 3 computers, only one has the "Main class" error.

    I have seen several peoples posts that they have the problem but no solutions.

    I started this thread for trying to find a fix for this single issue only.
    Always pimpin' PunnyShirts.com
    gamer7L7L likes this.
  2. Clipse's Avatar
    Posts
    110 Posts
    Global Posts
    111 Global Posts
    #2  
    double check the file is .jar use the cmd to double check. If it isn't rename it.
  3.    #3  
    Quote Originally Posted by Clipse View Post
    double check the file is .jar use the cmd to double check. If it isn't rename it.
    It is a jar, exact same file downloaded from the WebOS Quick Install Thread.

    Attempting to run the .jar from the command line causes Java to hang.
    Always pimpin' PunnyShirts.com
  4. #4  
    The same thing happened to me.. I deleted everything (WebOsDoctor and all) and did it all again, and EMAILED the .jar file to myself, and it worked after that.
  5. #5  
    ok here's how i finally overcame this error on my 32-bit vista install.

    open a command prompt,
    cd into the dir that has the .jar,
    type: java -jar WebOSQuickInstall.jar

    that should start the install and you should get the prompt window from Quick Install to check if you have the proper WebOSDoctor.

    i battled this error "Cannot find main class, program will exit" all afternoon. this is the only thing that would work for me to even get the install to start.

    now to getting it to work!....
  6. #6  
    Honest to God, I could kiss you on the mouth for this! I have been trying to get around this problem since August.

    This worked like a charm and took two seconds to complete. I seriously can't thank you enough! THANK YOU!
  7. #7  
    Just found this after searching for weeks. I had the same problem. Thanks!
  8. #8  
    any help on this issue?
  9. Mac454's Avatar
    Posts
    6 Posts
    Global Posts
    10 Global Posts
    #9  
    justinholtweb's solution works, but to open WebOS Quick Install, I have to do this every time.

    How would I create a batch file to do this for me until I can figure out what's wrong? Thanks in advance!
  10. #10  
    Im having the exact same problem, I have Windows 7 64 bit and have only the WebOSQuickInstall.jar file in my directory, however in cmd I when i type:

    java -jar WebOSQuickInstall.jar
    (obviously in the correct directory where webos jar file is located)

    I recieve the following error message: 'java' is not recognized as an internal or external comman, operable program or batch file.

    I have no idea what to do, im not that confident with Path changes and working in cmd but any suggestions/help would be great!

    Thanks
  11. #11  
    Quote Originally Posted by eddster59 View Post
    Im having the exact same problem, I have Windows 7 64 bit and have only the WebOSQuickInstall.jar file in my directory, however in cmd I when i type:

    java -jar WebOSQuickInstall.jar
    (obviously in the correct directory where webos jar file is located)

    I recieve the following error message: 'java' is not recognized as an internal or external comman, operable program or batch file.

    I have no idea what to do, im not that confident with Path changes and working in cmd but any suggestions/help would be great!

    Thanks
    Do you have Java installed?

    If so, is it 64-bit Java? (open IE 64bit and try installing through that)
    Arthur Thornton

    Former webOS DevRel Engineer at Palm, HP, and LG
    Former webOS app developer (built Voice Memos, Sparrow, and several homebrew apps and patches)
    Former blogger for webOS Nation and webOS Roundup
  12. #12  
    For me, -jar option doesn't worked. Still got some errors... After that I realised, that I was trying to execute it from samba drive... So I copied it to local drive and problems are gone...

Posting Permissions