Results 1 to 9 of 9
  1. Beknatok's Avatar
    Posts
    55 Posts
    Global Posts
    73 Global Posts
       #1  
    Hi all - I'd been frustrated with the super small font sizes that were being rendered on various "mobile" sites like m.facebook.com, so I decided to start digging. I've already replied to another similar thread, but thought I'd start a fresh one to share what I've found and ask what other tweaks others have found.


    Change Default Font Sizes - This requires rooting your Pre

    1. Edit the following file:
    /etc/palm/browser-app.conf

    The default settings you should change are:
    MinFontSize=8
    MinLogicalFontSize=5
    DefaultFontSize=14
    DefaultFixedFontSize=14

    MinTextAutoSizeFontSize=18

    2. Stop and start the luna preferences service:
    stop luna-prefs-service && start luna-prefs-service

    3. Pull up a site like m.facebook.com and enjoy.

    For reference, I've put my font values in the 30s. I'll also note that images do not scale properly, but that's not something I personally care about.


    Has anyone else out there done any further tweaks to their browser? One of the other parameters in the conf file is:
    # The 'EnableFitWidth' parameter lets us control the default behavior of ScrollView.
    EnableFitWidth=false

    Searches here have turned up nothing, so I'm going to start experimenting with that shortly.
  2. #2  
    So I went ahead and increased the font size per your instructions (using the 24, 24, 36, 36, 24 values I saw you post in another thread), and I'm not seeing any difference for some reason. Well, at least not all web pages. m.facebook.com for instance, which you list as an example doesn't seem to be affected.

    I find this to be a limitation of the browser, the small font size. Anyone that's used one of the Opera Mini browsers knows what good mobile web formatting can look like. Even if the paragraph or table or whatever is small width-wise, that doesn't mean the text has to be small as well. Those are HTML fields that will allow the text to wrap if the font is larger, so why make them so small? I find myself having to zoom in so much that I have to constantly scroll from left-to-right and repeat to be able to read any article on the web.

    Just like Firefox allows you to use CTRL+scroll wheel to zoom the font size, there really ought to be a way to control that within the Pre's web browser. Again the font can increased independent of the rest of the web page. The text will just wrap.
    Last edited by onlinespending; 10/28/2009 at 05:19 PM.
  3. #3  
    I'm not really into rooting my phone, just because I have no time for such things (I have two very little kids and a work long hours...'nuf said!) But this small font issue is driving me bezerk. Is there really no fix? I need to be able to see some sites but for whatever reason they're either rendered in microscopic font size or I have to scroll left to right endlessly. How can the broswer not be wrapping???? I just posted anbother thread about this and other issues. I hope to get some working solution because this is almost a deal-breaker for me. Does the iPhone (webkit based like the ewebOS) behave this way?
  4. #4  
    forgive my ignorance, but how does one 'root' the pre?
  5. #5  
    ok ok I figured out how to root the phone with novaterm and all. I just don't speak linux though, from the command/root line how can I change these default font sizes? what commands do i need to type?
  6. #6  
    does anyone know if there is a way of modifying this file to direct the browser to use an alternate font family instead of the default prelude fonts. thanks for any help.
  7. veerar's Avatar
    Posts
    180 Posts
    Global Posts
    192 Global Posts
    #7  
    Update: Please visit http://forums.precentral.net/showthr...07#post2833507 for the latest patch.

    Ok, I still dont understand how these files affect the browser exactly, but if I load the two patches attached with this message & then restart, then I can reduce the font sizes a bit for most webpages. It works on
    - m.ft.com
    - mobile.nytimes.com
    - m.guardian.co.uk

    It does not work on
    - mobile.bloomberg.com
    - the mobile Google reader page.

    I cannot explain why it only works on some webpages. Any help in understanding will be great.

    Also, I needed to restart my phone for the patch to take effect. There seems to be some caching of the fonts going on. Maybe the FontCache section in browser.conf file controls the caching? Any help in understanding the caching will also be great.

    Also, I edited a whole bunch of settings; I have no idea what they do since they produced no effect. The settings I changed are:
    +EnableFitWidth=true
    +PageCacheCapacity=1
    +MinFontSize=5
    +DisableGifAnimations=true

    If someone can help me combine the two patches into one file, we can upload it to Preware. Otw, please use WOSQI.

    I am sure others will want to _increase_ the font size; for them , download the patches, edit the font sizes to be 16 or 18. So you would say:
    +DefaultFontSize=16
    +DefaultFixedFontSize=16

    BTW, there are font family settings in browser.conf:
    DefaultSerifFontFamilyName=Times New Roman
    DefaultSansSerifFontFamilyName=Prelude
    DefaultFixedFontFamilyName=Courier New
    DefaultStandardFontFamilyName=Prelude

    I did not try changing them; if any of you make the effort to find out how this behaves, please let us know!


    Hope this helps someone.

    Thanks,
    veerar.
    Attached Files Attached Files
    Last edited by veerar; 01/20/2011 at 09:26 PM. Reason: Added font family settings; referring to the simpler better single patch version
  8. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
    #8  
    could the browser.conf to be tweaked to add an Arabic Font to the Fonts family and make it able to the Browser to read Arabic? How?
  9. veerar's Avatar
    Posts
    180 Posts
    Global Posts
    192 Global Posts
    #9  
    I am not sure about the arabic fonts. I think you should change the regional settings for that. Try that instead.

Posting Permissions