Results 1 to 5 of 5
  1.    #1  
    I was able to root and apply several patches by doing "quilt import <patch>", "quilt push" (or "quilt push -f" whenever I received an error that one of the hunks failed, as I learned in a thread here) and then "quilt refresh" if I had to do a force before because of the hunks failed error. All that worked and I was able to install the following packages, which I can see by doing "quilt applied":

    /opt/src/patches/hidden-clock.patch
    /opt/src/patches/enable-landscape-email.patch
    /opt/src/patches/capture_with_volume_keys.patch
    /opt/src/patches/add-onscreen-keyboard.patch
    /opt/src/patches/message-forwarding.patch
    /opt/src/patches/messagelandscape.patch
    /opt/src/patches/enable-browser-downloads.patch
    /opt/src/patches/add-delete-pages-in-the-launcher.patch
    /opt/src/patches/messaging-enter-newline.patch
    /opt/src/patches/enable-dev-mode-icon.patch


    However, after I imported that last patch you see in the list, I can't do "push", even if I use "-f". This is what I get:

    The topmost patch /opt/src/patches/enable-dev-mode-icon.patch needs to be refreshed first.

    OK, so I try a "quilt refresh" and this is what I get:

    Nothing in patch /opt/src/patches/enable-dev-mode-icon.patch

    I learned about the deletions, so I tried "quilt delete /opt/src/patches/enable-dev-mode-icon.patch" and then get this:

    Patch /opt/src/modifications/luna/enable-dev-mode-icon.patch is not in series

    What am I doing wrong? I can't install any other patches or, what's worse, I am afraid I won't be able to do "quilt pop -a" whenever Palm releases a new webOS update, because if I try to do "quilt pop", I get the following error:

    Patch /opt/src/patches/enable-dev-mode-icon.patch needs to be refreshed first.

    What? You didn't let me refresh it in the first place! I'm frustrated and don't know where to go. Yes, I read the Quilt manual and it didn't help.
  2.    #2  
    Nobody, really?
  3. #3  
    Do a quilt delete /opt/src/patches/enable-dev-mode-icon.patch

    Problem was you were pointing it to the original path of the patch, which was where the file was BEFORE you imported it into the series, or your /opt/src/patches folder.
  4.    #4  
    Quote Originally Posted by K4p741nkrunch View Post
    Do a quilt delete /opt/src/patches/enable-dev-mode-icon.patch

    Problem was you were pointing it to the original path of the patch, which was where the file was BEFORE you imported it into the series, or your /opt/src/patches folder.
    DUH! You are right! How stupid of me! OK, I am going to try that once I get home. Anything special with that package, though? Why couldn't I install any other package after it?
  5.    #5  
    I couldn't wait, so I installed Java, VirtualBox and the Mojo SDK at work and tried what you suggested. Worked like a charm. Thanks!

Posting Permissions