Page 5 of 6 FirstFirst 123456 LastLast
Results 81 to 100 of 110
  1. mashiya's Avatar
    Posts
    55 Posts
    Global Posts
    57 Global Posts
    #81  
    Ok i am not understanding this at all. I installed the version from webos quick install, with 5 icons in a row. ok i dont like it. Been trying to get into putty to edit it, but it keeps telling me this :

    login as: mashiya
    mashiya@192.168.1.2's password:
    mashiya@castle:~$ sudo su -
    Password:
    root@castle:/var/home/root# /usr/lib/luna/system/luna-applauncher/app/controller
    s/launcher-assistant.jsjsjs
    -sh: /usr/lib/luna/system/luna-applauncher/app/controllers/launcher-assistant.jsjsjs: $Permission$ $denied$
    root@castle:/var/home/root#

    Keep in mind i am a noob lol. I have done a few things, but this i dont know how to do. Please help! Thanx
  2. mherald81's Avatar
    Posts
    77 Posts
    Global Posts
    85 Global Posts
    #82  
    you forgot to type vi
  3. mashiya's Avatar
    Posts
    55 Posts
    Global Posts
    57 Global Posts
    #83  
    ok now i have another problem. i am in the edit, but i dont see these lines

    vi /usr/lib/luna/system/luna-applauncher/app/controllers/launcher-assistant.jsjsjs

    LINE 19 ---- kPageIndicatorSpacing: 1,
    LINE 402 --- this.kAppWidth = 72;
    LINE 403 --- this.kAppHeight = 86;
    LINE 404 --- this.kAppsPerRow = 4;
    LINE 518 --- left: (((appIndex % this.kAppsPerRow) * this.kAppWidth)),


    i see line 20, but none of the other. has this changed or somthing?
  4. #84  
    Quote Originally Posted by mashiya View Post
    ok now i have another problem. i am in the edit, but i dont see these lines

    vi /usr/lib/luna/system/luna-applauncher/app/controllers/launcher-assistant.jsjsjs

    LINE 19 ---- kPageIndicatorSpacing: 1,
    LINE 402 --- this.kAppWidth = 72;
    LINE 403 --- this.kAppHeight = 86;
    LINE 404 --- this.kAppsPerRow = 4;
    LINE 518 --- left: (((appIndex % this.kAppsPerRow) * this.kAppWidth)),


    i see line 20, but none of the other. has this changed or somthing?
    The line numbers match my file. The code segment containing lines 402-404 is:

    Code:
    		// configure the div within the page (event handling, positioning, etc.)
    		var newAppDiv = $(newAppInfo.launchPointId);
    		Mojo.assert(newAppDiv !== undefined, "Application (%d) was inserted into the DOM but unable to be retrieved!", newAppInfo.launchPointId);
    		if (isNaN(this.kAppWidth) || isNaN(this.kAppHeight)) {
    			this.kAppWidth = 64;
    			this.kAppHeight = 90;
    			this.kAppsPerRow = 5;
    		}
    This code segment is about like line 475 in the unaltered file. The alteration is the numbers after the equal sign replace the stored/calculated values palm coded. I changed the app width since I wanted more space between icons in the rows. Which meant the margins had to be reduced. This reduction is seen in this code segment that contains line 518.

    Code:
    	/* determines the position of an app element at appIndex within a page */
    	calculateAppPosition: function(appIndex) {
    		return {
    			left: (((appIndex % this.kAppsPerRow) * this.kAppWidth) - 18),
    			top: (Math.floor(appIndex/this.kAppsPerRow) * this.kAppHeight + this.kTopMargin)
    		};
    	},
    In the original file this segment is about line 480. I would recommend checking each line that was supposed to be added or altered to make sure it is added. If you miss any part the launcher may malfunction. Hopefully you have a backup of the original. If not you can extract it from the 1.1 webOS doctor to replace the one on the pre.
  5. mashiya's Avatar
    Posts
    55 Posts
    Global Posts
    57 Global Posts
    #85  
    That is strange. i dont know why mine is off. Here is the girls original post:


    EDIT: Things were perfect with a notification, but without, had some dead space. I just adjusted one number (below in bold).

    Figured out margins and indicator. And I adjusted to make it 4x4 instead of 4x3.

    Here are my variables and screenshots.

    vi /usr/lib/luna/system/luna-applauncher/app/controllers/launcher-assistant.jsjsjs

    LINE 19 ---- kPageIndicatorSpacing: 1,
    LINE 402 --- this.kAppWidth = 72;
    LINE 403 --- this.kAppHeight = 86;
    LINE 404 --- this.kAppsPerRow = 4;
    LINE 518 --- left: (((appIndex % this.kAppsPerRow) * this.kAppWidth)),

    vi /usr/lib/luna/system/luna-applauncher/stylesheets/launcher.css

    LINE 119 --- top: 56px;
    LINE 128 --- font-size: 11px;
    LINE 151 --- width:56px;
    LINE 152 --- height:56px;
    LINE 195 --- width:56px;
    LINE 196 --- height:56px;


    LIne 402- 518. dont match mine, but the bottom 119- 196. are perfect. do you think its because i installed the 5 icons per row from quick installed, and then i unisstalled the 5 and tried to do this code?

    Thanx for your help StoneRyno, i am gonna try this out, i am nervous because i dont have back ups. i dont know how to do it.
  6. mashiya's Avatar
    Posts
    55 Posts
    Global Posts
    57 Global Posts
    #86  
    sorry i forgot to quote hers. but i start typing at, where it says Line 402-518 dont match the line........
  7. cwgtex's Avatar
    Posts
    608 Posts
    Global Posts
    609 Global Posts
       #87  
    Quote Originally Posted by mashiya View Post
    That is strange. i dont know why mine is off. Here is the girls original post:
    I'm not a girl.
  8. cwgtex's Avatar
    Posts
    608 Posts
    Global Posts
    609 Global Posts
       #88  
    Here are the original files. I backed them up after I had to do a webOS Doctor reset for an unrelated issue.

    If you don't feel like restoring these files, use the search function of vi.

    /searchterm
    Attached Files Attached Files
  9. mashiya's Avatar
    Posts
    55 Posts
    Global Posts
    57 Global Posts
    #89  
    Oh sorry. didnt mean to call you a girl. i didnt know. thanx for all the info. i tried these last night. and had to visit the doctor 2 times. lol. cause i messed the launcher up some how, the launcher wouldnt even open.
  10. #90  
    I did this using the web os quick install 4x4 checkbox, but for some reason when i have 4 rows high i still see the scroll arrow (even tho all 4 rows are visible) anyone know how to fix?

    Edit: changed the vertical number (this.kAppHeight) to 85 - they had it higher, i think like 92, and it looks good now..
    Last edited by mdmogren; 08/29/2009 at 06:44 PM.
  11. mashiya's Avatar
    Posts
    55 Posts
    Global Posts
    57 Global Posts
    #91  
    Where did you find the 4x4 at? All i see is 5x4.
  12. #92  
    Quote Originally Posted by mashiya View Post
    LIne 402- 518. dont match mine, but the bottom 119- 196. are perfect. do you think its because i installed the 5 icons per row from quick installed, and then i unisstalled the 5 and tried to do this code?

    Thanx for your help StoneRyno, i am gonna try this out, i am nervous because i dont have back ups. i dont know how to do it.
    The following lines are added that aren't in the original file:
    At line 127-128:
    Code:
    				/*
    				START ENABLE PAGE ADD AND DELETE */
    At 142-157 (inserted at line 140 of the original)
    Code:
                                   /*
                                    END ENABLE PAGE ADD AND DELETE
    
                                    case 'newpage':
    					if (this.pageDivs.length < 10) {
    						this.insertPage(this.activePageIndex, true);
    					}
    					break;
    				case 'deletepage':
    					if (this.pageDivs.length > 1) {
    						this.deletePage(this.activePageIndex);
    						if (this.activePageIndex >= this.pageDivs.length) {
    							this.activePageIndex = this.pageDivs.length - 1;
    						}
    					}
    					break;
    				*/
    These lines of code possibly may explain the differences. They pertain to the add/removed launcher pages patch.
  13. mashiya's Avatar
    Posts
    55 Posts
    Global Posts
    57 Global Posts
    #93  
    Do you happen to have your icons 4x4 StoneRyno? And do you have the new code for the new lines with the page and delete section added?
  14. #94  
    Quote Originally Posted by mashiya View Post
    Do you happen to have your icons 4x4 StoneRyno? And do you have the new code for the new lines with the page and delete section added?
    Mine is 5 per row 4 rows visible above the quick launch. And I also have the add/remove launcher pages as well. At the time I applied the more icons patch it was a part of that patch. I don't know if the patch has changed any since. I know someone in this thread or the other thread has theirs setup 4x4. I think I have lost track of the conversation though, we are trying to manually patch the file because the patch fails to apply?
  15. #95  
    Could someone just please give me what exactly i should type in Putty? I have my pre rooted and have installed the onscreen keyboard. But I can not seem to get the more icons per page working. Could someone tell me what to type in putty after i have logged into it in order to add this patch to my phone?
  16. #96  
    Quote Originally Posted by Chunkylover21 View Post
    Could someone just please give me what exactly i should type in Putty? I have my pre rooted and have installed the onscreen keyboard. But I can not seem to get the more icons per page working. Could someone tell me what to type in putty after i have logged into it in order to add this patch to my phone?
    If you haven't done so already install optware and quilt. If you have already installed those and did so before Aug 8th 2009 begin following the instructions to upgrade to switch to quilt lite. Then follow the instructions for importing and applying patches on that page. One of the steps is to enter the patch you want to install. Once you are done following the instructions all should be good and the patch applied.
  17. #97  
    I did all the steps but something is wrong. It wont add the patch. Coudl you just tell me the specific lines of code to enter in order pleeeease
  18. mashiya's Avatar
    Posts
    55 Posts
    Global Posts
    57 Global Posts
    #98  
    You should try Quick install. Its easier. Its 4x4, you will have to download the updated version of quick install Version 2.02. You find it under tweaks, I gave up on the code. I had to go to the doctor twice, Quick install is much easier. Just a suggestion for you.
  19. #99  
    Quote Originally Posted by Chunkylover21 View Post
    I did all the steps but something is wrong. It wont add the patch. Coudl you just tell me the specific lines of code to enter in order pleeeease
    Anything I would tell you to do would just be exactly what those pages tell you to do, so it wouldn't change the problem you are encountering. I can troubleshoot the problem if you can supply a screenshot or copy of the session so I can see what you see. Also at which point in the instructions you are encountering the issue.
  20. hdhuntr's Avatar
    Posts
    218 Posts
    Global Posts
    696 Global Posts
    #100  
    My eyes are gonna pop from looking all over to see if there's a non-rooted way yet to add/delete pages for applications.

    I think I ended up in an ok place to at least ask the question. If it matters I have prwbrew but not webosquickinstall... Thanks,Dave.
    Treo 300,600,650,755p and now Pre
Page 5 of 6 FirstFirst 123456 LastLast

Posting Permissions