Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27
  1. #21  
    Got it working...not sure what I did, but it works now. Thanks.
  2. #22  
    I cant get this to work I got putty and WinSCP both login and I also did a mount -o remount, rw o but it still not working.
  3. Pseudo's Avatar
    Posts
    7 Posts
    Global Posts
    11 Global Posts
    #23  
    wish there was an easier way, but yeah...

    Jumping back into winscp after not using it for a few days i realized that "sudo /opt/libexec/sftp-server" setting was not set when I tried to log back in...


    Questions
    1. Anyone know command-line parameters one can add to make PUTTY and WinSCP easier/faster? (Auto-connect to hostname maybe, instead of the dynamic IP?)

    2. Any way to automate the putty->login->sudo command remount, where all it asks for is my password? I assume if you can pass 1 command line to putty you could get this done...

    I Don't use SSH much >.> Just want to make this an easier process to shoot files to my phone
  4. e_town's Avatar
    Posts
    37 Posts
    Global Posts
    42 Global Posts
    #24  
    Strange, i added
    Code:
    sudo /opt/libexec/sftp-server
    and i have access to change some directories, but not all.... Doesnt seem to let me change anything in root/usr/palm/applicatoins, but i CAN in root/var/usr/palm/applications/. Should this command let you have access to the whole filesystem or just selected parts?

    Also, i did NOT do anything in putty to get this to work. Just the change in Win SCP...



    EDIT: Fired up putty and
    Code:
    sudo mount -o remount,rw /
    and I could change anything and everything through winscp... (so far)


    Steps that i did to get it to work:

    1. Add "sudo /opt/libexec/sftp-server" to connections settings in winscp



    2. Putty to unmount filesystem "sudo mount -o remount,rw /"



    3. upload / change files that you want.

    4. when done lock filesystem "sudo mount -o remount,ro /" and close winscp

    Last edited by e_town; 09/17/2009 at 08:08 AM. Reason: used putty
  5. #25  
    I'm trying to input instructions as shown here (link below) to enable my permissions in Winscp ..

    http://forums.precentral.net/attachm...ace_images.jpg

    .. in Putty I'm at this stage (Trying to get to (4) as in instructions) ..

    putty window.jpg

    How do I get it to show 'northernlanes@castle' as opposed to 'northernlanes@palm-webos-device' ? (similar to instructions)

    Also in (2) of the instructions, if I try to Login to Winscp by ticking the 'Advanced Options' and select "Environment>SFTP" and in the SFTP server box enter: "sudo /opt/libexec/sftp-server" but when I login I get this error message .. I can Login ok if I leave SFTP as Default.

    login error.jpg

    .. I feel I'm going round in circles here, can anyone help me ?
  6. #26  
    Quote Originally Posted by Northernlanes View Post
    I'm trying to input instructions as shown here (link below) to enable my permissions in Winscp ..

    http://forums.precentral.net/attachm...ace_images.jpg

    .. in Putty I'm at this stage (Trying to get to (4) as in instructions) ..

    putty window.jpg

    How do I get it to show 'northernlanes@castle' as opposed to 'northernlanes@palm-webos-device' ? (similar to instructions)
    I think aver 1.3.1 or after WinSCP's new version was released your login to root changed from @castle to @palm-webos-device.

    Anyhow this stuff is kinda over my head but I'm able to use the more powerful commands when at the prompt '@palm-webos-device'
    Pre|central Peacekeepers
    Share your Mizzou pride:
    - wallpapers/boot themes - here
    - Black n' Gold theme - here
  7. #27  
    Thanks MLJones8, I'm not too clued up about the subjects intricacies but ....

    I sorted it .., RedNinja had the answer here, this and a combination of this post and a lot of tinkering about and it worked..

    http://forums.precentral.net/showthr...53#post2092953

    Quote Originally Posted by redninja View Post
    after you fill in the name,pass,ip, page click on sftp on the left, and paste this command in the protocol window. "sudo /opt/libexec/sftp-server" then sign it in. also sometimes i still have to open a putty session in it.
    Last edited by Northernlanes; 12/15/2009 at 02:28 AM.
Page 2 of 2 FirstFirst 12

Posting Permissions