Results 1 to 9 of 9
  1.    #1  
    I have followed the instructions here:

    hxxp://w w w.webos-internals.org/wiki/Next_steps

    (sorry about the link, I still can't post them)

    and I chose the option for EVDO and wifi but I can only SSH when I am on EVDO. I have tried to solve this problem myself for a couple days now but I am stuck. I have also tried searching the forums but have not yet found an answer

    The contents of my optware-dropbear file are below:

    Code:
    description "Dropbear SSH Daemon for WebOS"
    author "Dax Kelson"
    version 1.1
    
    # don't start until the WebOS finishes it's normal boot 
    # that way no delay is added to the GUI startup
    start on stopped finish
    stop on runlevel [!2]
    
    # The "stock" WebOS dropbear (not shipped) uses this next line
    # uncomment if you want the same behavior
    #stop on started start_update
    
    # don't try to log any output
    console none
    
    # Uncomment to make sure SSH sessions don't slow down GUI use
    #nice 5
    
    # Restart the SSH daemon if it exits/dies
    respawn
    
    # -g disallow password logins for root
    # -F runs in the foreground so the respawn will work
    # -p sets the TCP port
    exec /opt/sbin/dropbear -g -F -p 222
    
    pre-start script
         # Add firewall rule to allow SSH access over WiFi on port 222
         # Remove the "-i eth0" on both of the following lines to enable SSH access
         # over the cellular data network (EVDO, etc).
         /usr/sbin/iptables -D INPUT -p tcp --dport 222 -j ACCEPT || /bin/true
         /usr/sbin/iptables -I INPUT -p tcp --dport 222 -j ACCEPT
    end script
    
    # funny comment goes here
    I am still new to linux so I may be doing something wrong that would otherwise seem obvious. If that is the case please point me in the right direction.
  2. stubbs's Avatar
    Posts
    425 Posts
    Global Posts
    442 Global Posts
    #2  
    We need to know more details. What's actually happening? Are you connected to a wifi network? Does the phone have internet access? Is the computer you're trying to connect to your Pre from on the same network? Do you know the Pre's IP address? What's the exact string you are typing?

    Give us some more info and we can probably work it out.
  3.    #3  
    Sorry for the lack of detail. I figured it would just be an obvious mistake in my settings.

    I am connected to the wifi through a linksys wrt54g router. The phone does have internet access and the IP changes when I am connected through wifi. The computer I am using is connected through the same router but not through wifi. I do know the Pre's IP address. I am using putty:

    port 222
    preferred SSH version 2
    Disable Nagle's algorithm checked
    Enable TCP keepalives checked

    basically the same settings that I use to connect when the phone is on EVDO but I use the ip address that the "whatismyip" site reports after connecting to the wifi which changes from what it was when I only had the EVDO on.

    The error that I get is "Network Error: Connection Refused". I also can not SFTP into the phone using wifi but it will work with EVDO as well.
  4. #4  
    Don't connect to "whatsmyip" to get your IP address, since that will be your external IP address. Your router is most likely blocking the incoming connection, since it doesn't know where to forward it to. You're going out to the internet and back to get to a local device.

    If you're trying to connect to it on the same network, you need to SSH to the phone's internal IP. Your WRT54g router most likely assigned it an address like 192.168.1.10X, where X is variable.

    There's an app that can tell you your IP, or you can check the router's DHCP logs.

    edit: Here's the app
    http://forums.precentral.net/homebre...ress-tool.html

    Summary: Basically you're trying to connect to the wrong IP.
    Last edited by panda6; 08/04/2009 at 06:10 PM. Reason: Added link to myip app.
  5.    #5  
    Quote Originally Posted by panda6 View Post

    If you're trying to connect to it on the same network, you need to SSH to the phone's internal IP. Your WRT54g router most likely assigned it an address like 192.168.1.10X, where X is variable.
    This was exactly my issue! It is so much faster than EVDO as I have a horrible connection at home
  6. #6  
    touch the wifi icon in the upper right corner,tap wifi,then tap the connection you are using,Your Ip will show up as the first line. Thats what you need to input into putty.


    Doug
  7.    #7  
    Thanks 2sslow, your method works as well.
  8. bscabl's Avatar
    Posts
    35 Posts
    Global Posts
    56 Global Posts
    #8  
    where is this file hiding, im having the same issue but cant find this file to edit


    Quote Originally Posted by kickenchicken57 View Post
    I have followed the instructions here:

    hxxp://w w w.webos-internals.org/wiki/Next_steps

    (sorry about the link, I still can't post them)

    and I chose the option for EVDO and wifi but I can only SSH when I am on EVDO. I have tried to solve this problem myself for a couple days now but I am stuck. I have also tried searching the forums but have not yet found an answer

    The contents of my optware-dropbear file are below:

    Code:
    description "Dropbear SSH Daemon for WebOS"
    author "Dax Kelson"
    version 1.1
    
    # don't start until the WebOS finishes it's normal boot 
    # that way no delay is added to the GUI startup
    start on stopped finish
    stop on runlevel [!2]
    
    # The "stock" WebOS dropbear (not shipped) uses this next line
    # uncomment if you want the same behavior
    #stop on started start_update
    
    # don't try to log any output
    console none
    
    # Uncomment to make sure SSH sessions don't slow down GUI use
    #nice 5
    
    # Restart the SSH daemon if it exits/dies
    respawn
    
    # -g disallow password logins for root
    # -F runs in the foreground so the respawn will work
    # -p sets the TCP port
    exec /opt/sbin/dropbear -g -F -p 222
    
    pre-start script
         # Add firewall rule to allow SSH access over WiFi on port 222
         # Remove the "-i eth0" on both of the following lines to enable SSH access
         # over the cellular data network (EVDO, etc).
         /usr/sbin/iptables -D INPUT -p tcp --dport 222 -j ACCEPT || /bin/true
         /usr/sbin/iptables -I INPUT -p tcp --dport 222 -j ACCEPT
    end script
    
    # funny comment goes here
    I am still new to linux so I may be doing something wrong that would otherwise seem obvious. If that is the case please point me in the right direction.
  9. bscabl's Avatar
    Posts
    35 Posts
    Global Posts
    56 Global Posts
    #9  
    irc strikes again, got it thanks!

Posting Permissions