Results 1 to 18 of 18
  1.    #1  
    Ok fellas I have no clue what I am doing wrong here or what is not working properly, and YES I have searched forum after forum for a solution...

    Ok I installed Virtual Box
    Then Mojo SDK
    My Java was up to date
    Then d/l novaterm-1.zip and extracted it to my C:\Program Files\Palm\SDK\bin

    My system is Windows XP 32bit so no need to start novacomd it was already a running process

    When I cmd in novaterm the connection box opens and when I click Connect (with localhost) I get this msg "failed to connect to novacomd"
    My pre is connected to the PC via USB and I have tried leaving it alone or the Just Charge tab but I get the same result... Yes it is in DevMode


    Any help would be greatly appreciated...
  2. #2  
    why didnt you install the novocom drivers thru the sdk using the dpinst.exe?
    do you have the rootkit?
  3.    #3  
    I went strictly off the youtube video for "How to Root Your Pre" the only difference was his system was 64 bit and mine isn't....

    Should I run that dpinst.exe ???
  4. #4  
    yah buddy try running that and install the novacom drivers thru there, and let me know how that goes after its done and you try to root the pre
  5.    #5  
    Novaterm still says "failed to connect to novacomd"
  6. #6  
    ugh, not that error. I have gotten similiar errors before, but when i turned Dev mode off, rebooted and turned it back on it seemed to work fine for me. Have you tried that yet?

    click start - run - type in services.msc and look for Palm Novacom, and see if its started. If it isnt, start it. If it is, stop the service and the start it back up again and try connecting the pre.
  7.    #7  
    then should I try to connect to the pre using novaterm or the novacom ?
  8.    #8  
    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\XXXXXXXXXX>cd \program files\palm\sdk\bin

    C:\Program Files\Palm\SDK\bin>novacom -t open tty://
    unable to find device

    C:\Program Files\Palm\SDK\bin>


    and I get the "failed to connect to novacomd" when I try it with novaterm
  9. koaltech's Avatar
    Posts
    28 Posts
    Global Posts
    29 Global Posts
    #9  
    I had this issue, then I figured out that my software firewall on my PC was blocking the attempt to connect...once I enabled it, I was cooking with grease...
  10.    #10  
    Ok well I gave up on trying to root using my XP PC and I moved on to my Vista Ultimate 64 PC instead...

    now when I connect my pre I get all but the novacom linux drivers to install...
  11.    #11  
    All fixed...

    Thanks for trying to help out, I actually got it rooted and started editing my Pre on my Vista Ultimate 64 PC.
  12. #12  
    i get the same problem
  13. #13  
    When enabling root your phone cannot be in usb. Put it in just charge.
  14. #14  
    Download the Palm SDK.
    Install it using the Palm SDK installation instructions.
    If you are on Windows 7, the SDK may not install properly and will rollback 75% of the way through install. You need to follow special instructions here from PreCentral to get the Novacom to install properly.
    Enable dev mode on your Pre Enable dev mode.
    You can then run palm-install to install a package onto your Pre (or onto the Pre Emulator)
    The next step is different for different operating systems:
    If you are on a Mac or Linux, you can type novaterm instead of 'palm-install' to directly access the Linux command line.
    If you are using 32 bit Windows XP or Vista there is a novaterm program at the following address: novaterm1.zip Download it and unzip it into the sdk/bin directory. Then, just like the Mac and Linux users you can just type novaterm.
    If you are on 64 bit Windows Vista or Windows 7, novaterm isn't running yet, but you can type novacom -t open tty:// to achieve a similar outcome to using novaterm on the other platforms.
    Long Versions
    -- detailed walk through for windows 64 users: Novacom on Windows.
    -- detailed walk through for Mac OS X / Linux / 32 Bit Windows users: Accessing Linux Using Novaterm
    Follow desired steps from the 'Next steps' below.


    the whole novacom thing doesnt work for me. does the pre have to be hooked up by this point, via putty or usb? AGhh, lost.
    there seems to be too many different instructions, load python, so forth
    I do have the MOJO SDK and eclipse, and virtual box, but I'm still lost.
    I have vista 32 bit, so I did the install " you are using 32 bit Windows XP or Vista there is a novaterm program at the following address: novaterm1.zip Download it and unzip it into the sdk/bin directory. Then, just like the Mac and Linux users you can just type novaterm.
    If you are on 64 bit Windows Vista or Windows 7, novaterm isn't running yet, but you can type novacom -t open tty:// to achieve a similar outcome to using novaterm on the other platforms.

    but it cant type novaterm into the command window, it just sits there.
  15. #15  
    If I am running the mojo sdk, can I just paste that code, or whatever code, into something there? LOL?
    do i need to run the eclipse, paste the code, package it? then send it to the emulator? aggh.
  16. #16  
    It didnt work, unzipping comes up with errors and wont unzip it into the folder.
  17. jsg7377's Avatar
    Posts
    1 Posts
    Global Posts
    2 Global Posts
    #17  
    I had the same problem after trying to root my pre after a couple months.

    Turns out I forgot to turn Developer Mode back on.

    For those of you who are not familiar with Developer mode...


    Enabling Developer Mode:

    1.In Card view or in the Launcher application, type the following:
    upupdowndownleftrightleftrightbastart
    2.Tap the resulting Developer Mode Enabler icon.
    3.In the application, move the Developer Mode slider to the On position.
    4.Tap Reset the Device.
    When reset is complete, Developer mode is enabled.
  18. ird
    ird is offline
    ird's Avatar
    Posts
    156 Posts
    Global Posts
    167 Global Posts
    #18  
    You can also type webos20090606

Posting Permissions