Results 1 to 3 of 3
  1. stubbs's Avatar
    Posts
    425 Posts
    Global Posts
    442 Global Posts
       #1  
    So I'm a regular vi/vim user, and I followed the How To Use "ls" In Color - WebOS Internals guide to enable color for ls, which is great. Does anybody know how to do so for vim? I've installed vim with ipkg-opt, but so far haven't been able to enable color. Those are the things I use most on the command line, so syntax highlighting while looking at/modifying files would be great.
    Thanks!
  2. #2  
    You need to add this to your ~/.vimrc file:
    syntax on

    Or you can enable it in the editor by hitting escape and typing
    :syntax on

    It looks like you have to make sure your TERM environment variable is not vt100. If you set it to xterm then you will get all the pretty colors. But if you have color ls that might already be set.
  3. #3  
    ^^^ What he said.

    Make sure $TERM is set to xterm, and for extra convenience add

    syntax on
    set nocompatible
    set ai

    To your $HOME/.vimrc file.

Tags for this Thread

Posting Permissions