Results 1 to 12 of 12
  1.    #1  
    Please help..
    I was followed the SDK intructions for rooting my pre and was initially able to access my pre using novacom. After completing the bootstrap instructions including creating username/password I am nolonger able to communicate with the pre via novacom. I am able to see the device using novacom -l but am not able to communicate with it. Using palm-install -l it does retrieve my current apps, so there is communication but I can nolonger get to the command line. Any assistance would be greatly appreciated... I am using linux mint as my OS. Thanks so much
  2. stubbs's Avatar
    Posts
    425 Posts
    Global Posts
    442 Global Posts
    #2  
    strange. Are you sure it's still in developer mode? If not, try turning it off, rebooting, then back on (with another reboot).
    Do you have the Pre on wifi, and do you know its IP address? Did you already install Dropbear or OpenSSH?

    As a last resort, you can always use the WebOS doctor and start over, but I'm sure you want to avoid that.
  3.    #3  
    It is strange,
    I tried rebooting it back on and it is in developer mode. I tried ssh and telnet into it's IP address w/o success (both plugged into the usb and not) and I did install dropbear and openSSH back when I had access. I am really trying to avoid WebOS if possible. quite simply novacom does not pick it up. do I need to pass any parameters using telnet or ssh (from the command line I simply type telnet IP and ssh IP) Thanks for the help
  4. pre-cious's Avatar
    Posts
    6 Posts
    Global Posts
    7 Global Posts
    #4  
    Hi folks. First post.
    In order to SSH to your pre you need to specify the non-standard port the pre is listening on which is 222. So you just type "ssh -p 222 preip". If you use scp then it's scp -P 222 file pre:/path/where/you/want/file.

    Hope this helps.
  5.    #5  
    Thanks so much, that got it
  6. #6  
    Hello:
    I previously rooted with my Mac but I am not able since the 1.1 update. I rebooted phone, Mac, and have the phone in developer mode. I previously launched Terminal and did "cd /opt/nova/bin" then "./novaterm" Those commands got me rooted but I now get a "cannot connect to server."
    Thanks in advance for any assistance,
    Bob G
  7. stubbs's Avatar
    Posts
    425 Posts
    Global Posts
    442 Global Posts
    #7  
    Quote Originally Posted by gugbogey View Post
    Hello:
    I previously rooted with my Mac but I am not able since the 1.1 update. I rebooted phone, Mac, and have the phone in developer mode. I previously launched Terminal and did "cd /opt/nova/bin" then "./novaterm" Those commands got me rooted but I now get a "cannot connect to server."
    Thanks in advance for any assistance,
    Bob G
    I frequently use that exact method on my mac, and haven't had any problems. Are you making sure to hit "just charge" when you plug it in? Is the phone giving you the option for media sync or USB drive? Just trying to run through the options.
  8. Bigfire's Avatar
    Posts
    259 Posts
    Global Posts
    543 Global Posts
    #8  
    I continue to have Putty command terminal timeouts....anything known to cure this? I continually have to 'restart session'

    I have been able to successfully get one app loaded (text forwarding) but was having the same issues and just seemed to get lucky....its like the device wasn't able to keep a good wifi connection or something.
  9. stubbs's Avatar
    Posts
    425 Posts
    Global Posts
    442 Global Posts
    #9  
    Quote Originally Posted by bigfire View Post
    I continue to have Putty command terminal timeouts....anything known to cure this? I continually have to 'restart session'

    I have been able to successfully get one app loaded (text forwarding) but was having the same issues and just seemed to get lucky....its like the device wasn't able to keep a good wifi connection or something.
    The phone turns off its wifi radio when it goes into standby. You need to either set it to turn off after a long time (3 minutes is the longest you can do by default), and just remember to keep touching it every couple of minutes, or plug it in. If it's charging, it keeps the wifi connection active even when the screen turns off.

    You're getting connection timeouts when the screen turns off and the phone kills wifi.
  10. #10  
    I tried editing script files on the pre. In the past, I didn't have any problems. After the 1.1 release, I can't get vi to work correctly. When I try to navigate through a file, the arrow keys do not work. For example, when I press the down arrow key, it echos ^[[B on the screen and the line number does not change. The : commands seem to work, for example, I can enter :q! and vi quits immediately. The last time previously that I had used vi was on July 8th. It worked correctly at that time. Got any ideas where I am screwing up.
    Thanks, Jim
  11. stubbs's Avatar
    Posts
    425 Posts
    Global Posts
    442 Global Posts
    #11  
    Quote Originally Posted by seippel View Post
    I tried editing script files on the pre. In the past, I didn't have any problems. After the 1.1 release, I can't get vi to work correctly. When I try to navigate through a file, the arrow keys do not work. For example, when I press the down arrow key, it echos ^[[B on the screen and the line number does not change. The : commands seem to work, for example, I can enter :q! and vi quits immediately. The last time previously that I had used vi was on July 8th. It worked correctly at that time. Got any ideas where I am screwing up.
    Thanks, Jim
    Sounds like a profile is messed up somewhere. Have you made any custom profiles or anything? What shell are you using? (sh, bash, ksh...)

    Does that happen when you login through ssh or through novaterm?
  12. #12  
    Thanks for the help. I was logging in using the novaproxy.py script and using putty in RAW mode. The problem was I had not saved the line discipline options to force off for line echo and local line editing. I had saved the default setting the last time I used Putty and missed that option. Thanks for your help. - Jim

Posting Permissions