Results 1 to 8 of 8
  1.    #1  
    First off let me say thanks to all those contributing to this site. It's nice to have a place to go to get info on what's possible on this phone.

    Now on to my issue. I have successfully rooted my Pre and chose to install the dropbear option for WiFi only since I don't plan on needing the extra features of OpenSSH and don't have a need for access via EVDO. SSH will work, but not reliably. It seems the only time I can make a connection via SSH is if I have the phone initiate network traffic. I am aware of WiFi shutting off when the phone sleeps and that is not the issue I'm having. Even on a Touchstone I'm having the same problem. I have to open a web page or force a check for mail to get the SSH session to update. Even those are not guaranteed. The only way I have found to make SSH respond normally is to have the Pre run a constant ping to another host on the network. That's not good for the battery and I don't think this is how it's supposed to behave so I'm looking for suggestions.

    I searched these forums to see if anyone had seen something like this but didn't run across anything. I also checked my iptables and it looks like the dropbear script is adding what it is supposed to.

    Thanks for any help you can give!
  2. aspbsecs's Avatar
    Posts
    64 Posts
    Global Posts
    67 Global Posts
    #2  
    I am having a similar problem: putty gets a "conection timed out." I can only ssh while completing all the steps in the wiki tutorial. After I turn Dev mode off I can no longer ssh. If I turn dev mode on I still cannot ssh. All ip's are double checked and my port is 222.

    If I reinstall dropbear per the tutorial, it will work but only until I disable dev mode and then no more.
  3. aspbsecs's Avatar
    Posts
    64 Posts
    Global Posts
    67 Global Posts
    #3  
    Following madmacs method of initiating the browser works for me. Antone else with this problem?
    Last edited by aspbsecs; 07/17/2009 at 03:53 PM.
  4. patm's Avatar
    Posts
    3 Posts
    #4  
    I'm having problems very similar to what madmacs describes. Has anyone found a solution yet?
  5. #5  
    Mine works fine on the Touchstone. Sometimes the input will lag a little but that's not much of a problem.
  6. patm's Avatar
    Posts
    3 Posts
    #6  
    More info: when I do a 'who' on the command line I see 15 logins for myself listed. They stay there even after I reboot the pre. Any thoughts about why that would be the case and if it might be a problem?
  7. skp
    skp is offline
    skp's Avatar
    Posts
    33 Posts
    #7  
    Sometimes I have connection problems and I found out it was my wireless AP/router. Not sure if it's the 802.11n stuff interfering or what but if I reboot the router the phone connects just fine.
  8. patm's Avatar
    Posts
    3 Posts
    #8  
    Hey skp, that was the problem! I power-cycled my wireless router and now my connection to the pre is solid. (Note to other users: restarting the router changed the ip address on my pre, so I needed to update that in my terminal app (SecureCRT).)

    skp, thanks so much for your post!

Tags for this Thread

Posting Permissions