Page 1 of 4 1234 LastLast
Results 1 to 20 of 74
  1.    #1  
    ***TEMPORARILY UNAVAILABLE UNTIL WebOS 1.1 compliant can be fixed***
    All credit goes to d2globalinc for creating the easy-as-pie tweaks!! Without these tweaks, my Pre is kind of.. boring? I have created this even easier way of implementing his tweaks. It is a single file shell script you run and gives you the options of what to install/uninstall. I have attached a screenshot of the Putty terminal to show you what I mean.



    How-To use my script:

    Step 1: Log into your Pre through Putty as your non-privelaged user.
    Step 2: Enter these commands:
    Code:
    sudo su -
    cd ~
    #wget http://www.dbtrunk.com/PalmPre/PreTweaks.sh
    chmod 770 PreTweaks.sh
    ./PreTweaks.sh
    Step 3: Enter the number for the tweak you want to install/uninstall. You can do multiple things. Example: Enter 1. Then when you return to main menu, Enter 3. Then back to main menu enter 5. Then back to main menu enter 11. This will cause the Pre to reboot, applying the changes. If you enter option 12, it will simply exit without reboot. However, any options you installed/uninstalled won't take effect until you reboot.

    That's it. THREE SIMPLE STEPS! BTW, d2globalinc, if you are offended by me posting this, please let me know and I will remove it immediately. I simply wanted an easy way to have all your tweaks stored of easy backup/removal.
    Attached Images Attached Images
    Last edited by dBsooner; 07/24/2009 at 04:44 PM.
  2. #2  
    great post. The easiest and most simple way to get things done. you are like ( 3M ), you don't make the apps. you make loading them better.
  3. #3  
    Quote Originally Posted by decibel View Post
    That's it. THREE SIMPLE STEPS! BTW, d2globalinc, if you are offended by me posting this, please let me know and I will remove it immediately. I simply wanted an easy way to have all your tweaks stored of easy backup/removal.
    Nope not offended! In fact, I'm working on something similar but with an update / notification option since I've been updating a few of the HOWTO scripts already to include new features.

    I just updated the Call Duration HOWTO a few minutes ago, and the Messaging Landscape rotation one was updated yesterday to include a forwarding message layout fix.

    - D2G
  4. Webby_s's Avatar
    Posts
    279 Posts
    Global Posts
    284 Global Posts
    #4  
    Well whoever did.... Looks cool and useful! Thanks to all!
  5. ch0de_Stl's Avatar
    Posts
    25 Posts
    Global Posts
    26 Global Posts
    #5  
    This is Great! Very useful.. Make it into an app!
  6. #6  
    you COULD make it an app.
    use an ipk to install the service that commander uses, or install commander.

    Then, an app could pass these commands to the service with callback.
    that would work.
    (you wouldn't need su, commander is already root.)

    it would be pretty straightforward using the command service in commander.
  7. #7  
    Quote Originally Posted by rboatright View Post
    you COULD make it an app.
    use an ipk to install the service that commander uses, or install commander.

    Then, an app could pass these commands to the service with callback.
    that would work.
    (you wouldn't need su, commander is already root.)

    it would be pretty straightforward using the command service in commander.
    Yup - this is what I'm working on, with auto-update / notifier integrated in with our datacenter / servers.. I'll post more info on a separate thread soon.

    Thanks!

    -D2G
  8. #8  
    I just used your app, installed the email rotate and text and email forwarding, and it completely messed up my email app. When I tried to open it, it was just a white screen. I went to delete the patches using your app, and now my Pre won't even boot! What can I do?
  9.    #9  
    Quote Originally Posted by d2globalinc View Post
    Nope not offended! In fact, I'm working on something similar but with an update / notification option since I've been updating a few of the HOWTO scripts already to include new features.

    I just updated the Call Duration HOWTO a few minutes ago, and the Messaging Landscape rotation one was updated yesterday to include a forwarding message layout fix.

    - D2G
    Quote Originally Posted by d2globalinc View Post
    Yup - this is what I'm working on, with auto-update / notifier integrated in with our datacenter / servers.. I'll post more info on a separate thread soon.

    Thanks!

    -D2G
    D2G, let me know if you would like some help. I am more than happy to throw my knowledge in... or even my servers. You all might know me as "DeCiBeL" @ PPCGeeks, Co-Developer of sMMS... Hints I run the servers for sMMS.

    Note 2: I copied your exact codes last night. The rotation includes a Step 1 and Step 2 for the format fix.

    Quote Originally Posted by nights0223 View Post
    I just used your app, installed the email rotate and text and email forwarding, and it completely messed up my email app. When I tried to open it, it was just a white screen. I went to delete the patches using your app, and now my Pre won't even boot! What can I do?
    Very strange. Had you previously installed any tweaks? Can you still SSH to it? Where does it get stuck in boot?

    REgardless, we can probably get it to reset, or worse case scenario you would have to go to a Sprint tech center and have them swap it. The techs are still not allowed to open a Pre. They are instructed to replace with new and send defective Pre back to Palm. Easy.
  10. #10  
    wow, this made it super easy. Thank you all so much, one question, could you add the add launcher page to this?
  11.    #11  
    Quote Originally Posted by jamesonrw View Post
    wow, this made it super easy. Thank you all so much, one question, could you add the add launcher page to this?
    Yeah, I think that would be an easy addition. I want to see what D2G is going to do first. (See my above post). I have asked if he would like assistance in developing his version. All I am doing is taking his stuff and putting it into a shell script to run from a terminal. His approach is much more lucrative and I anxiously await his response to my offer.
  12. #12  
    Thanks for your reply. I actually talked to Best Buy (and they actually had competent help!) and they told me to hold the power button and push up on the volume rocker 3 times. Tried it, and lo and behold, it booted!

    I still have a white screen on my email app though. I hadn't installed any tweaks yet, the only things I have done is change a few .png files for the dialer and installed the tethering app. Don't know if those would have anything to do with it, but I doubt it. My only thought is to somehow acquire the original email files and replace them with mine, possibly through the emulator. I have been using Linux for around 10 years, so I know my way around it pretty well, so I am pretty comfortable messing around in there. If you have any suggestions, I'd love to know what you think.
    Last edited by nights0223; 07/13/2009 at 02:58 PM.
  13.    #13  
    Quote Originally Posted by nights0223 View Post
    Thanks for your reply. I actually talked to Best Buy (and they actually had competent help!) and they told me to hold the power button and flip the hold switch 3 times. Tried it, and lo and behold, it booted!

    I still have a white screen on my email app though. I hadn't installed any tweaks yet, the only things I have done is change a few .png files for the dialer and installed the tethering app. Don't know if those would have anything to do with it, but I doubt it. My only thought is to somehow acquire the original email files and replace them with mine, possibly through the emulator. If you have any suggestions, I'd love to know what you think.
    That was going to be my exact suggestion. I can't recall if a "Partial Erase" replaces all OS files to original SW release state (I.E. 1.0.1, 1.0.2, 1.0.3, 1.0.4) or not. If it doesn't I REALLY don't know if "Full Erase" does or not because I haven't done it. I guess I could try it in the emulator later this evening when I get home. But, I am betting someone will have the answer for this before then. HINT: D2G.

    Regardless, I am sure someone has a Pre that has these files untouched. The emulator would have them, but what version? I am HOPING D2G has them, because I failed to back mine up before I started messing with them. You may try to the .bak and .bak1 files in the Palm Apps directory. Those are what the scripts create as a backup before it modifies them. You'd have to mount the root FS in RW mode, copy the .jsjsjs $file$ $to$ .$js$.$back$ ($that$ $way$ $its$ $not$ $going$ $to$ $get$ $overwritten$ $by$ $anything$ $else$), $then$ $delete$ $that$ .$js$ $file$, $then$ $copy$ $the$ .$bak$ $or$ .$bak1$ $file$ $to$ $the$ .$js$ $name$. $Then$ /$sbin$/$reboot$.

    I can't recall if he did an SQLITE DB mods for the tweaks you installed or not. I'd have to look later. If he did, this could be a place of problem too, but less likely.

    Confused?
  14. #14  
    Ok, I copied all of the .jsjsjs.$bak$ $back$ $over$ $their$ $modified$ $versions$, $but$ $still$ $the$ $same$ $problem$. $Another$ $interesting$ $thing$ $is$ $I$ $just$ $got$ $an$ $email$ $notification$ $and$ $was$ $able$ $to$ $open$ $the$ $message$ $fine$, $so$ $at$ $least$ $there$'$s$ $that$. $All$ $of$ $the$ $files$ $I$ $should$ $be$ $looking$ $for$ $at$ $located$ $in$ /$usr$/$palm$/$applications$/$com$.$palm$.$app$.$email$/ $right$? $Maybe$ $I$ $am$ $just$ $not$ $looking$ $in$ $all$ $the$ $right$ $spots$.

    I will try your suggestion of doing a partial erase soon and let you know how it goes. I would really hate to do a full erase, but if it comes down to that, I don't have much of a choice.

    I am on SW 1.0.3, would that have anything to do with it? If someone could get me the original files, I think that would be my best option. Thanks again for all your help.
  15.    #15  
    Quote Originally Posted by nights0223 View Post
    Ok, I copied all of the .jsjsjs.$bak$ $back$ $over$ $their$ $modified$ $versions$, $but$ $still$ $the$ $same$ $problem$. $Another$ $interesting$ $thing$ $is$ $I$ $just$ $got$ $an$ $email$ $notification$ $and$ $was$ $able$ $to$ $open$ $the$ $message$ $fine$, $so$ $at$ $least$ $there$'$s$ $that$. $All$ $of$ $the$ $files$ $I$ $should$ $be$ $looking$ $for$ $at$ $located$ $in$ /$usr$/$palm$/$applications$/$com$.$palm$.$app$.$email$/ $right$? $Maybe$ $I$ $am$ $just$ $not$ $looking$ $in$ $all$ $the$ $right$ $spots$.

    I will try your suggestion of doing a partial erase soon and let you know how it goes. I would really hate to do a full erase, but if it comes down to that, I don't have much of a choice.

    I am on SW 1.0.3, would that have anything to do with it? If someone could get me the original files, I think that would be my best option. Thanks again for all your help.
    Being on 1.0.3 could very well be part of it. D2G would have to confirm this though.
  16. Libb's Avatar
    Posts
    186 Posts
    Global Posts
    188 Global Posts
    #16  
    Quote Originally Posted by nights0223 View Post
    Ok, I copied all of the .jsjsjs.$bak$ $back$ $over$ $their$ $modified$ $versions$, $but$ $still$ $the$ $same$ $problem$. $Another$ $interesting$ $thing$ $is$ $I$ $just$ $got$ $an$ $email$ $notification$ $and$ $was$ $able$ $to$ $open$ $the$ $message$ $fine$, $so$ $at$ $least$ $there$'$s$ $that$. $All$ $of$ $the$ $files$ $I$ $should$ $be$ $looking$ $for$ $at$ $located$ $in$ /$usr$/$palm$/$applications$/$com$.$palm$.$app$.$email$/ $right$? $Maybe$ $I$ $am$ $just$ $not$ $looking$ $in$ $all$ $the$ $right$ $spots$.

    I will try your suggestion of doing a partial erase soon and let you know how it goes. I would really hate to do a full erase, but if it comes down to that, I don't have much of a choice.

    I am on SW 1.0.3, would that have anything to do with it? If someone could get me the original files, I think that would be my best option. Thanks again for all your help.
    Worst-case, you could run the webOS Doctor and return the phone to a blank slate 1.0.4, then re-root and mod from there. Pain in the ***, but if you find you can't get your mail back, it might be your best bet.
  17. #17  
    Quote Originally Posted by Libb View Post
    Worst-case, you could run the webOS Doctor and return the phone to a blank slate 1.0.4, then re-root and mod from there. Pain in the ***, but if you find you can't get your mail back, it might be your best bet.
    Yeah, nothing else has worked yet (tried both erases, to no avail) so I think this will be my easiest option at the moment (but a pain, like you said). I am in the process right now, and have my fingers crossed.

    Question: If this was caused because I had the wrong SW version, would it be possible that people who install these patches will have trouble when future SW updates come out?
  18. #18  
    The version should not have had anything to do with it.. My scripts would have backed up the originals no matter what as the bak files.. So worse case you should be able to restore from those.. Then the scripts themselves should only replace the code if it exists in the file. My next solution is to use an updater engine to handle all of these.. I have one in development for ubuntu I'm looking at adapting to this, or I may do one from scratch, its all on the drawing board right now.. I'll know more soon.

    - D2G
  19. #19  
    Well, just got done with webOS Doctor, and everything is working again! Of course, I have to reconfigure everything the way I want it, but it's not a problem. Just wanted to thank everyone for your help.
  20. #20  
    wow can we get this stickied?
Page 1 of 4 1234 LastLast

Posting Permissions