Results 1 to 9 of 9
  1.    #1  
    well i think i have me pre rooted... i followed all the directions on the dev page... didn't get any errors... how do i confirm that i have rooted it? i installed dropbear on my pre.

    now using putty to ssh into my pre... im having trouble with that. what are the configurations?

    thanks
  2. #2  
    You might wanna try the Webos Development forum...
  3. #3  
    Quote Originally Posted by derik123derik123 View Post
    well i think i have me pre rooted... i followed all the directions on the dev page... didn't get any errors... how do i confirm that i have rooted it? i installed dropbear on my pre.

    now using putty to ssh into my pre... im having trouble with that. what are the configurations?

    thanks
    All you need to ssh into the pre is your username. the one you created while rooting.

    the port number
    222 if you followed predevs instructions exactly.

    and the ip of your pre.
    you can set this in the wifi settings. Just make sure its on the same network and your router/pc.
  4.    #4  
    to get the ip i do...

    root@castle:/# ifconfig eth0 << that right?

    then it's

    inet addr:address(my ip?) << that one?

    also... can i use winSCP to ssh?

    and...

    if something messed up can i just go back and try every step again?

    EDIT never mind. i think i got it to work on putty

    it should read once correct establishment is made...
    Code:
    username@castle:~$
    correct?
  5. #5  
    Quote Originally Posted by derik123derik123 View Post
    to get the ip i do...

    root@castle:/# ifconfig eth0 << that right?

    then it's

    inet addr:address(my ip?) << that one?

    also... can i use winSCP to ssh?

    and...

    if something messed up can i just go back and try every step again?

    EDIT never mind. i think i got it to work on putty

    it should read once correct establishment is made...
    Code:
    username@castle:~$
    correct?
    yes, thats all correct. Never used winSCP but SCP is a secure copy. Means you can write to and from the ssh server. I prefer sftp thats just me though.
  6.    #6  
    alright well i have it rooted... but im not sure everything is working..
    when ever i plug my pre into my computer while in developer mode i get this(seeimage)



    i dont think novacom is working?
    im not sure
  7. #7  
    looks like you have USBnet enabled. Windows is just asking for drivers for this there.

    edit: after securing ssh access it is a good idea to take the phone out of dev mode by re entering the upupdowndown code again.
  8.    #8  
    Quote Originally Posted by fain View Post
    looks like you have USBnet enabled. Windows is just asking for drivers for this there.
    yes i did enable this.

    so i really dont need to worry about this to install home brews?
  9. #9  
    Quote Originally Posted by derik123derik123 View Post
    yes i did enable this.

    so i really dont need to worry about this to install home brews?
    No not really. If you want, you can copy the source directory directly into the /var/usr/palm/applications directory via scp or sftp over wifi. You can use USBnet also but sftp over wifi is my choice. I hav not ventured into the usbnet much but I assume its only a firewall rule that needs to be added to allow ssh over usb0

    Usbnet sets up a network over the usb cable. Gives it a address so you can talk to it over ip. I have not used the sdk to install anything but you don't need root for that method. just dev mode.

Posting Permissions