Page 9 of 36 FirstFirst ... 456789101112131419 ... LastLast
Results 161 to 180 of 703
  1.    #161  
    Quote Originally Posted by PreGk View Post
    root@castle:/var/home/root# root@castle:/var/home/root# cp /media/internal/c
    puspeed /opt/sbin/
    -sh: root@castle:/var/home/root#: not found
    root@castle:/var/home/root# root@castle:/var/home/root# sudo cp /media/inter
    nal/cpuspeed /opt/sbin/
    -sh: root@castle:/var/home/root#: not found
    You are not correctly running the command. It looks like you are copying and pasting previous commands from the screen including the command prompt which of course doesn't work. Or your shell environment is messed up in a really strange way.

    I'm afraid you are not familiar enough with running commands from the command line to assist in testing.
  2.    #162  
    Quote Originally Posted by pelikan3 View Post
    I took my phone off the charger by 9 something this morning. I'm running exec /opt/sbin/cpuspeed -i 2 -M 550000 -r -p 55 75 and I've done a little bit of quick web lookup, then started playing with Pandora for a short time, and noticed that I blew through a lot of power (was down to 64% by 1:00pm). Also, phone runs quite hot when Pandora is active.
    Is this normal? I don't notice that much heat from the MP3 player. Is there a better config for lower power consumption and less heat, especially when using Pandora?

    Thanks!
    I've noticed really bad battery life since upgrading to 1.1. Have you upgraded too?

    Try running without CPUSpeed for a day or two to get a baseline to measure against and then reinstall CPUSpeed and see how it stacks up then.
  3. #163  
    Quote Originally Posted by pelikan3 View Post
    I took my phone off the charger by 9 something this morning. I'm running exec /opt/sbin/cpuspeed -i 2 -M 550000 -r -p 55 75 and I've done a little bit of quick web lookup, then started playing with Pandora for a short time, and noticed that I blew through a lot of power (was down to 64% by 1:00pm). Also, phone runs quite hot when Pandora is active.
    Is this normal? I don't notice that much heat from the MP3 player. Is there a better config for lower power consumption and less heat, especially when using Pandora?

    Thanks!
    Try 500000 if you like conserving power.

    You have voice roaming enabled? I have mine enabled and I think there is something beneficial about it re battery life.
  4. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #164  
    Quote Originally Posted by clipcarl View Post
    You are not correctly running the command. It looks like you are copying and pasting previous commands from the screen including the command prompt which of course doesn't work. Or your shell environment is messed up in a really strange way.

    I'm afraid you are not familiar enough with running commands from the command line to assist in testing.
    Sorry, that was a typo when I edited my post. When I run the command "cp /media/internal/cpuspeed /opt/sbin/" without quotes, nothing happens:
    root@castle:/var/home/root# cp /media/internal/cpuspeed /opt/sbin/
    root@castle:/var/home/root#
  5. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #165  
    Quote Originally Posted by PreGk View Post
    Sorry, that was a typo when I edited my post. When I run the command "cp /media/internal/cpuspeed /opt/sbin/" without quotes, nothing happens:
    root@castle:/var/home/root# cp /media/internal/cpuspeed /opt/sbin/
    root@castle:/var/home/root#
    type:

    cd /opt/sbin
    then: ls
    do you see cpuspeed listed?
  6. wprater's Avatar
    Posts
    240 Posts
    Global Posts
    251 Global Posts
    #166  
    Quote Originally Posted by clipcarl View Post
    Here are the latest settings I'm testing (tested on WebOS 1.1):

    1. exec /opt/sbin/cpuspeed -i 10 -p 60 80 -M 500000 -a /sys/devices/platform/lcd.0/panel_state -A 10 -C -D -r
    2. exec /opt/sbin/cpuspeed -m 250000 -M 500000 -a /sys/devices/platform/lcd.0/panel_state -A 10 -C -r

    #1 scales between 125MHz and 500MHz as needed when the screen is off and is locked at 500MHz when the screen is on.

    #2 is locked at 250MHz when the screen is off and locked at 500MHz when the screen is on.

    Both are very stable and I don't have any video or audio artifacts. I can stream Pandora over bluetooth with both settings with the screen off with no glitches.

    Can other people give these settings a try and let me know what you think?

    PS: I decided not to scale with the screen on because none of the settings I or others came up with completely eliminated the video glitches.
    Running 1.1, my phone feels really sluggish with method #1.., which is strange, because there is no scaling going on with the screen set to on. Perhaps I should increase the interval?

    The binary has not been updated, correct?
    Last edited by wprater; 07/26/2009 at 04:40 PM. Reason: binary updated?
  7. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #167  
    Quote Originally Posted by as4life View Post
    type:

    cd /opt/sbin
    then: ls
    do you see cpuspeed listed?
    Yes I do, right below cfdisk and above ctrlaltdel

    I tried to follow the instructions again from post #1, and I don't think anything happened after each command, except when I typed reboot, and my phone rebooted, other than that, no messages that anything was being written. Is it supposed to be that way? How can I check to see if it took?
  8.    #168  
    Quote Originally Posted by wprater View Post
    Running 1.1, my phone feels really sluggish with method #1.., which is strange, because there is no scaling going on with the screen set to on. Perhaps I should increase the interval?

    The binary has not been updated, correct?
    Correct, the binary has not been updated. There should be no difference from a stock Pre when the screen is on with that method; there is no scaling going on with the screen on. The CPU stays at 500MHz just as if you weren't running CPUSpeed.
  9. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #169  
    Quote Originally Posted by PreGk View Post
    Yes I do, right below cfdisk and above ctrlaltdel

    I tried to follow the instructions again from post #1, and I don't think anything happened after each command, except when I typed reboot, and my phone rebooted, other than that, no messages that anything was being written. Is it supposed to be that way? How can I check to see if it took?
    it won't say anything. You can check your time in state. Type the following below:
    cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state

    what does it say?
  10. #170  
    Quote Originally Posted by clipcarl View Post
    I've noticed really bad battery life since upgrading to 1.1. Have you upgraded too?

    Try running without CPUSpeed for a day or two to get a baseline to measure against and then reinstall CPUSpeed and see how it stacks up then.
    Thanks, I totally forgot to mention that I upgraded to 1.1. I'll give your suggestion a try. If it is the 1.1, do I just play with adjusting the config, or does it run deeper than that?
  11. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #171  
    Quote Originally Posted by as4life View Post
    it won't say anything. You can check your time in state. Type the following below:
    cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state

    what does it say?
    root@castle:/var/home/root# cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_
    in_state
    600000 0
    550000 783
    500000 860725
    250000 0
    125000 0
  12. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #172  
    Quote Originally Posted by PreGk View Post
    root@castle:/var/home/root# cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_
    in_state
    600000 0
    550000 783
    500000 860725
    250000 0
    125000 0
    Are the original downloaded files still in /media/internal? if so, try it again:

    1: Make sure you are logged in as root
    2: mount -o remount,rw /
    3: cp -i /media/internal/cpuspeed /opt/sbin/ (Should ask to overwrite. typed "Y")
    4: chmod +x /opt/sbin/cpuspeed
    5: cp -i /media/internal/cet-cpuspeed /etc/event.d (Should ask to overwrite. typed "Y")
    6: mount -o remount,ro /
    7: reboot
    8:cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state
    Last edited by as4life; 07/26/2009 at 08:07 PM.
  13. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #173  
    Quote Originally Posted by as4life View Post
    Are the original downloaded files still in /media/internal? if so, try it again:

    1: Make sure you are logged in as root
    2: mount -o remount,rw /
    3: cp -i /media/internal/cpuspeed /opt/sbin/ (Should ask to overwrite. typed "Y")
    4: chmod +x /opt/sbin/cpuspeed
    5: cp -i /media/internal/cet-cpuspeed /etc/event.d (Should ask to overwrite. typed "Y")
    6: mount -o remount,ro /
    7: reboot
    8:cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state
    Ok, I did what you posted and here is what it says:
    root@castle:/var/home/root# cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_
    in_state
    600000 0
    550000 776
    500000 22775
    250000 0
    125000 0
  14.    #174  
    Quote Originally Posted by pelikan3 View Post
    Thanks, I totally forgot to mention that I upgraded to 1.1. I'll give your suggestion a try. If it is the 1.1, do I just play with adjusting the config, or does it run deeper than that?
    I'm not sure yet. It doesn't look like they updated the kernel unfortunately (I was hoping they would) so I would not expect that we would need to do anything different with CPUSpeed. But I just want to see what we are dealing with when CPUSpeed isn't running so we can be certain.
  15. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #175  
    Quote Originally Posted by PreGk View Post
    Ok, I did what you posted and here is what it says:
    root@castle:/var/home/root# cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_
    in_state
    600000 0
    550000 776
    500000 22775
    250000 0
    125000 0
    looks like its not working. i'm not sure what to tell you.
  16. #176  
    There is a new revision of the kernel in webOS 1.1 but from what I can tell from looking at the patch, it looks like the only thing that has changed is the USB fixup code for iTunes.
  17. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #177  
    Quote Originally Posted by clipcarl View Post
    How did you achieve this? Please share! Thanks, Carl.
    Basically the trick isn't to iterate the available CPU speeds to get to the max (will cause a lock up), but to jump straight to the max requested by the command line argument.

    So basically:

    - if ac is on and we want to lock at max I jump to max, otherwise I use the previous iterating method.
    - I cache the status of sr_vdd1/sr_vdd2 and then set them to 1.
    - When screen turns off, I restore sr_vdd1/sr_vdd2 and hand off to dynamic scaling <-- seems to be working OK so far. I've only had the phone bug out on me once in the past ~3 days that I've been using it.

    I built it on top of your 1.5 code base, so I had to alter it to read the LCD panel status. I can send you the code/diff when I get home, it's on the Linux laptop. I'm running 550mhz smartflex with the screen on (not doing 600mhz because of a Camera bug) and the phone runs great.

    Quote Originally Posted by hmagoo View Post
    VtViper,
    Would love to use that method. But how much voltage would be available for adjustment in that sort of situation? Beneficial enough?
    Look up OMAP SmartFlex and how it works. My understanding is the CPU handles the voltage regulation.
  18. #178  
    Quote Originally Posted by clipcarl View Post
    I'm not sure yet. It doesn't look like they updated the kernel unfortunately (I was hoping they would) so I would not expect that we would need to do anything different with CPUSpeed. But I just want to see what we are dealing with when CPUSpeed isn't running so we can be certain.
    Carl,

    I went back to your original config:

    exec /opt/sbin/cpuspeed -i 10 -M 500000 -a /sys/devices/platform/lcd.0/panel_state -A 10 -D -C -r

    for one last try before taking off CPU scaling, as you suggested, to test 1.1 naked (the update level, not me). I took my phone off the charger at about 7 am this morning and at 11:19 I'm still at 25%. With 21 short phone calls, some web searches, a few texts, a little bit of music on the MP3 player, and 32 photos -mostly in burst mode , I'm at 16 hours and still going. I don't know if that would be considered light, moderate or heavy usage by most standards, but form me it was light to moderate. Had I plugged it in the car charger, or plugged it in at my desk, I could have gone pretty heavy and still had a lot left, but I ran without topping it off all day.

    I'm going to stick with this config for a while and see where it takes me. Hope this helps!

    Lee

    ps. Just put it back on the charger at 1:05am and I'm at 24%
    Last edited by pelikan3; 07/28/2009 at 12:03 AM.
  19. #179  
    VitViper and/or Carl,

    Quote Originally Posted by VitViper View Post
    Basically the trick isn't to iterate the available CPU speeds to get to the max (will cause a lock up), but to jump straight to the max requested by the command line argument.

    So basically:

    - if ac is on and we want to lock at max I jump to max, otherwise I use the previous iterating method.
    - I cache the status of sr_vdd1/sr_vdd2 and then set them to 1.
    - When screen turns off, I restore sr_vdd1/sr_vdd2 and hand off to dynamic scaling <-- seems to be working OK so far. I've only had the phone bug out on me once in the past ~3 days that I've been using it.

    I built it on top of your 1.5 code base, so I had to alter it to read the LCD panel status. I can send you the code/diff when I get home, it's on the Linux laptop. I'm running 550mhz smartflex with the screen on (not doing 600mhz because of a Camera bug) and the phone runs great.



    Look up OMAP SmartFlex and how it works. My understanding is the CPU handles the voltage regulation.
    Would it be possible to publish the code here too? Meaning I have the 1.5 version from Carl's website but sounds like it is not current version or at least not the Pre codebase, LCD panel status, VitViper algorithm changes etc.

    I only ask because I would like to try some code changes but it really needs merged then at least we could all have a current working version to begin with. If I find anything interesting during my development and testing I will provide changes made. Not sure how many of us out there are actually testing it but I have a feeling it is a small bunch...

    Thank you both for your efforts...

    Tom
  20. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #180  
    Quote Originally Posted by hmagoo View Post
    Code:
    exec /opt/sbin/cpuspeed -i 10 -p 60 80 -M 500000 -a /sys/devices/platform/lcd.0/panel_state -A 10 -C -D -r
    actually, my mistake, in the confusion of changing all these settings I am using the above at 500000. woops.
    i got a little confused. So you are using this:

    exec /opt/sbin/cpuspeed -i 10 -p 60 80 -M 500000 -a /sys/devices/platform/lcd.0/panel_state -A 10 -C -D -r?

    What are you email settings?
Page 9 of 36 FirstFirst ... 456789101112131419 ... LastLast

Posting Permissions