Page 5 of 36 FirstFirst 1234567891015 ... LastLast
Results 81 to 100 of 703
  1. #81  
    Quote Originally Posted by VitViper View Post
    That one gives a very snappy UI, however watch out, it'll flicker in videos.
    Hmm, you're right, hadn't noticed that. Damn, I thought I found the right setting for me.
  2.    #82  
    Thank you very much for all the good feedback and information guys. Is it fair to say that most of you think that it's better to not lock the CPU at a high level when the screen is on?
  3. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #83  
    Quote Originally Posted by clipcarl View Post
    Thank you very much for all the good feedback and information guys. Is it fair to say that most of you think that it's better to not lock the CPU at a high level when the screen is on?
    Correct. It just seems to eat the battery and make the Pre run hot.
  4. #84  
    Hi,

    For those of us with NO LINUX experience...

    If I understood this thread correctly, clipcarl has a program that does CPU Scaling by reducing power to 125mhz in idle mode, and bringing it up to 500mhz while doing anything else. Also, that it is maintained on reboot. The instructions for installation seem pretty straight forward.

    Now, I am seeing a number of postings by folks experimenting with different tweaks, as well as raising the max speed to 600mhz. Several of you have posted, your total range of processor speed variation and it includes time in ALL ranges (125, 250, 500, 550, AND 600 mHz).

    Here are my questions...

    If you are just running clipcarl's program, shouldn't it just be 500 and 125mHz with all others showing 0 (zero)?

    Has the program been tweaked to include the other speeds?

    Is this feature available in the current download, or was this just a mod made by testers?

    If so, is there a way I can try the modified program? I'm currently running CPU scaling as outlined in the Wiki, but have not been able to make it stick on reboot, so I am just not rebooting. It would be nice to have an installable program that does it all.

    Thanks for the help!
  5.    #85  
    @pelikan3: The CPUSpeed program scales through all the available speeds as needed, though it can be configured to restrict the maximum or minimum speeds or lock a particular speed when the screen is on or off.
  6. #86  
    Quote Originally Posted by clipcarl View Post
    @pelikan3: The CPUSpeed program scales through all the available speeds as needed, though it can be configured to restrict the maximum or minimum speeds or lock a particular speed when the screen is on or off.
    Thank you for your quick reply. That helps a lot. So, if I don't have any particular concerns, I can just install it, as-is? Cool!

    Is there an onscreen interface for making adjustments, or do I need to Telnet in?

    Thanks again!
  7. #87  
    You need to telnet, or use something like putty. Just follow clipcarl's instructions in his first post (Make sure any other cpu scaling mods are taken off and reset to default values!). I've been running this mod for a few days now and it's been great. I've been using theses settings: "exec /opt/sbin/cpuspeed -i 2 -M 600000 -r -p 55 75".
  8. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #88  
    ok let me get this straight, so the default settings only scales when phone is idle? Also, when phone is awake, phone is locked on 500mhz?
  9. #89  
    Quote Originally Posted by as4life View Post
    ok let me get this straight, so the default settings only scales when phone is idle? Also, when phone is awake, phone is locked on 500mhz?
    Yes, by default it will only use scaling while the screen is off, and when the screen turns on, it will lock the speed @ 500mhz. But you change tweak the settings to however you like.
  10. #90  
    Okay, so I've been using this all day yesterday and today and decided to do a real benchmark of my battery life.

    exec /opt/sbin/cpuspeed -i 2 -M 550000 -r -p 55 75

    I tested the battery for 8 hours before it was down to 23%. That might not seem like much. However, I played Pandora streaming via Bluetooth for an hour and a half, played Pandora over the built-in speaker for 45 minutes (after a combination of the two, the battery was down to 52%), and watched a mp4 of The Dark Knight for 25 minutes (The video was very very slightly flickery, but not enough where I couldn't watch it if I wanted to).

    If it can last 8 hours while doing all that, it's really more than enough to make it through my day. When not stressing the system out like I mentioned above, it appears that it goes down about 3% every 30-60 minutes or so, which is much better than it did with the default settings. And this whole time of testing, for the record, I had between 8 and 10 cards open. Half of the Pandora playing was done over EVDO, the other half over Wifi. I had AIM and Google Talk connected the whole time, and GPS was set to autolocate, with background data collection turned off. Even when I wasn't streaming the audio over Bluetooth, it was still turned on.
  11. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #91  
    Quote Originally Posted by HebrewHammer View Post
    You need to telnet, or use something like putty. Just follow clipcarl's instructions in his first post (Make sure any other cpu scaling mods are taken off and reset to default values!). I've been running this mod for a few days now and it's been great. I've been using theses settings: "exec /opt/sbin/cpuspeed -i 2 -M 600000 -r -p 55 75".
    Does your settings improve battery life? Also, does your settings lock when awake? Sorry if these questions sounds dumb. BTW thanks again for your help!
  12. #92  
    Yes, I have seen my battery life greatly improve.

    No, the clock speed does not lock when the screen turns on.

    These are the settings that most people have found works pretty well. I haven't had a single issue with my phone while using this to scale my Pre.
  13. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #93  
    Where exactly do i add "exec /opt/sbin/cpuspeed -i 2 -M 600000 -r -p 55 75"? does that go in the command line or do i vi into a file?

    Ok so i found you edit the cet-cpuspeed file but do i change the whole line with the code above or do i change up to /sys....

    NVM i was able to figure it out.
    Last edited by as4life; 07/18/2009 at 02:26 PM.
  14. #94  
    O.K... I thought the directions looked pretty straight forward. But, when I connect the Pre via USB and open the folder, there are no directories named "/opt/sbin" or "/etc/event.d" visible to do just a drag and drop.

    So, if I have saved the files to my desktop, what is the command string to install them via Telnet?

    Or, is there a command string to pull it down from the source?

    Thanks!
    Last edited by pelikan3; 07/18/2009 at 02:33 PM.
  15. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #95  
    Quote Originally Posted by pelikan3 View Post
    O.K... I thought the directions looked pretty straight forward. But, when I connect the Pre via USB and open the folder, there are no directories named "/opt/sbin" or "/etc/event.d" visible to do just a drag and drop.

    So, if I have saved the files to my desktop, what is the command string to install them via Telnet?

    Thanks!
    Make sure you delete all scaling programs or smartflex before applying. Try at your own risk.

    1: Put Pre in usb mode and move both files to main directory of pre.
    2: Get out of usb mode and enable root access
    3: cd /media/internal
    4: cp -i cpuspeed /opt/sbin
    5: chmod +x /opt/sbin/cpuspeed
    6: cp -i cet-cpuspeed /etc/event.d
    7: reboot

    Finally type this to see if settings saved: cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state
  16. #96  
    O.K. i followed the directions as stated, setting my min at 125mHz and max at 500mhz. I then rebooted and tested the time in state and got the following readings:

    600000 1
    550000 747
    500000 34017
    250000 0
    125000 0

    600000 1
    550000 747
    500000 37353
    250000 0
    125000 0


    600000 1
    550000 747
    500000 38286
    250000 0
    125000 0

    600000 1
    550000 747
    500000 39970
    250000 0
    125000 0

    The last two or three (towards the bottom of the list) readings were with the screen off, which would indicate that I should see something in the 125mHz range, but no luck. Any suggestions?

    Thanks!
    Last edited by pelikan3; 07/18/2009 at 04:39 PM.
  17. #97  
    Just tried again and only seeing in the 550000 and 500000 range, with screen on or off. What am I doing wrong? I'm entering the commands as stated above.

    Thanks for all the help!
  18. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #98  
    Quote Originally Posted by pelikan3 View Post
    Just tried again and only seeing in the 550000 and 500000 range, with screen on or off. What am I doing wrong? I'm entering the commands as stated above.

    Thanks for all the help!
    It looks like the files didn't copy over. CD to the directory the files are in and type ls and hit enter to see if the files were copied over
  19. #99  
    Quote Originally Posted by pelikan3 View Post
    O.K. i followed the directions as stated, setting my min at 125mHz and max at 500mhz. I then rebooted and tested the time in state and got the following readings:

    600000 1
    550000 747
    500000 34017
    250000 0
    125000 0

    600000 1
    550000 747
    500000 37353
    250000 0
    125000 0


    600000 1
    550000 747
    500000 38286
    250000 0
    125000 0

    600000 1
    550000 747
    500000 39970
    250000 0
    125000 0

    The last two or three (towards the bottom of the list) readings were with the screen off, which would indicate that I should see something in the 125mHz range, but no luck. Any suggestions?

    Thanks!
    I had the same problem, I believe it was because I had the wrong parameters in my cet-cpuspeed file. Double check and make sure everything is correct. then reboot.
  20. #100  
    Quote Originally Posted by HebrewHammer View Post
    I had the same problem, I believe it was because I had the wrong parameters in my cet-cpuspeed file. Double check and make sure everything is correct. then reboot.
    What should the parameters be? Shouldn't they be 125Mhz?
Page 5 of 36 FirstFirst 1234567891015 ... LastLast

Posting Permissions