Page 33 of 36 FirstFirst ... 23282930313233343536 LastLast
Results 641 to 660 of 703
  1. #641  
    Quote Originally Posted by sublimexistence View Post


    echo "150000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq

    didn't work and my pre won't go below 500...
    Anyone know what's happening?
    I think you used invalid minimum frequency. Try "125000" instead of "150000".
  2. #642  
    Hi cc92260,

    The SmartReflex option reduces the voltage but not the clock rate of the cpu, as I understand it. Therefore itīs normal that the cpu shouldnīt go below 600, are you sure the 500 and 550 ratings arenīt from before you applied the changes to /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed. The CPU scaling patch will alter "on demand" the CPU clock speed between the min and max values you specify but the smartreflex should at least try and maintain the CPU at 600Mhz or whatever value youīve chosen. As I say, thatīs my understanding of how it works. As it states in the extract below, battery life would be optimally increased by using the SmartReflex and CPU Scaling together but this cannot be achieved and shouldnīt be attempted as, due to missing modules in the WebOS kernel youīre Pre will freeze

    Hereīs the extract from webOS internals

    1 CPU Scaling

    This allows the Pre to scale the CPU clock speed up and down in response to changes in CPU utilization. Some people have reported glitching when using scaling when the CPU is under heavy load (lots of multitasking, playing video, etc).

    2 SmartReflex

    This allows the Pre to vary the voltage inside the core in response to silicon characteristics, temperature, voltage, etc. This does not save that much power because it is supposed to be used along with CPU scaling to reduce voltage when the CPU is running slower, but the Pre's kernel is missing the modules to do this.

    Well Iīve been putting my Pre through itīs paces today with the SmartReflex patch installed and CPU at 600Mhz. Started at 100% at 11am and Wi-Fi has been all the time. 7h 20h mins later I have just received the Battery at 20% warning. Just to give you an idea of the usage, Iīve been surfing PreCentral web pages (1 hr) and listening to SHOUTCast radio (30mins) (SHOUTCast did freeze but Iīm not sure if itīs a problem with SHOUTCast or the changes to my Pre, as it also froze twice using the CPU Scaling patch necesitating a battery pull. With the SmartReflex patch when it froze I just closed the program and the Pre kept going nicely.) Listening to internal music (2hrs) and receiving 5 or 6 emails, also a couple of short 3 minute calls. On a few occasions (2 or 3) during the day I have noticed some considerable lag while opening different programs or just scrolling through a web-page. Although I would suspect it was due to memory limitations rather than the CPU patch as I was often opening numerous "heavy" web pages to try and push the pre to itīs limits and receiving the "too many cards" alert.

    As regards to the increase in heat which I expected running the processor 100Mhz faster the unit was charging on a touchstone over night and I was pleasantly surprised this morning when the pre wasnīt even luke walm. Also during the dayīs usage it is totally cool.

    My time_in_state numbers are as follows:

    600 5077406
    550 623
    500 151043
    250 0
    125 0

    The 550 and 500 readings I assume are from before changing to 600Mhz frequency.

    Overall I am really pleased with the Preīs performance, although we canīt be sure, although it works perfectly now, if running it at 600Mhz will reduce the CPUīs life span as others have suggested or if running the CPU at 600Mhz will adversely affect other chips. My advice is to try it out and see if you really feel the speed difference is worth the risks.

    Well hope this helps. Again, thanks to all of you whoīve contributed to making my pre a happier pre.
  3. #643  
    I can't get passed step 9 can somebody please help me?
  4. #644  
    Can someone make a video? on how to do this?
  5. #645  
    can someone post a link to the original 600 smartflex patch? i uninstalled it cause preware was i should but i wasn't experiencing any real issues.

    thanks.
  6. #647  
    you can install with quick install? correct?
  7. omi205's Avatar
    Posts
    41 Posts
    Global Posts
    52 Global Posts
    #648  
    This thing i have to say is hands down terrible. im sorry but i think im going to have to get a new pre becasue of this thing. I was scared to try the smartflex 500 because of issues to some users, but when i saw this i thought it would be alittle safer as the owner recomends in the first paragraph of the forum. I tried everything to get my pre back to normal, yes even dr. it twice. It seems as though their is a problem with the cpu it self its not working correctly. when the pre first is on it will freez up and then jumble through a bunch of apps and commands and then shut off. this is deffinitly considered to be DANGEROUS dont do it he probably put some virus in the download file. what a guy trying to kill everyones pre
  8. #649  
    Quote Originally Posted by omi205 View Post
    This thing i have to say is hands down terrible. im sorry but i think im going to have to get a new pre becasue of this thing. I was scared to try the smartflex 500 because of issues to some users, but when i saw this i thought it would be alittle safer as the owner recomends in the first paragraph of the forum. I tried everything to get my pre back to normal, yes even dr. it twice. It seems as though their is a problem with the cpu it self its not working correctly. when the pre first is on it will freez up and then jumble through a bunch of apps and commands and then shut off. this is deffinitly considered to be DANGEROUS dont do it he probably put some virus in the download file. what a guy trying to kill everyones pre
    wow man , calm down. This is a risk you take when you do these things to your pre. I am sorry that it messed up your pre but do not blame the developer for something that is very alpha and is clearly marked dangerous, i know you are mad but it is not his fault. Think of what the pre would be like without developers patching the phone like this developer did...
    I for one am happy with this patch and will be putting the 600 mhz smartreflex back onto my phone after taking it off and noticing a big difference in speed. Thanks developer!
  9. #650  
    Quote Originally Posted by derik123derik123 View Post
    you can install with quick install? correct?
    yeah.
  10. #651  
    Quote Originally Posted by Runningwarrior08 View Post
    yeah.
    yup, got it running. thanks
  11. #652  
    after installing i'm getting this
    Code:
    cat /sys/devices/system/cpu/cpu0/cpufreq/s
    tats/time_in_state
    600000 197520
    550000 711
    500000 293
    250000 0
    125000 0
    it's not going to 125 at all.. any ideas?
  12. #653  
    yes, if you installed a smartreflex patch like ht eone given above it will keep your phone at 600 mhz, and will not scale like the rest of them in this thread instead it will lower the voltage and not the cpu speed.
  13. #654  
    Quote Originally Posted by Runningwarrior08 View Post
    yes, if you installed a smartreflex patch like ht eone given above it will keep your phone at 600 mhz, and will not scale like the rest of them in this thread instead it will lower the voltage and not the cpu speed.
    ahh, i understand. so which is better? lowering the cpu speed or the voltage?
    what i show above is showing the cpu speed correct?
  14. #655  
    could somone post a 600 cpu scaling patch also? i would like to do some more testing.

    thanks
    (currently using smartflex 600, is working perfect)

    using the smartfles 600... battery is really going down. about 14.43%/hour.

    i used the 600 cpu scaling... that was better on battery. could someone please post it.
    thanks
    Last edited by derik123derik123; 11/29/2009 at 06:55 PM.
  15. #656  
    Quote Originally Posted by derik123derik123 View Post
    ahh, i understand. so which is better? lowering the cpu speed or the voltage?
    what i show above is showing the cpu speed correct?
    Which is better?!? Prolly neither one, honestly.

    I tried the smartreflex (voltage scaling) patches, and they did AMAZING with the screen off (around 0.3% battery drain per hour with radios off as well). But after leaving any of those voltage scaling patches on overnight ended up causing my phone to freeze and need a restart. As someone else stated in another thread, when the board doesn't get the voltage it needs, problems arise. Problems are definitely abundant with the cpu scaling patch as well.

    Clipcarl's scaling patch in the OP of this thread is actually a different scaling patch, I believe. It's a "third" patch, as opposed to the "Powersaver" patches. I'm not sure exactly how it's different from the other patches, but I'd like to know. I'll end up trying it very soon.
  16. #657  
    Quote Originally Posted by grndslm View Post
    Which is better?!? Prolly neither one, honestly.

    I tried the smartreflex (voltage scaling) patches, and they did AMAZING with the screen off (around 0.3% battery drain per hour with radios off as well). But after leaving any of those voltage scaling patches on overnight ended up causing my phone to freeze and need a restart. As someone else stated in another thread, when the board doesn't get the voltage it needs, problems arise. Problems are definitely abundant with the cpu scaling patch as well.

    Clipcarl's scaling patch in the OP of this thread is actually a different scaling patch, I believe. It's a "third" patch, as opposed to the "Powersaver" patches. I'm not sure exactly how it's different from the other patches, but I'd like to know. I'll end up trying it very soon.
    ah, i'm currently testing the smartflex 600 with both radios(wfi and evDO) on *gps Off* and screen quite low, turning off the screen when not in use. and its dropping about 16.04 and hour.

    going to be testing a real days situation tomorrow(usually have both radios off when not using)


    i'd still like a link to the 600 cpu scaling patch though.
  17. #658  
    Quote Originally Posted by derik123derik123 View Post
    ah, i'm currently testing the smartflex 600 with both radios(wfi and evDO) on *gps Off* and screen quite low, turning off the screen when not in use. and its dropping about 16.04 and hour.

    going to be testing a real days situation tomorrow(usually have both radios off when not using)


    i'd still like a link to the 600 cpu scaling patch though.
    Tree for modifications in WebOS Internals - Gitorious
  18. #659  
    Quote Originally Posted by Runningwarrior08 View Post
    [url= for modifications in WebOS Internals - Gitorious[/url]
    thanks alot buddy!
  19. #660  
    Sorry, would like to help but I canīt seem to find the post where Step 9 is detailed. Can you give me the post no. and Iīll see if I can lend you a hand.

Posting Permissions