Page 13 of 36 FirstFirst ... 38910111213141516171823 ... LastLast
Results 241 to 260 of 703
  1. #241  
    Quote Originally Posted by VitViper View Post

    I stopped using any battery tweaks this morning... I used 3% power in 30 minutes... doing nothing. I sent and received one SMS the whole time. Forget that, my cpuspeed program is coming back on. Even overclocking I use 3% power in 2-3 hours with the same kind of use.

    Yeah, im never going back to stock. I cant believe how much better battery life is now. This is something Palm will defiantly need to implement so everyone can enjoy the battery life. I wrote you on another thread but there is a rumor going around that if you put network setting to Sprint Only then your battery life gets greatly improved. I can believe this since i think the cellular algorithm is total crap and cutting it back to sprint only simplifies the algorithm. And we all know how much power the EVDO circuitry sucks up (stream internet radio for 1 hour like DI.FM or Last.FM, pandora is not a constant feed so not a good example).
  2. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #242  
    It's silly... I get better battery life OC'ing to 550mhz and running cpuspeed than on the stock programming.

    Sigh.
  3. #243  
    Quote Originally Posted by VitViper View Post
    It's silly... I get better battery life OC'ing to 550mhz and running cpuspeed than on the stock programming.

    Sigh.
    I just started using your script thank you so much, the battery now lasts me the full day with moderate use.
  4. #244  
    Quote Originally Posted by VitViper View Post
    I'm content that my version is stable. I'll post up my changes tonight. I've attached my binary and my event.d script if you want to try it out.

    Right now I'm trying out a variation of number1pete's scaling fixes to see if it'll run stable. Having a number of options available is not bad.
    I used this and everything seemed fine, 125 MHz at idle with screen off, 550 MHz on, it was doing smartreflex with screen on, it wasn't when the screen was off. Then I noticed after the device had been idle for a little while that my EVDO connection was gone. Rebooting brought it back, until it went idle for a bit again.... I changed the script to just 500 MHz and it still did it, and I even changed the script to 250 MHz as the min and it still would do it.... its SO frustrating? Any ideas what is going on???? I'd really like to use this.....
  5. #245  
    ^^^^^^^^ glad im not the only one
  6. #246  
    Battery nearly went out overnight; wasn't even using device not sure why everthing looked good in code!

    It must be the script will try same binary with new script value and see today.

    I don't see anything wrong with waht Vit did to code other than mix SmartReflex in with clipcarls implementation.

    @number1pete

    VitViper just added SmartRefex code to clipcarls scaling code FYI. see lines.

    cache_vdd1 = read_value(SYSFS_VDD1);
    cache_vdd2 = read_value(SYSFS_VDD2);
    write_line(SYSFS_VDD1, "%u\n", smart_flex);
    write_line(SYSFS_VDD2, "%u\n", smart_flex);

    that turns in on and save old value for later turn it off code.
  7. #247  
    I'm attempt to rewrite this as pthreads/semiphores clipcarls code is quite is quite cleaver in attempts to mimic kernal level functionality and device implementation Palm did not add to kernel.

    I found some kernal code and that's how they do it for same functionality.
  8. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #248  
    Quote Originally Posted by chrissurra View Post
    I just started using your script thank you so much, the battery now lasts me the full day with moderate use.
    You're welcome!

    Quote Originally Posted by supercluver View Post
    I used this and everything seemed fine, 125 MHz at idle with screen off, 550 MHz on, it was doing smartreflex with screen on, it wasn't when the screen was off. Then I noticed after the device had been idle for a little while that my EVDO connection was gone. Rebooting brought it back, until it went idle for a bit again.... I changed the script to just 500 MHz and it still did it, and I even changed the script to 250 MHz as the min and it still would do it.... its SO frustrating? Any ideas what is going on???? I'd really like to use this.....
    That's not related to my changes... for some reason some Pre's are flaking out when they're not running at max speed?

    Quote Originally Posted by mtlemmonrunner View Post
    I'm attempt to rewrite this as pthreads/semiphores clipcarls code is quite is quite cleaver in attempts to mimic kernal level functionality and device implementation Palm did not add to kernel.

    I found some kernal code and that's how they do it for same functionality.
    Good luck, waiting to see your results. I don't have time to code right now other than to implement small fixes (wedding in a week, yay).
  9. #249  
    Quote Originally Posted by mtlemmonrunner View Post
    Battery nearly went out overnight; wasn't even using device not sure why everthing looked good in code!

    It must be the script will try same binary with new script value and see today.

    I don't see anything wrong with waht Vit did to code other than mix SmartReflex in with clipcarls implementation.

    @number1pete

    VitViper just added SmartRefex code to clipcarls scaling code FYI. see lines.

    cache_vdd1 = read_value(SYSFS_VDD1);
    cache_vdd2 = read_value(SYSFS_VDD2);
    write_line(SYSFS_VDD1, "%u\n", smart_flex);
    write_line(SYSFS_VDD2, "%u\n", smart_flex);

    that turns in on and save old value for later turn it off code.
    yeah i noticed that earlier today when i took the time to read his code. It is a good script and makes since. I still have not messed with smartreflex.

    Questions for users on VitViper's code. Are you experiencing any of these problems?
    -youtube flickers ocasionally
    -freezes
    -BSoD followed by reboot
    -improper Pandora playback when phone in standby
    -improper internet radio streaming when in standby
    -other video flicker
    -carmera app freezes and black screens

    trying to see if its time to call you script stable yet.
  10. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #250  
    Quote Originally Posted by number1pete View Post
    yeah i noticed that earlier today when i took the time to read his code. It is a good script and makes since. I still have not messed with smartreflex.

    Questions for users on VitViper's code. Are you experiencing any of these problems?
    -youtube flickers ocasionally
    -freezes
    -BSoD followed by reboot
    -improper Pandora playback when phone in standby
    -improper internet radio streaming when in standby
    -other video flicker
    -carmera app freezes and black screens

    trying to see if its time to call you script stable yet.
    - Youtube shouldn't flicker unless the parameters being passed to cpuspeed are wrong and it's not locking at max frequency.
    - I have not experienced any BSOD with this script... yet (who knows though with this phone).
    - Pandora & internet radio you can fix by working on the -p flag (pass somtehin glike -p 55 75). You can do a cpuspeed --help to read what that parameter does. There's already several examples of -p values combined with -i values that provide good streaming & pandora.
    - Camera App does freeze up when OC'ing and using 600mhz with SmartFlex. Has not dont this when using 550mhz (hence why I'm using it). You'll have to work on the max value that works for your phone.


    We have a lot of variety in our Pre's and there does not seem to be a set of parameters for CPUspeed that covers every possible situation, you have to play with it and tweak it.
  11. #251  
    i have been using it at 500mhz for a few days

    -youtube flickers none
    -freezes none
    -BSoD followed by reboot never
    -improper Pandora playback when phone in standby runs with no problems
    -improper internet radio streaming when in standby again no issues (except when evdo is spotty obviously)
    -other video flicker dont watch movies on it
    -carmera app freezes and black screens none and i have taken about 15-20 pics to test
  12. jnk5y's Avatar
    Posts
    73 Posts
    Global Posts
    76 Global Posts
    #252  
    so what's the consensus on the best parameters to feed the script to have a stable (not overclocked) and battery saving Pre?
  13. #253  
    Quote Originally Posted by jnk5y View Post
    so what's the consensus on the best parameters to feed the script to have a stable (not overclocked) and battery saving Pre?
    It seems to be different for everyone.


    - Both clipcarl and vitviper's scripts running at 500mhz max work well for me EXCEPT for the fact that my EVDO network shuts down when my phone is idle and I can't receive text messages. This is a huge problem for me as I often get messages that are urgent or time-sensitive.

    - Vitviper's script when running at 550mhz does not seem to save power simply because it never really dips below the 550mhz line, even when idle. For some reason, my phone refuses to scale the cpu speed down.


    Note that a lot of people do not have these problems, but some do, so you may have to just try a few things and see what works. Basically, whenever my phone goes into the 125mhz - 250mhz range, my EVDO network shuts down. Until this is resolved, I'm forced to use the stock settings
  14. #254  
    Quote Originally Posted by adrenalinestyle View Post
    It seems to be different for everyone.


    - Both clipcarl and vitviper's scripts running at 500mhz max work well for me EXCEPT for the fact that my EVDO network shuts down when my phone is idle and I can't receive text messages. This is a huge problem for me as I often get messages that are urgent or time-sensitive.

    - Vitviper's script when running at 550mhz does not seem to save power simply because it never really dips below the 550mhz line, even when idle. For some reason, my phone refuses to scale the cpu speed down.


    Note that a lot of people do not have these problems, but some do, so you may have to just try a few things and see what works. Basically, whenever my phone goes into the 125mhz - 250mhz range, my EVDO network shuts down. Until this is resolved, I'm forced to use the stock settings



    same...
  15. wprater's Avatar
    Posts
    240 Posts
    Global Posts
    251 Global Posts
    #255  
    Quote Originally Posted by adrenalinestyle View Post
    It seems to be different for everyone.


    - Both clipcarl and vitviper's scripts running at 500mhz max work well for me EXCEPT for the fact that my EVDO network shuts down when my phone is idle and I can't receive text messages. This is a huge problem for me as I often get messages that are urgent or time-sensitive.

    - Vitviper's script when running at 550mhz does not seem to save power simply because it never really dips below the 550mhz line, even when idle. For some reason, my phone refuses to scale the cpu speed down.


    Note that a lot of people do not have these problems, but some do, so you may have to just try a few things and see what works. Basically, whenever my phone goes into the 125mhz - 250mhz range, my EVDO network shuts down. Until this is resolved, I'm forced to use the stock settings

    Using Vipers binary and params (at 500), Im getting the java usage (20-50%) over evdo connection.

    EDIT:
    Looks like the java process is just an issue with ssh connections over EvDO. Does this process stop after you log out?
    Last edited by wprater; 07/31/2009 at 06:40 PM.
  16. #256  
    Quote Originally Posted by wprater View Post
    Using Vipers binary and params (at 500), Im getting the java usage (20-50%) over evdo connection.
    Using VitViper code and params, I am noticing 9% battery usage per hour just letting the phone sit there with screen lock/off coming on after 30 seconds.

    Bluetooth off, GPS/loc services off, push mail to Exchange and Gmail on with "as items arrive" for both, 4 bars signal strength. No open cards.

    I also tried changing the mail delivery for both accounts to "15 minutes fetch." made no difference.

    ugh. why are my results so bad?
  17. #257  
    switch to original clipcarl's version; goto page one (1st pape of this topic).

    Download clipcarl's cpuspeed.zip most are doing fine with it.

    stop cet-cpuspeed

    or maybe your using vitviper's script then

    stop vit-cpuspeed

    now copy over clipcarl's version and remember to make cpuspeed runnable (chmod +x cpuspeed)
  18. #258  
    Viper (or anyone else who's tried it) -- did you notice a big difference in speed between 550 and 600? Right now I've been running at 550 locked while on..but was wondering how much faster the phone would be at 600. I understand that there are some risks associated with it so I was hoping for some anecdotal advice first..
  19. wprater's Avatar
    Posts
    240 Posts
    Global Posts
    251 Global Posts
    #259  
    Quote Originally Posted by mtlemmonrunner View Post
    switch to original clipcarl's version; goto page one (1st pape of this topic).

    Download clipcarl's cpuspeed.zip most are doing fine with it.
    I had to revert back to cet version, because the vit binary and settings were locking my screen while it was on.
  20. wprater's Avatar
    Posts
    240 Posts
    Global Posts
    251 Global Posts
    #260  
    Quote Originally Posted by chbearsrock View Post
    Viper (or anyone else who's tried it) -- did you notice a big difference in speed between 550 and 600? Right now I've been running at 550 locked while on..but was wondering how much faster the phone would be at 600. I understand that there are some risks associated with it so I was hoping for some anecdotal advice first..
    600 is noticeable faster, however, I've only played with it for a few hours. I never left it on for days, since its still unknown what long term effects it could cause.

Posting Permissions