Page 9 of 9 FirstFirst ... 456789
Results 161 to 177 of 177
  1. #161  
    Quote Originally Posted by Keegan99 View Post
    As a prerequisite, you'll need the webosinternals services installed so you can run shell commands from within your application. If you already have this installed (for the my-tether application, for example) you can skip this step.
    As root:
    Code:
    wget http://gitorious.org/webos-internals/applications/blobs/raw/db385edfa3f71ceb98401c16dd94b2490bfaaae5/org.webosinternals.services/org.webosinternals.services-0.4_all.ipk
    ipkg install org.webosinternals.services-0.4_all.ipk
    The reason why you have such a weird string in that wget command is because that proof-of-concept org.webosinternals.services code has been removed from the webos-internals git repository due to it being a *huge* security vulnerability.

    If you install that service, you effectively allow any rogue webos application to do anything it wants on your Pre, such as taking your web access bank account username and password and emailing it to someone who wants to steal your identity.

    Anyone who has installed this service must remove it immediately.

    It looks like instead of just removing it from the visible set of files in the git repository, I'm going to need to actually modify the history of the git repository to remove this problem.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2. #162  
    Oh, and for those interested, the open source LED-Service should be able to satisfy your immediate needs as a replacement for the webosinternals service
  3. #163  
    This is a little off topic but how do you know if webosinternals is installed on your pre? I know with the original flashlight or tether it was a requirement but I think it removed it. If it is installed how do you remove it?
  4. #164  
    Quote Originally Posted by mamouton View Post
    This is a little off topic but how do you know if webosinternals is installed on your pre? I know with the original flashlight or tether it was a requirement but I think it removed it. If it is installed how do you remove it?
    in commandline enter:
    Code:
    /bin/mount -o remount,rw /
    ipkg remove org.webosinternals.services
    /bin/mount -o remount,ro /
  5. #165  
    Thanks
  6. #166  
    Quote Originally Posted by mdmogren View Post
    Where is ipkg-opt located? I'm getting ipkg-opt not found?
    I'm getting the same thing.
  7. #167  
    Quote Originally Posted by mdmogren View Post
    Where is ipkg-opt located? I'm getting ipkg-opt not found?
    You need to bootstrap optware to use ipkg-opt. See the WebOS Internals wiki for more details.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  8. ulatif1's Avatar
    Posts
    2 Posts
    Global Posts
    3 Global Posts
    #168  
    Okay im sorry im new to this i am complelty lost i just got the pre ..so how do i do this?
  9. bdubbx's Avatar
    Posts
    133 Posts
    Global Posts
    136 Global Posts
    #169  
    ^with all the quirks with this (like it doesn't work when the screen is off), you are probably better off waiting until 1.2 is officially released. It sounds like there's more of a working light that you can set up and you won't have to undo this once its released.
  10. cmcghee1's Avatar
    Posts
    3 Posts
    Global Posts
    6 Global Posts
    #170  
    Hi, i am completely comfused about the step by step directions provided. Where am I imputing all of these codes?
  11. #171  
    Quote Originally Posted by cmcghee1 View Post
    Hi, i am completely comfused about the step by step directions provided. Where am I imputing all of these codes?
    You no longer need this. Just open up your Preware and installed LED NOtifications under the patches

    enjoy
  12. #172  
    hmm when i try to run led from preware i get an error saying the hunks have failed, how can i get aroung this please?
  13. #173  
    Quote Originally Posted by andywoodstick View Post
    hmm when i try to run led from preware i get an error saying the hunks have failed, how can i get aroung this please?
    anyone?
  14. #174  
    is your preware up to date? Quick install worked for me last night
  15. #175  
    thanks waiting for this patch in preware

    Thanks again
  16. #176  
    it wont work with my WEB OS version any updates news
  17. #177  
    are you really posting that in this old thread?? The pre now does this stock you don't need to install a patch to get this function. Just go to Screen and Lock and set Blink Notifications to On....
Page 9 of 9 FirstFirst ... 456789

Posting Permissions