Page 6 of 9 FirstFirst 123456789 LastLast
Results 101 to 120 of 177
  1. Ikyo's Avatar
    Posts
    290 Posts
    Global Posts
    292 Global Posts
    #101  
    You could modify the event.d script and put it into debug mode. I am not sure where we would find out what options are actually available for the config file.
  2. bdubbx's Avatar
    Posts
    133 Posts
    Global Posts
    136 Global Posts
    #102  
    Quote Originally Posted by fishheads View Post
    it seems to work as advertised when plugged in via USB. But when unplugged, what I'm seeing is that the LED lights up until the phone goes to sleep. When the phone is asleep, no more blinking occurs. But when it hit the power button to turn the phone on, the blinking starts up. It seems to be the same issue Keegan99 ran into with the power-off scripts of sorts that check to see if everything is off.
    bummer...I thought it was finally true...nice try though...still gonna out the pager nagger crond on for now...at least the vibrate os working.
  3. fishheads's Avatar
    Posts
    49 Posts
    Global Posts
    50 Global Posts
    #103  
    I'm looking at the powerd file that Keegan99 was looking at. I noticed(as well as some others), that when unplugged, the LED will light up here and there. So, it appears something is waking the phone up(but not the screen). If we can find out what runs in the background then we can tie the pager/nagger script LED portion into that.

    If we all scour, I think we can find a way to get LED notification!!

    Quote Originally Posted by Ikyo View Post
    You could modify the event.d script and put it into debug mode. I am not sure where we would find out what options are actually available for the config file.
  4. Ikyo's Avatar
    Posts
    290 Posts
    Global Posts
    292 Global Posts
    #104  
    I can tell you why it is waking up. In the conf file, it has the line for it not to go into suspend. It will sleep the screen, but the rest of the phone stays active.
  5. Ikyo's Avatar
    Posts
    290 Posts
    Global Posts
    292 Global Posts
    #105  
    Code:
    [general]
    debug = 0
    
    [battery]
    fake_battery = false
    
    disable_charging = false
    
    [suspend]
    wait_idle_ms = 500 
    after_resume_idle_ms = 1000
    wait_suspend_response_ms = 30000
    wait_prepare_suspend_ms = 5000
    suspend_with_charger = false
  6. Ikyo's Avatar
    Posts
    290 Posts
    Global Posts
    292 Global Posts
    #106  
    If someone wants to try, they can make powerd run with a -l (lowercase L) when it starts. That is supposed to enable visual-leds. It might allow us to change them.
  7.    #107  
    If someone wants to try, they can make powerd run with a -l (lowercase L) when it starts
    Veeeery interesting. Where did you read/learn this?

    If it enables LEDs during sleep mode, then we're in business.
  8. Ikyo's Avatar
    Posts
    290 Posts
    Global Posts
    292 Global Posts
    #108  
    Just run powerd -? and you will get a list of commands. The other issue is that most of the phone goes into suspend including the processor. When this happens it is going to suspend all background tasks including the cron script. So if this does work, then it would be better to code something into the messaging routine since it will wake the phone.
  9. #109  
    So does this work? Cause I am using WebOS Quick Install v2.01 and there i can download Led Service, I downloaded and installed via WebOS Quick Install v2.01, i dont seem to see the app and im not getting the led to light up, anyone help me out?

    Thanks
  10. Ikyo's Avatar
    Posts
    290 Posts
    Global Posts
    292 Global Posts
    #110  
    This isn't built on that service. That is something totally different.
  11. #111  
    So why was it listed there? So basically i downloaded and installed it but i really didnt install it? Or this has to be rooted only?

    Thanks
  12. Ikyo's Avatar
    Posts
    290 Posts
    Global Posts
    292 Global Posts
    #112  
    Rooted only
  13. #113  
    Quote Originally Posted by Ikyo View Post
    This isn't built on that service. That is something totally different.
    Ive seen the "LED service" also, i knew it wasn't this. but does anyone know what it is/does?
  14. #114  
    The LED service is a custom service written so that developers can use it control the brightness of the 3 LED's in the gesture area.
  15. #115  
    I see, so whats the reason for it being available to someone in Preware and quickinstall?
  16. #116  
    Because all the packages are stored in the repo.
  17. #117  
    oh gotcha. that makes sense now, thanks.
  18. #118  
    I am glad to see someone else pushing this fix. It is sad that a phone with such great technology is so limited. I am raising the bar. Anyone who can get a working fix I am willing to make a $50.00 donation
  19. mg3
    mg3 is offline
    mg3's Avatar
    Posts
    12 Posts
    #119  
    First off, let me also thank all of you who are working on this.

    Two points of clarification:

    1) When the phone is off the charger and goes into suspend does that kill the sound & vibrate as well as the LED?

    2) I have been looking at the GPS tracking script wikipage. It appears that the script at the bottom of the page has been running "every 20 minutes on my phone for the last 4 days, no problem. -dld121" What is it about this script that allows it to work despite the phone going into suspend?
  20. #120  
    Maybe I'm just too newbish, but I put the script into media internal, followed the commands on the internals page.

    How do I test run the script so I know its working...

    Again, sorry

Posting Permissions