Results 1 to 9 of 9
  1. Spunky424's Avatar
    Posts
    27 Posts
    Global Posts
    28 Global Posts
       #1  
    So i attempted to root my pre right now and i think i was successful. i followed the wiki then i installed openssh, created my username and pw. i'm doing all of this on windows so i used putty and the novaproxy file. after remounting the file system and exiting putty. i'm trying to find a way to get back into my pre. it seems like novaproxy cant find my pre anymore. is the only way to get back into my pre is through using putty and my newly created username & pw through ssh? i wanted to setup usbnet since i'm at work and have no wifi connection. can someone help me out?

    Thanks
  2. SirWill's Avatar
    Posts
    439 Posts
    Global Posts
    492 Global Posts
    #2  
    Quote Originally Posted by Spunky424 View Post
    So i attempted to root my pre right now and i think i was successful. i followed the wiki then i installed openssh, created my username and pw. i'm doing all of this on windows so i used putty and the novaproxy file. after remounting the file system and exiting putty. i'm trying to find a way to get back into my pre. it seems like novaproxy cant find my pre anymore. is the only way to get back into my pre is through using putty and my newly created username & pw through ssh? i wanted to setup usbnet since i'm at work and have no wifi connection. can someone help me out?

    Thanks
    Unless you did a usbnet enable on the phone and rebooted it, then you will not get usbnet working without accessing shell via putty and enabling it first.
  3. Spunky424's Avatar
    Posts
    27 Posts
    Global Posts
    28 Global Posts
       #3  
    thanks i actually got back into my pre and enabled usbnet and i think i got the login correct. if it says username@castle as the command prompt after entering my username and pw i should be all set correct?

    do i need dev mode still on in order to connect through ssh to my fone? or can i disable dev mode and still connect?
  4. #4  
    Quote Originally Posted by Spunky424 View Post
    thanks i actually got back into my pre and enabled usbnet and i think i got the login correct. if it says username@castle as the command prompt after entering my username and pw i should be all set correct?

    do i need dev mode still on in order to connect through ssh to my fone? or can i disable dev mode and still connect?
    You can login through EVDO, you don't have to have WiFi... its all in how you set up your phone. I login through EVDO at work all the time. USBNet might be more convenient, but meh.


    I left my phone in dev mode, I see no reason to disable it, you set up a secure SSH connection, so its not like anyone can login to your phone without your login name and password anyways, and you can't telnet in without running talk.py, so no worries.
  5. Spunky424's Avatar
    Posts
    27 Posts
    Global Posts
    28 Global Posts
       #5  
    thanks so much for the quick replies. now that i've rooted my pre, i'm wondering if theres anyway to revert back to the "unrooted" state. can i use webdoctorOS to restore back to OEM configurations?

    also with the pre rooted can updates be normally downloaded through the phone or is there a special way of doing it since the phone is rooted?
  6. zna03's Avatar
    Posts
    281 Posts
    Global Posts
    294 Global Posts
    #6  
    Quote Originally Posted by Spunky424 View Post
    thanks so much for the quick replies. now that i've rooted my pre, i'm wondering if theres anyway to revert back to the "unrooted" state. can i use webdoctorOS to restore back to OEM configurations?

    also with the pre rooted can updates be normally downloaded through the phone or is there a special way of doing it since the phone is rooted?
    Things you shoulda found out beforehand...
  7. #7  
    Quote Originally Posted by Spunky424 View Post
    thanks so much for the quick replies. now that i've rooted my pre, i'm wondering if theres anyway to revert back to the "unrooted" state. can i use webdoctorOS to restore back to OEM configurations?

    also with the pre rooted can updates be normally downloaded through the phone or is there a special way of doing it since the phone is rooted?
    Why would you want to unroot the phone? Whats the point? Updates are just as per usual. I installed 1.0.4 and my phone is still rooted, cpu-scaling still enabled, etc.
  8. Spunky424's Avatar
    Posts
    27 Posts
    Global Posts
    28 Global Posts
       #8  
    just a question i posed to know if something goes wrong. i wont be meddling much, i'm on the dev wiki trying to understand how to do some of the changes.

    i followed the directions to connect through EVDO but PuTTY keeps saying it times out. i've got the right ip address entered and port, but still no luck. any ideas on how to get it to work via EVDO?
  9. #9  
    Quote Originally Posted by Spunky424 View Post
    thanks so much for the quick replies. now that i've rooted my pre, i'm wondering if theres anyway to revert back to the "unrooted" state. can i use webdoctorOS to restore back to OEM configurations?

    also with the pre rooted can updates be normally downloaded through the phone or is there a special way of doing it since the phone is rooted?
    The webOS Doctor will revert everything.

    Installing a secure root access mechanism (what you call "rooting the phone") does not alter it's operation in any way.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals

Posting Permissions