Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 80
  1. #41  
    i did copy paste
    line 28 is the } then a blank line then main on line 30
  2. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
       #42  
    i'm not sure how yours look, but mine has 33 lines....

    *EDIT* I'm not trying to sound like an ***, but are you sure you copied everything from the web-os internals site?
  3. #43  
    #!/bin/sh

    mai

    that wasn't showing up thats why it was two lines short
  4. #44  
    it wasn't copying that part u made me realize that when u said main should be past line 30
    for some reason it wasn't copying the first two line, got the right response now, no i have to mess with crond, crosses fingers
  5. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
       #45  
    Quote Originally Posted by Prethorpe24 View Post
    it wasn't copying that part u made me realize that when u said main should be past line 30
    for some reason it wasn't copying the first two line, got the right response now, no i have to mess with crond, crosses fingers
    sounds good. Let me know if you need any more help
  6. #46  
    yeah i enabled crond using the ipkg method "i think i really am in unkown territory" but when i try to save it says /etc/cron/crontabs/root no such file or directory even though i'm editing it
  7. #47  
    ok since i used the ipkg method and his instructions are based on enabling the stock crond then i should enable stock crond?
  8. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
       #48  
    Quote Originally Posted by Prethorpe24 View Post
    yeah i enabled crond using the ipkg method "i think i really am in unkown territory" but when i try to save it says /etc/cron/crontabs/root no such file or directory even though i'm editing it
    so you did the Alternative (ipkg-opt) Method? If so, crond isn't edited under /etc/cron/crontabs/root. "etc/cron/crontabs/root" is the file that schedules the script
  9. #49  
    ok i enabled reg. crond now it's not switching
  10. #50  
    well i mean like it wasn't switching before but i enabled stock crond and i used his 1 minute change file and no dice
  11. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
       #51  
    Quote Originally Posted by Prethorpe24 View Post
    ok i enabled reg. crond now it's not switching
    vi /etc/cron/crontabs/root and add
    0 * * * * /opt/share/wallswitcher/wallswitcher.sh > /opt/share/wallswitcher/wallswitcher.log 2>&1

    save and quit. then test with:
    sudo /opt/share/wallswitcher/wallswitcher.sh
  12. #52  
    i tested and it works but no auto switch
  13. #53  
    how often will that change it
  14. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
       #54  
    you need to edit the stock crond:
    vi /etc/event.d/mod-crond (make sure to backup prior to editing)
    make sure your code looks the same as the one on the wiki. Crond - WebOS Internals
  15. #55  
    when i put in the one from web os internals "*/1 * * * * /opt/share/wallswitcher/wallswitcher.sh > /opt/share/wallswitcher/wallswitcher.log 2>&1
    " is says pattern not found
  16. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
       #56  
    Quote Originally Posted by as4life View Post
    you need to edit the stock crond:
    vi /etc/event.d/mod-crond (make sure to backup prior to editing)
    make sure your code looks the same as the one on the wiki. Crond - WebOS Internals
    Actually i did mine differently. I modified /etc/event.d/crond
  17. #57  
    okay so the mod-crond is a created one cuz it's empty otherwise right? so i should mod the stock /etc/event.d/crond? thing is i don't know how to back it up
  18. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
       #58  
    Quote Originally Posted by Prethorpe24 View Post
    when i put in the one from web os internals "*/1 * * * * /opt/share/wallswitcher/wallswitcher.sh > /opt/share/wallswitcher/wallswitcher.log 2>&1
    " is says pattern not found
    u added that code to /etc/cron/crontabs/root right?
  19. #59  
    [QUOTE=as4life;1793192]vi /etc/cron/crontabs/root and add
    0 * * * * /opt/share/wallswitcher/wallswitcher.sh > /opt/share/wallswitcher/wallswitcher.log 2>&1

    The crond setting you have now is for once an hour. to put it in a mode to see the testing you need to make it say

    */1 * * * * /opt/share/wallswitcher/wallswitcher.sh > /opt/share/wallswitcher/wallswitcher.log 2>&1

    This will make it switch every minute.
  20. #60  
    at as4life

    no it won't let me save it

    is it cuz i don't have the right crond file modified?

    when i put it in /etc/cron/crontabs/root it says pattern not found
Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions