Results 1 to 8 of 8
  1. aaronchow's Avatar
    Posts
    51 Posts
    Global Posts
    94 Global Posts
       #1  
    I'm starting to read the Palm WebOS rough cut and trying to follow through the "News" application. I'm encountering problems when trying to add the AJAX functions in Ch. 3. Does anyone have the code example up to Ch. 3? Any help is appreciated.

    PS~I could also copy my code here and have you corrected me if that's possible, too...
  2. #2  
    What I and another poster found was the "ProcessFeed" function isn't included on the phone anywhere and the code for it isn't anywhere to be found. Yea, annoying.

    I can't post links yet but do a search on "oreilly news" should be in top 3 posts.
  3. aaronchow's Avatar
    Posts
    51 Posts
    Global Posts
    94 Global Posts
       #3  
    Thanks for the quick reply.

    I'm going to leave a comment at the OReilly site and see if Mitch Allen will respond to this... just plain annoying right now...
  4. #4  
    Generally O'Reilly books have a pretty decent online errata section or something of the like, especially for Rough Cuts. Have you checked there? If not, submit something against the book, since that's where they should be checking anyway before the book goes to print.
  5. #5  
    Problem is its supposed to be in "Appendix D" but it being roughcuts that isn't out yet (unless I overlooked it somehow). So for people like us wanting to follow along and get more comfortable developing for webOS we're stuck at that section.
  6. aaronchow's Avatar
    Posts
    51 Posts
    Global Posts
    94 Global Posts
       #6  
    Just an update... Mitch Allen has finally posted the entire News app source code in Appendix A. I'll start comparing it to see where my problems are ^^
  7. #7  
    Quote Originally Posted by aaronchow View Post
    Just an update... Mitch Allen has finally posted the entire News app source code in Appendix A. I'll start comparing it to see where my problems are ^^
    I have copied the entire code from the appendix and the app fails to run in the emulator. The icon glows for 3 seconds and then doesnt do anything.
  8. #8  
    See this thread.

    http://forums.precentral.net/web-os-...s-rss-app.html

    I do have to upload a new version that has some fixes but the current one there runs and works mostly.

Posting Permissions