Page 21 of 26 FirstFirst ... 111617181920212223242526 LastLast
Results 401 to 420 of 506
  1. #401  
    Quote Originally Posted by GoSteelers View Post
    Greg,

    I dropped the file into the installer, and this is the result. I have 64 bit Vista.


    PreTool 1.1 by Greg Roll 2009
    Connects to the Palm Pre and performs various opperations.
    NOTE: Requires Dev Mode Enabled on Palm Pre. (upupdowndownleftrightleftrightbastart)

    Connected to Novacom Controller

    Listing devices...
    Unable to connect to Novacom. Check driver is running.
    Error: java.net.ConnectException: Connection refused: connect
    Java complete.
    PreTool Complete...

    Any help would be appreciated.
    Hi GoSteelers,

    I can't remember if this one is because your Pre is not in dev mode, your Pre is not in "just charge" or because the driver isn't running correctly. Double check your Pre is in dev mode, connected in "just charge" mode and if it is restart your computer with your Pre connected.

    Let me know how you go,
    Greg
  2. RonWood's Avatar
    Posts
    43 Posts
    Global Posts
    48 Global Posts
    #402  
    Most likely it is the novacom driver is not installed correctly or running.

    Win7 64bit on my first install of the PreBrew has not worked due to the novacom driver not being properly installed. Novacom Linux is the failed driver.

    Which I will be resolving the issue using the Windows 7 manual install.
    Last edited by RonWood; 07/22/2009 at 09:50 AM.
  3. #403  
    ^how do you do this?
  4. atistang's Avatar
    Posts
    1 Posts
    Global Posts
    12 Global Posts
    #404  
    i'm receiving this message


    " 'java' is not recognized as an internal or external command, operable program or batch file."


    anyone got any clues?

    windows 7 64bit


    EDIT: i got it to work now
    Last edited by atistang; 07/22/2009 at 11:52 AM.
  5. katsnuts's Avatar
    Posts
    59 Posts
    Global Posts
    71 Global Posts
    #405  
    Quote Originally Posted by vladthedog View Post
    I'm getting the exact same thing.
    ***HELP***

    I am getting this exact same PreBrew message, but found somethign very crazy. If I go to JAVA's website and TEST my JAVA VIRTUAL MACHINE, the image does not show up to confirm that it is working properly. It gives me an option to show errors, and when I do (again, on the JAVA page) this exact thing shows up as in PreBrew...

    Running Java...

    Exception in thread "main" java.lang.UnsupportedClassVersionError: com/PreTool/P
    reTool (Unsupported major.minor version 49.0)
    at java.lang.ClassLoader.defineClass0(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)


    This means that the problem that the JAVA website found, is exactly what the PreBrew program found. So, this has nothing to do with the phone or installation of PreBrew/Novacom, rather a JAVA problem. I have un-installed and installed the latest JAVE several times, but there has to be a Java Vitual Machine error preventing the JAVA test to work on their site, and on the PreBrew.

    I am not an expert so I have no idea where to begin on a fix for this, any help would be appreciated.

    *NOTE* I was able to load Apps all day long for 2 weeks until yesterday when my computer got a virus. I think the virus attacked my JAVA, Virtual Machine, RunDll or something else related. Please help and I hope this helps.

    JB
  6. #406  
    Install Application 1.1 by Greg Roll 2009
    Installs an application on the Palm Pre
    Ensure your Palm Pre is connected and running in developer mode.

    Press any key to continue . . .


    Starting PreTool...

    Checking for webosdoctorp100ewwsprint.jar...

    webosdoctorp100ewwsprint.jar found.

    Running Java...

    Exception in thread "main" java.lang.NoClassDefFoundError: com/palm/novacom/Nova
    comException
    Caused by: java.lang.ClassNotFoundException: com.palm.novacom.NovacomException
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    Could not find the main class: com.PreTool.PreTool. Program will exit.

    Java complete.
    Complete. Check for any error messages above.

    Press any key to continue . . .
    **************************************************************************
    THis keeps happening to me as well. WHen i try to install prebrew wget has some problem looks like it cant download something please someone help me i didnt buy my pre to not be able to put these apps on it!!!
  7. #407  
    Install Application 1.1 by Greg Roll 2009
    Installs an application on the Palm Pre
    Ensure your Palm Pre is connected and running in developer mode.

    Press any key to continue . . .


    Starting PreTool...

    Checking for webosdoctorp100ewwsprint.jar...

    webosdoctorp100ewwsprint.jar found.

    Running Java...

    Exception in thread "main" java.lang.NoClassDefFoundError: com/palm/novacom/Nova
    comException
    Caused by: java.lang.ClassNotFoundException: com.palm.novacom.NovacomException
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    Could not find the main class: com.PreTool.PreTool. Program will exit.

    Java complete.
    Complete. Check for any error messages above.

    Press any key to continue . . .
    **************************************************************************
  8. #408  
    FYI to everyone ...


    I had HUGE troubles trying to get the novacom driver to recognize my pre. Nothing I did worked. Until now.

    Turns out the /etc/event.d/usbctrl script which loads kernel modules for novacom to recognize it, depends on the hostname being either castle or pixie.

    Which means that if you change your hostname, novacom breaks.

    I hope this helps others than just me.

    Oh well for keeping all my devices and computers in my hostname scheme (physicists: feynman, einstein, bohr, curie).
  9. #409  
    Hey guys,

    Regarding the problem with running out of install space for homebrew apps, I have found several threads on it and consolidated them in post #9 here: http://forums.precentral.net/general...maxed-out.html

    If anyone has additional information or advice on this problem, I'm not sure which thread it should be posted in. I just wanted to help consolidate the info since it's in a bunch of different threads.

    Thanks!
  10. #410  
    ok so I read all 25 pages of the other thread using the SDK to get apps on the pre and I have no desire to go through all these....

    I downloaded PreBrew, when I click on Setup.vbs and I get the following warning

    "Setup.xml missing unable to continue" anythoughts??? I am using Windows Vista Home
    Last edited by triathlet3; 07/22/2009 at 10:04 PM.
  11. #411  
    Quote Originally Posted by triathlet3 View Post
    ok so I read all 25 pages of the other thread using the SDK to get apps on the pre and I have no desire to go through all these....

    I downloaded PreBrew, when I click on Setup.vbs and I get the following warning

    "Setup.xml missing unable to continue" anythoughts??? I am using Windows Vista Home
    Hi triathlet3,

    Make sure you extract the zip to a folder then run the Setup.vbs from there. That should resolve your issue.

    Thanks,
    Greg
  12. #412  
    Greg_roll and all the people who have been helping, I just want to say thanks. I think I speak for everyone on PreCentral when I say that in less than two months from the phone's release, that getting this far on both app-writing and app-loading marks a monumental achievement in Pre development. You guys have even inspired me to start working on some Pre apps just so I can hope to give back to the community (just gotta get Mojo SDK working right on my machine...)

    V1.1 of PreBrew is the best yet. For those who still can't get it working, hang in there and ask us all questions. I'm happy to help, too. I'm running Win7 64-bit and it's working fine on my machine. I actually installed WebOS Doc, Java and the 64-bit Novacom drivers back in version V0.9, so that makes it even easier - simply had to re-install PreBrew application.

    Thanks again.
    -N
  13. RonWood's Avatar
    Posts
    43 Posts
    Global Posts
    48 Global Posts
    #413  
    Quote Originally Posted by badboi24u View Post
    ^how do you do this?
    Novacom with Windows 7 - WebOS Internals

    Instructions for manual install of novacom driver
  14. #414  
    Quote Originally Posted by greg_roll View Post
    Hi everyone,

    Anyone had a chance to test this for me???

    Thanks
    Greg
    Hi Greg...

    I've tried every way I could think of to d/l this Pretest.zip file. I've failed..

    I"m not allowed to put links here yet... but it's your link.. could you double check it for errors.. thanks

    Since I"m not allowed to put links.. It just will NOT let me get a thing.. well, only a blank screen... so check it out again and I will be happy to download it and try it out for you... since everything on my Vista 64 is working 100%
  15. #415  
    Quote Originally Posted by Converse420 View Post
    Install Application 1.1 by Greg Roll 2009
    Installs an application on the Palm Pre
    Ensure your Palm Pre is connected and running in developer mode.

    Press any key to continue . . .


    Starting PreTool...

    Checking for webosdoctorp100ewwsprint.jar...

    webosdoctorp100ewwsprint.jar found.

    Running Java...

    Exception in thread "main" java.lang.NoClassDefFoundError: com/palm/novacom/Nova
    comException
    Caused by: java.lang.ClassNotFoundException: com.palm.novacom.NovacomException
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    Could not find the main class: com.PreTool.PreTool. Program will exit.

    Java complete.
    Complete. Check for any error messages above.

    Press any key to continue . . .
    **************************************************************************
    Hi everyone,

    The error "Could not find the main class: com.PreTool.PreTool. Program will exit." means it cannot find PreTool.jar in c:\program files\prebrew.

    If this file is missing please run the Prebrew uninstall from START MENU>Programs>PreBrew and then reinstall PreBrew again.

    Let me know how you go.

    Greg
  16. #416  
    Quote Originally Posted by Papahawg View Post
    Hi Greg...

    I've tried every way I could think of to d/l this Pretest.zip file. I've failed..

    I"m not allowed to put links here yet... but it's your link.. could you double check it for errors.. thanks

    Since I"m not allowed to put links.. It just will NOT let me get a thing.. well, only a blank screen... so check it out again and I will be happy to download it and try it out for you... since everything on my Vista 64 is working 100%
    Hi Papahawg,

    Thanks! Sorry skydrive mustn't like direct links.

    Go here Public - Windows Live and download PreTest from there.

    Thanks for testing for me

    Greg
  17. #417  
    Quote Originally Posted by katsnuts View Post
    ***HELP***

    I am getting this exact same PreBrew message, but found somethign very crazy. If I go to JAVA's website and TEST my JAVA VIRTUAL MACHINE, the image does not show up to confirm that it is working properly. It gives me an option to show errors, and when I do (again, on the JAVA page) this exact thing shows up as in PreBrew...

    Running Java...

    Exception in thread "main" java.lang.UnsupportedClassVersionError: com/PreTool/P
    reTool (Unsupported major.minor version 49.0)
    at java.lang.ClassLoader.defineClass0(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)


    This means that the problem that the JAVA website found, is exactly what the PreBrew program found. So, this has nothing to do with the phone or installation of PreBrew/Novacom, rather a JAVA problem. I have un-installed and installed the latest JAVE several times, but there has to be a Java Vitual Machine error preventing the JAVA test to work on their site, and on the PreBrew.

    I am not an expert so I have no idea where to begin on a fix for this, any help would be appreciated.

    *NOTE* I was able to load Apps all day long for 2 weeks until yesterday when my computer got a virus. I think the virus attacked my JAVA, Virtual Machine, RunDll or something else related. Please help and I hope this helps.

    JB
    Hmm Java is very broken for you

    The only thing I can suggest is goto C:\Program Files\Java\jre6\bin (path may be slightly different jre6 may be jre5 or 1.5.x etc) and copy the java.exe file to your c:\windows\system32. Replace java.exe if it exists. Try and see if this works.

    Greg
  18. #418  
    Greg, thanks for the advice you guys are doing a GREAT job!

    Ok so I downloaded PreBre and when I tried to install an app, i get the following error

    Install Application 1.1 by Greg Roll 2009
    Installs an application on the Palm Pre
    Ensure your Palm Pre is connected and running in developer mode.

    Press any key to continue . . .


    Starting PreTool...

    Checking for webosdoctorp100ewwsprint.jar...

    webosdoctorp100ewwsprint.jar found.

    Running Java...

    PreTool 1.1 by Greg Roll 2009
    Connects to the Palm Pre and performs various opperations.
    NOTE: Requires Dev Mode Enabled on Palm Pre. (upupdowndownleftrightleftrightbast
    art)

    Connected to Novacom Controller

    Listing devices...
    Number of devices found: 0

    No devices have been found.
    Ensure your Pre is connected and running in DEV mode.
    Ensure the 'Palm Novacom' Service is running.

    Java complete.
    Complete. Check for any error messages above.

    Press any key to continue . . .




    The device is in fact in dev mode...
  19. #419  
    Quote Originally Posted by triathlet3 View Post
    Greg, thanks for the advice you guys are doing a GREAT job!

    Ok so I downloaded PreBre and when I tried to install an app, i get the following error

    Install Application 1.1 by Greg Roll 2009
    Installs an application on the Palm Pre
    Ensure your Palm Pre is connected and running in developer mode.

    Press any key to continue . . .


    Starting PreTool...

    Checking for webosdoctorp100ewwsprint.jar...

    webosdoctorp100ewwsprint.jar found.

    Running Java...

    PreTool 1.1 by Greg Roll 2009
    Connects to the Palm Pre and performs various opperations.
    NOTE: Requires Dev Mode Enabled on Palm Pre. (upupdowndownleftrightleftrightbast
    art)

    Connected to Novacom Controller

    Listing devices...
    Number of devices found: 0

    No devices have been found.
    Ensure your Pre is connected and running in DEV mode.
    Ensure the 'Palm Novacom' Service is running.

    Java complete.
    Complete. Check for any error messages above.

    Press any key to continue . . .




    The device is in fact in dev mode...
    Hi triathlet3,

    Thanks. I think this is because either the Novacomd service is not running or your Pre is not in "Just Charge" mode.

    I dont have a Pre so im not too sure. Someone else here may be able to help.

    Also a few posts ago said the issue may occur if you have renamed your device name in Pre's linux.

    Hope some of this helps,
    Greg
  20. #420  
    HOLY CRAPPP ! edit I got it to work!! thank you guys so much! keep up the good work

Posting Permissions