Page 1 of 2 12 LastLast
Results 1 to 20 of 21
  1.    #1  
    This is for everyone who was having trouble installing the SDK. I wrote up a quick how-to and included genoahous' gesture guide from this forum. If you are having any trouble, need help or have information to contribute, please post it! Also, anyone from the Dev Wiki want to PM me please?

    Here's the guide: Pre Insiders • View topic - HowTo: Set Up Mojo SDK (ver. 0.3.4)

    It's only for Windows XP 32bit users, but czechdev posted this guide on how OSX users can install using Windows Runtime Environment.

    Enjoy!
  2. #2  
    Quote Originally Posted by PreInsiders View Post
    It's only for Windows XP 32bit users
    Thats not true, i got it up and running on my Windows Vista 32bit
  3. Leke's Avatar
    Posts
    597 Posts
    Global Posts
    603 Global Posts
    #3  
    Quote Originally Posted by murdermajig View Post
    Thats not true, i got it up and running on my Windows Vista 32bit
    Same here
  4. #4  
    Quote Originally Posted by murdermajig View Post
    Thats not true, i got it up and running on my Windows Vista 32bit
    How? What was our process?
  5. #5  
    I Installed the Sdk, and then it asked me to install virtualbox 2.2.0 or greater
  6. Leke's Avatar
    Posts
    597 Posts
    Global Posts
    603 Global Posts
    #6  
    I already had virtualbox installed. I installed the sdk, and you have to reboot before you launch it.
  7. #7  
    Thanks Leke, I almost forgot that i turned off my computer when i installed it
  8. #8  
    I got it running on Win7 32bit, without a reboot.
  9. Leke's Avatar
    Posts
    597 Posts
    Global Posts
    603 Global Posts
    #9  
    Vista 32 bit specifically said a reboot will be required. I had to uninstall reinstall again after getting similar errors as everyone else. After the reboot it ran smoothly.
  10. diomark's Avatar
    Posts
    752 Posts
    Global Posts
    770 Global Posts
    #10  
    does anyone have this working on vista 64bit?
    -mark
  11. #11  
    Quote Originally Posted by diomark View Post
    does anyone have this working on vista 64bit?
    -mark
    no luck for me on vista x64. it tries to open but nothing happens.
  12. #12  
    I finally got it working in Vista 64 bit.

    Follow the normal instructions.

    1. Install JDK6u14 for 64 bit.
    2. Instal VirtualBox 2.2.4
    3. Install Safari 4

    4.Reboot your PC.

    5. Install Palm WebOS SDK. Make sure to change the install path to c:\palm\sdk

    6. Reboot your PC.

    7. Download w w w .eclipse . org/downloads/download.php?file=/eclipse/downloads/drops/S-3.5RC4-200906051444/swt-3.5RC4-win32-win32-x86_64.zip


    8. Open the zip file and copy the file swt.jar to the folder C:\Palm\SDK\share\jars

    9. Do not run the emulator from the shortcut or the exe.

    10. Open Command Prompt from Start menu - All Programs - Accessories.

    11. type cd C:\Palm\SDK\bin then hit enter.

    12. type palm-emulator then hit enter

    The emulator will then launchand go through a Virtual Machine setup process. Just approve any prompts and after a bit, your emulator will be running.
  13. #13  
    I have installed all the items listed on the documentation but when I try and start SDK it still keeps saying tat I it needs Vitualbox 2.2 or greater that I had installed-I do not think it is seeing it, any tips?

    I have rebooted and installed VBox several times
  14. #14  
    Found there SDK can still be downloaded.

    Quote Originally Posted by PreInsiders View Post
    It also has a number of sites that can still do the download. The first site given in other threads no longer works.

    - Craig
  15. #15  
    Thanks for the link, very useful.
    Wake up, Mr. Freeman, wake up and... smell the ashes.

    My theme: Minimalist+

    $5 app icons for webOS developers!
  16. #16  
    Mods - can we make this a sticky
    Devices: Blackberry 7130, 8130, 8330, HTC Touch Pro, Treo 600, 700wx, Pro, Palm Pre
  17. TomServo's Avatar
    Posts
    10 Posts
    Global Posts
    11 Global Posts
    #17  
    I have it installed on Windows 7 32-bit
  18. Auzo's Avatar
    Posts
    35 Posts
    Global Posts
    355 Global Posts
    #18  
    I just want to confirm that Blubble's method to get the SDK working on Vista x64 also works for Win7 x64

    edit: Also wanted to note that the JDK isn't a necessity. You can get away with using the JRE (Java Runtime Environment) instead. The JDK has a bunch of extra things for Java Developers that arent needed if you just want to run Java programs.
    Last edited by Auzo; 07/02/2009 at 12:19 AM.
  19. #19  
    i'm guessing no hope for ubuntu? it's crazy how i'm stuck with a linux phone, but i can't even root without windows?
  20. #20  
    Quote Originally Posted by Blubble View Post
    I finally got it working in Vista 64 bit.

    Follow the normal instructions.

    1. Install JDK6u14 for 64 bit.
    2. Instal VirtualBox 2.2.4
    3. Install Safari 4

    4.Reboot your PC.

    5. Install Palm WebOS SDK. Make sure to change the install path to c:\palm\sdk

    6. Reboot your PC.

    7. Download w w w .eclipse . org/downloads/download.php?file=/eclipse/downloads/drops/S-3.5RC4-200906051444/swt-3.5RC4-win32-win32-x86_64.zip


    8. Open the zip file and copy the file swt.jar to the folder C:\Palm\SDK\share\jars

    9. Do not run the emulator from the shortcut or the exe.

    10. Open Command Prompt from Start menu - All Programs - Accessories.

    11. type cd C:\Palm\SDK\bin then hit enter.

    12. type palm-emulator then hit enter

    The emulator will then launchand go through a Virtual Machine setup process. Just approve any prompts and after a bit, your emulator will be running.
    Ok... I need help.... this simply does NOT work!!! I have followed this step-by-step about 6 times... all I get is the error: "Error 25: Disk read error". Before, I was getting the error: "Fatal: blah, blah, blah" Please advice.. I have Windows Vista 64bit.

    Thanks!
Page 1 of 2 12 LastLast

Posting Permissions