Page 15 of 20 FirstFirst ... 51011121314151617181920 LastLast
Results 281 to 300 of 385
  1. #281  
    Quote Originally Posted by genoahous View Post
    As I understand it the SDK does not support video or audio at this time. If you're writing an app with these features, then final debugging with playback would have to occur on real PrPrPr&#$275$; $hardware$.

    Also, several features are stubbed out. e.g. The camera App brings up an image of a camera.
    Ah, gotcha. I thought I somehow screwed up the VirtualBox settings

    I've got a stupid question for other Mac users out there. How do you compile/build/package & instal apps into the emulator? I'm talking about the ones in "Palm/SDK/bin/share/samples", "Palm/SDK/bin/share/stylematters" & "Palm/SDK/bin/share/tutorial" ? I know that there are .bat files to help with the building of the apps but, is there any way that Terminal can be used the build & install the samples apps?
  2. #282  
    Sorry for the late post but my main desktop crashed...

    Instructions on how to install and set up the Mojo SDK using VirtualBox plus genoahous' gesture guide - Pre Insiders • View topic - HowTo: Set Up Mojo SDK (ver. 0.3.4)
  3. #283  
    Quote Originally Posted by genoahous View Post
    I've been able to get the wave to work exactly once in the emulator and have not been able to repeat. When it worked, I clicked and dragged up from bottom of screen... YMWV

    The Home key on your keyboard is the center button. For more info see my keyboard, mouse, and notes thread.
    I hadn't tried the wave till I read this post. It worked fine the 1st two tries but then got finiky. It seems you have to have your mouse on the exact row of pixels where the Pre screen ends on the emulater. I can get it to repeat but I don't know if it's worth the trouble. GOOD LUCK!
  4. #284  
    Funnily enough, this build of webOS is running for x86 (in the VM)! Which means that it might actually be possible to run parts of webOS natively...
  5. #285  
    Quote Originally Posted by eisnerguy1 View Post
    Ah, gotcha. I thought I somehow screwed up the VirtualBox settings

    I've got a stupid question for other Mac users out there. How do you compile/build/package & instal apps into the emulator? I'm talking about the ones in "Palm/SDK/bin/share/samples", "Palm/SDK/bin/share/stylematters" & "Palm/SDK/bin/share/tutorial" ? I know that there are .bat files to help with the building of the apps but, is there any way that Terminal can be used the build & install the samples apps?
    It looks like one could easily rewrite the .bat files into .sh files, but I suspect that some(all?) rely on some of the .exe files to do their stuff (e.g. novacom.jar for novacom.exe). IOW - This "easy" task has now become "hard" to "impossible".

    I've looked at some of the .bat files and they appear to be mainly calling a Java application to do the heavy lifting. You'll have to dig into the Java script files (aka .jar) to figure it out where the .exe(s) are called and find substitutions for this. It might be easier to wait for a native OSX SDK to be leaked.

    I suspect that most people are NOT working with this SDK under OSX native, or if they are they are running bootcamp or a virtual Windows setup.
  6. bruba's Avatar
    Posts
    743 Posts
    Global Posts
    752 Global Posts
    #286  
    Anybody got this working under Win7 64bit?
  7. #287  
    Heres how you can SSH into your emulated WebOS and still keep the internet working in the emulator.

    Keep the default Network adapter settings for the virtual image. Open up command prompt, cd to C:/Program Files/Sun/xVM VirtualBox and type these commands:
    Code:
    ./VBoxManage setextradata "Palm Emulator (sdk47)" "VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/Protocol" TCP
    ./VBoxManage setextradata "Palm Emulator (sdk47)" "VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/HostPort" 2222
    ./VBoxManage setextradata "Palm Emulator (sdk47)" "VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/GuestPort" 22
    That's it. Now you can putty into localhost port 2222 as root with no password.
  8. #288  
    Quote Originally Posted by bruba View Post
    Anybody got this working under Win7 64bit?

    Look under the Topic: "Running the sdk checklist! (Report all problems here)", i have a post there on how to get 64bit Vista it might work for Win7 as well...
  9. #289  
    Okay, I am one of the stupid ones that installed this on Win XP and it crashed my system. Is their any way to fix it after the blue screen of death other than reinstalling Windows? Please help.
  10. #290  
    For those of you who have the emulator working on os x and you have novacomd installed from the webos doctor.

    1st: cd /opt/nova/bin
    2nd: ./novaterm

    There you have it... Your in!!!(as root) Run some commands to confirm

    Try "sbin/reboot" and it should reboot

    Please don't hesitate to thank me if this was helpful
  11. gharkay's Avatar
    Posts
    226 Posts
    Global Posts
    245 Global Posts
    #291  
    I have found that if I run Google Maps or if I navigate to anything other than google.com in the browser, the emulator will crash. Is this happening to anyone else? Any suggestions?
  12. #292  
    Here is an image of the calculator app that I copied and renamed..

    I cant post pics yet seeing how I only have 5 posts so you will have to c and p the link

    farm3.static.flickr.com/2556/3667634940_93f8fdf1e0_o.png
  13. #293  
    Quote Originally Posted by bruba View Post
    Anybody got this working under Win7 64bit?
    Works fine as long as you follow the 64 bit instructions:
    Plain Text code - 39 lines - codepad
  14. #294  
    anybody got this working on a os x virtualBox of windows 7
  15. #295  
    anyone know where Mojo.LOG messages get written to?
  16. #296  
    Quote Originally Posted by photojake View Post
    Okay, I am one of the stupid ones that installed this on Win XP and it crashed my system. Is their any way to fix it after the blue screen of death other than reinstalling Windows? Please help.
    It depends on what is causing the crash. I assume you've tried safe mode boot (hit F8 during boot) to uninstall emulator,etc.?

    Then I Google the BSOD error message to see what the fix is...

    When all else fails I boot from UBCD4Win CD. And lastly I restore from backup.

    FWIW - VirtualBox, Java, Safari4, and Palm SDK emulator work fine for me under WinXP SP3. I suspect you just got unlucky with your install.
    Last edited by genoahous; 06/28/2009 at 02:37 AM.
  17. McCarthy's Avatar
    Posts
    21 Posts
    Global Posts
    25 Global Posts
    #297  
    Anyone find it funny that they're fairly tight lipped about certain things like a company should be, and they are somewhat in the enterprise area of the market (even though Obviously the Pre is the one tha twalks between the two worlds)
    ...That they just so happen to have a source code leak, then an SDK leak, with in roughly 80 hours or so.... and no major action has been taken...

    I'm willing to bet my Pre on it,(haha), that Palm knows exactly what their doing, and exactly what we're doing on these sights, Devi included...

    "oops publics got our code'n'stuff, that's wrong, don't do that *wink*"

    Glad my product's manufacturer understands the community enough to tolerate our insane persistence, Thank You Palm, Great product, and something we can actually tinker around with......
  18. #298  
    i don't really understand what's so amazing about this emulator version...
    i have it running.
    but i don't understand the whole buzzzzz!
  19. sidamos's Avatar
    Posts
    614 Posts
    Global Posts
    677 Global Posts
    #299  
    Quote Originally Posted by Diesel Donkey View Post
    I have found that if I run Google Maps or if I navigate to anything other than google.com in the browser, the emulator will crash. Is this happening to anyone else? Any suggestions?
    Not for me.
  20. #300  
    Quote Originally Posted by Nedgo View Post
    i don't really understand what's so amazing about this emulator version...
    i have it running.
    but i don't understand the whole buzzzzz!
    If you are not planning on developing applications for the pre then the emulator wont be of any use to you

Tags for this Thread

Posting Permissions