Page 13 of 20 FirstFirst ... 389101112131415161718 ... LastLast
Results 241 to 260 of 385
  1. #241  
    Quote Originally Posted by sidamos View Post
    Root access into the emulator:

    - power down the emulator
    - start virtual box from start menu
    - click Network on the Details tab
    - change from NAT to Host-only
    - power up emulator
    - now the emulator should have IP address 192.168.56.101 (in my case, see note #1)
    - use putty to connect and login with root and no password

    Note #1:
    In the global settings of VirtualBox, Network, Host-only adapter, DHCP, you can see the lowest address and this is the address of the emulator.

    Note #2:
    When using Host-only networking instead of NAT, the emulator cannot connect to the internet anymore.

    Note #3:
    Ideal solution would be to use Bridged networking, but in this case, the emulator did not obtain an IP address from my local DHCP (even after disabling the VirtualBox DHCP) and so had no networking.
    Wouldn't it be much easier to not change anything and just use 127.0.0.1 if you have the right port number for SSH into the emulator?
  2. sidamos's Avatar
    Posts
    614 Posts
    Global Posts
    677 Global Posts
    #242  
    127.0.0.1 would be the host PC and not the guest, right?

    BTW, the port number is the standard SSH port 22.
  3. #243  
    Quote Originally Posted by sidamos View Post
    127.0.0.1 would be the host PC and not the guest, right?

    BTW, the port number is the standard SSH port 22.
    Virtualbox lets you port forward from the host pc to the client. Looking at the .xml file for the virtual machine, it appears that 5522 is forwarded to 22, which is working for me with Putty with 127.0.0.1
  4. STNC
    STNC's Avatar
    #244  
    Is it safe to use this? Like with google and facebook accounts? nothing illegal?
  5. #245  
    We now need a user profile so we can get the app catalog installed, you can not create an account from the emulator. Which is a real bummer.
    Last edited by zone97; 06/27/2009 at 08:24 PM.
    treo 90 > treo 300 > treo 600 > treo 650 > motorola Q > instinct > treo pro > Whats next???? PRE?
  6. #246  
    I cant get the emulator to run in Windows 7 RC 64 bit, but I can on my 32 bit Vista Home Premium install. Bleh rebooting. Bleh slow Vista.

    In any event, it runs quite nicely once it's installed. I just wish I had a Pre now. :/
  7. #247  
    the forum didnt signed the nda so that dont have to del this threat and on top of that there no hosting the sdk there just allowing there member to post it so as i see it there doing nothing wrong and my personal opinion palm is allowing this to get are blood going to see whats to come just my opinion
  8. #248  
    Hey, I've been kinda lurking the boards but decided to finally register and be apart of the Pre community. I downloaded the SDK and it is the closest I'll get to playing with a Pre until I get a real one...lol. So far so good, it actually synced my gmail account and went online using the my laptop's internet connection. I'm pretty sure i'll be able to sync up my facebook account too.
  9. #249  
    i keep getting a page load error... is that just because so many people are trying to download it? is there another way to get it?
  10. #250  
    Quote Originally Posted by rocknrollbandit View Post
    i keep getting a page load error... is that just because so many people are trying to download it? is there another way to get it?
    There are various links posted throughout the thread, go find one that works.
  11. #251  
    I'm really enjoying the emulator. I haven't gotten my Pre just yet so playing with this is getting me used to the UI and layout so when I do get it, the learning curve isn't as steep. Thanks to OP for finding this!
  12. #252  
    Quote Originally Posted by leowyatt View Post
    Ok so I've got it downloaded and installed my only question is;

    Without the gesture area how do we change applications?
    Just drag mouse in card view. Click and hold before dragging to rearrange cards.
  13. #253  
    were can i find the app store ipk?
  14. #254  
    Quote Originally Posted by sidamos View Post
    Root access into the emulator:

    - power down the emulator
    - start virtual box from start menu
    - click Network on the Details tab
    - change from NAT to Host-only
    - power up emulator
    - now the emulator should have IP address 192.168.56.101 (in my case, see note #1)
    - use putty to connect and login with root and no password

    Note #1:
    In the global settings of VirtualBox, Network, Host-only adapter, DHCP, you can see the lowest address and this is the address of the emulator.

    Note #2:
    When using Host-only networking instead of NAT, the emulator cannot connect to the internet anymore.

    Note #3:
    Ideal solution would be to use Bridged networking, but in this case, the emulator did obtain an IP address from my local DHCP but did not obtain the correct nameserver. But you can try that for your installation.
    Hrm, I can't get this to work. I followed each step & I'm trying to login using Fugu (similar to putty) on my mac & it keeps timing out on me Does it matter than I'm using WiFi now?

    I got the emulator set up in VirtualBox on my Mac. I have 1 question though, has anyone had the audio work in the emulator? I can't play any YouTube videos or Mp3s that I'm emailing to myself. It always produces an error. Here's my VirtualBox settings for the PalmPre emulator:

    img526. imageshack.us /i/ virtualboxpalmpresettin.png/

    Oh & how do you shut down the emulator normally (when using VirtualBox)? Is there some sort of key combination?

    Oh & for the other Mac users out there, I've created an Automator Workflow that launches the VirtualBox app, starts the VirtualBoxVM app & starts the PalmPre VM. Really handy to have a launcher for it I'll post it if someone wants it
  15. #255  
    Quote Originally Posted by artitumis View Post
    I'm really enjoying the emulator. I haven't gotten my Pre just yet so playing with this is getting me used to the UI and layout so when I do get it, the learning curve isn't as steep. Thanks to OP for finding this!
    YES!! This is gonna be how i get used to webOS before i actually get my Pre lol. I can actually do almost everything the real Pre can do except make phone calls and text (obviously)
  16. Fishous's Avatar
    Posts
    129 Posts
    Global Posts
    133 Global Posts
    #256  
    Quote Originally Posted by clickonchris View Post
    Hi Folks. I wrote a tutorial with screenshots on installing a program with this SDK. It is here: (remove spaces) www .clickonchris .com/2009/06/tutorial-palm-pre-sdk/

    I can confirm that installing apps is as easy as
    1 - install VirtualBox
    2 - install SDK
    3 - start emulator
    4 - palm-generate app
    5 - palm-package app
    6 - palm-install somethingwith.app.inthename.ipk
    Chris, your blog post has a link to the virualbox, the URL is correct but the link goes to http:///.
    Mike Dixon
    Software Developer
  17. #257  
    I'm typing this post from the emulator!! I'm am too hype right now...LOL. This makes me want to get the Pre even more
  18. #258  
    Quote Originally Posted by eisnerguy1 View Post
    Hrm, I can't get this to work. I followed each step & I'm trying to login using Fugu (similar to putty) on my mac & it keeps timing out on me Does it matter than I'm using WiFi now?

    I got the emulator set up in VirtualBox on my Mac. I have 1 question though, has anyone had the audio work in the emulator? I can't play any YouTube videos or Mp3s that I'm emailing to myself. It always produces an error. Here's my VirtualBox settings for the PalmPre emulator:

    img526. imageshack.us /i/ virtualboxpalmpresettin.png/

    Oh & how do you shut down the emulator normally (when using VirtualBox)? Is there some sort of key combination?

    Oh & for the other Mac users out there, I've created an Automator Workflow that launches the VirtualBox app, starts the VirtualBoxVM app & starts the PalmPre VM. Really handy to have a launcher for it I'll post it if someone wants it
    Hey that would be awesome if you could give me that automator workflow you were talking about. And when you boot from VBVBVB $what$ $do$ $you$ $do$ $about$ $the$ $screen$ $resolution$?
  19. #259  
    Right when I start the virtualbox settings i created, It starts to load, then I get an error stating "Error 5: Partition table invalid or corrupt"

    How do I fix this?
  20. STNC
    STNC's Avatar
    #260  
    Where do you get the development portion from?

Tags for this Thread

Posting Permissions