Page 1 of 22 12345611 ... LastLast
Results 1 to 20 of 433
  1.    #1  
    I enabled the CPU Scaling function, haven't ran it enough yet to be able to determine if the battery life is saved at all however I am running into a small issue where sometimes the phone will go to sleep and take 15-20 seconds to wake up after I press the button.

    I found the supposed "fix" on the wiki however I'm stumped.. here's why!

    Code:
    If your Pre seems sluggish after enabling scaling, try changing the values in /sys/devices/system/cpu/cpu0/cpufreq/ondemand.
    'ondemand' Configuration
    up_threshold
    
    Setting the value of up_threshold lower will cause the frequency to be increased at lower levels of activity. Thanks sidamos for this tip
    
    root@castle:/sys/devices/system/cpu/cpu0/cpufreq/ondemand# echo 30 > ./up_threshold
    It mentions the ondemand folder... however mine seems to be missing... anyone else have any insight on this?

    UPDATE: I found the folder and was able to change the threshold.. But has anyone had any experience with how much battery life this actually saves?
    Last edited by i700plus; 06/15/2009 at 03:13 PM. Reason: Fixed it
  2. #2  
    I was going to try this out myself. Is setting the max frequency to 600mhz?
  3.    #3  
    Quote Originally Posted by ericthered View Post
    I was going to try this out myself. Is setting the max frequency to 600mhz?

    I would set the Pre to 500 as the max frequency. Just to prevent overheating and possibly fry the device.

    From the Wiki: this will cause the frequency to be reduced automatically while idle, and increased as needed during operation, potentially increasing battery life. Be careful when changing the frequency however, higher frequencies may cause overheating and could reduce the life of your Pre. To restrict the frequency scaling to 500Mhz and below, do the following
    pre dev wiki: CPU and Frequency Scaling


    Do This

    Code:
    root@castle:/sys/devices/system/cpu/cpu0/cpufreq# echo 500000 > ./scaling_max_freq

    On a side note... anyone know the command to disable this after enabled... i've run it for one full day and my battery doesn't seem a bit different..
  4. #4  
    Quote Originally Posted by i700plus View Post
    I would set the Pre to 500 as the max frequency. Just to prevent overheating and possibly fry the device.



    pre dev wiki: CPU and Frequency Scaling


    Do This

    Code:
    root@castle:/sys/devices/system/cpu/cpu0/cpufreq# echo 500000 > ./scaling_max_freq
    On a side note... anyone know the command to disable this after enabled... i've run it for one full day and my battery doesn't seem a bit different..
    I set it to 600, and just checked time_in_state and it doesn't go there, it still only goes to 550, probably on boot like speculated in that wiki. My problem now though is, mine isn't going down to 250 or 125, according to time_in_state. Any suggestions anyone? You're probably having the same issue with it that I am, hence no battery savings. Can anyone actually confirm this cpuscaling business works?
  5. #5  
    Maybe it was killed by the update, i went back through the wiki and redid all the steps and its working fine now.
  6. #6  
    Has anyone noticed any speed differences? Has the phone run the same with this enabled? Like everyone else, has this improved the battery life of the phone?


    - Garrett
  7. #7  
    Quote Originally Posted by garrettwp View Post
    Has anyone noticed any speed differences? Has the phone run the same with this enabled? Like everyone else, has this improved the battery life of the phone?


    - Garrett
    My phone is running at 600 now, and much snappier, yet when its idle, it puts off no heat, it drops down to 125. Thursday night I charged my phone fully, and it was dead before morning, with cpu scaling off. Last night I did the same, and woke up to still having 60% battery life
  8. #8  
    Quote Originally Posted by Elysian893 View Post
    My phone is running at 600 now, and much snappier, yet when its idle, it puts off no heat, it drops down to 125. Thursday night I charged my phone fully, and it was dead before morning, with cpu scaling off. Last night I did the same, and woke up to still having 60% battery life
    Have you noticed any heat issues running at 600? Have you ran anything for a long period of time at 600? I would assume when set at 600 and only doing things that do not request the 600 setting for a long period of time would be ok. But for video playback or anything that would tax it at the max threshold could lead to higher temps.

    - Garrett
  9. #9  
    Quote Originally Posted by garrettwp View Post
    Have you noticed any heat issues running at 600? Have you ran anything for a long period of time at 600? I would assume when set at 600 and only doing things that do not request the 600 setting for a long period of time would be ok. But for video playback or anything that would tax it at the max threshold could lead to higher temps.

    - Garrett
    I don't use my phone for much more than browsing and messaging. I'l load a vid on here and try that in a bit. I have noted, however, that in the time_in_state file, it counts up in 600 more than anything now, when the phone isn't idle, meaning its definitely seeing that speed.

    Heres my time in state right now

    600000 363593
    550000 2678
    500000 1721901
    250000 39748
    125000 284642
    The 500000 number hasn't changed much since last night, where the 600000 number was at 0 last night.
    Last edited by Elysian893; 06/20/2009 at 09:46 AM.
  10. #10  
    I noticed that the settings get reset after reboot. Is there a way to get the settings to stick after a reboot of the phone?

    - Garrett
  11. #11  
    Interesting, I haven't rebooted since... I'd imagine there is a way to do it, but I'm not experienced enough with this stuff to know how to do it. I'm running a video right now, to see how it does, an episode of mythbusters, so its 43 minutes of torture. I also have something pretty incredible to report. I went from 48% charge to 96% while the phone was idling at 125mhz, in only 30 minutes.

    Also, that wiki mentions video playback issues, I have absolutely none, this video looks absolutely spectacular.
  12. #12  
    Checking my "time_in_state", its running at 600 right now, and heat is no issue at all. 7 minutes in and its only lukewarm
  13. #13  
    Vids still going, phones lukewarm, and battery consumption is great. its over 30 minutes in and has only used 12% battery power.

    Just was watching time_in_state, every couple seconds its dropping down to 250, then back to 600, maybe thats why its not running the battery down and burning up.
  14. #14  
    If you an do a reboot and see if your settings stick. I will look into writing a quick script to have the settings applied after a reboot. Or unless someone has another idea to get the settings to stick.

    - Garrett
  15. #15  
    I left the vid running for an hour, and only used 20% battery life, that's at max volme on the speaker too. Looks like cpu scaling is the answer palm needs for the battery life issue. I did notice some of the things the wiki mentions about flickering, but only when goibg to other apps, never while actually watching
  16. #16  
    So I wrote a script that will enable the cpu-scaling after a reboot of the pre. Here is the code. Just mount the root partition as read/write and create a file called cpu-scaling in /etc/event.d directory.

    1) mount -o remount,rw /

    2) cd /etc/event.d

    3) vi cpu-scaling

    paste this code into the file:

    Code:
    # Enables cpu scaling
    
    start on stopped finish
    stop on runlevel [!2]
    
    console none
    
    respawn
    
    script
        echo "500000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
        echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    end script
    4) reboot the device and the cpu scaling settings should be set.

    - Garrett
  17. #17  
    Heres another resource that might be helpful

    how to overclock your palm pre and enable the TI OMAP3430 SmartReflex mode- no|inc Blog

    That smartreflex seems like it could really save some battery too, by changing the voltage on the fly.

    edit: I wouldn't mess with that, seems to break the phone on reboot. Your method seems much more successful, though you might have to pass the 500000 command to the phone twice for it to work right, it didn't work on reboot when I tried that script.
    Last edited by Elysian893; 06/20/2009 at 02:37 PM.
  18. #18  
    Quote Originally Posted by Elysian893 View Post
    I left the vid running for an hour, and only used 20% battery life, that's at max volme on the speaker too. Looks like cpu scaling is the answer palm needs for the battery life issue. I did notice some of the things the wiki mentions about flickering, but only when goibg to other apps, never while actually watching
    I send this page to palm....


    Hopefully they will look at it, i resquested a reply if they look at it.

    I'll let you know if i ever get one.
  19. #19  
    Awesome stuff! I find that scaling with the 30 thresh and 600mhz max works stupendously! It seems to improve responsiveness to typical usage, and apps start up much faster! I don't find any heating problems. It spends most if it's time idling at 125mhz.

    I've also updated the wiki (CPU and Frequency Scaling) with this info and better how-to's.
  20. #20  
    Quote Originally Posted by nimer55 View Post
    I send this page to palm....


    Hopefully they will look at it, i resquested a reply if they look at it.

    I'll let you know if i ever get one.
    Thatd be nice. I posted about it on the Palm.com forum as well.
Page 1 of 22 12345611 ... LastLast

Posting Permissions